summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-17 08:51:06 +0100
committerSam James <sam@gentoo.org>2023-10-17 08:53:34 +0100
commit7c5d7fefe2750ec21f43663b5808bfad9832e53c (patch)
tree7bdf34897ff02d637398dc23091034e2c1613c69 /sys-block/parted
parentdev-java/felix-main: verify-sig (diff)
downloadgentoo-7c5d7fefe2750ec21f43663b5808bfad9832e53c.tar.gz
gentoo-7c5d7fefe2750ec21f43663b5808bfad9832e53c.tar.bz2
gentoo-7c5d7fefe2750ec21f43663b5808bfad9832e53c.zip
sys-block/parted: fix underlinking with libuuid (util-linux)
This showed up when building libblockdev. Closes: https://bugs.gentoo.org/910487 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block/parted')
-rw-r--r--sys-block/parted/files/parted-3.6-underlinked-util-linux.patch26
-rw-r--r--sys-block/parted/parted-3.6-r1.ebuild82
2 files changed, 108 insertions, 0 deletions
diff --git a/sys-block/parted/files/parted-3.6-underlinked-util-linux.patch b/sys-block/parted/files/parted-3.6-underlinked-util-linux.patch
new file mode 100644
index 000000000000..6e02f4aac8d8
--- /dev/null
+++ b/sys-block/parted/files/parted-3.6-underlinked-util-linux.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/910487
+https://git.savannah.gnu.org/cgit/parted.git/commit/?id=d22c2d01f62139e0d386d90584cac0705857a571
+
+From d22c2d01f62139e0d386d90584cac0705857a571 Mon Sep 17 00:00:00 2001
+From: Yegor Yefremov <yegorslists@googlemail.com>
+Date: Thu, 11 May 2023 10:03:59 +0200
+Subject: parted: link to libuuid
+
+parted.c uses libuuid since 61b3a9733c0e0a79ccc43096642d378c8706add6.
+Hence, add UUID_LIBS to PARTED_LIBS to avoid
+"DSO missing from command line" error.
+
+Signed-off-by: Brian C. Lane <bcl@redhat.com>
+--- a/configure.ac
++++ b/configure.ac
+@@ -298,6 +298,8 @@ Note: originally, libuuid was part of the e2fsprogs package. Later, it
+ moved to util-linux-ng-2.16, and that package is now the preferred source.])])
+ AC_SUBST([UUID_LIBS])
+
++PARTED_LIBS="$PARTED_LIBS $UUID_LIBS"
++
+ dnl Check for libdevmapper
+ DM_LIBS=
+ if test $ENABLE_DEVICE_MAPPER = yes; then
+--
+cgit v1.1
diff --git a/sys-block/parted/parted-3.6-r1.ebuild b/sys-block/parted/parted-3.6-r1.ebuild
new file mode 100644
index 000000000000..63d57a749b91
--- /dev/null
+++ b/sys-block/parted/parted-3.6-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/bcl.asc
+
+inherit autotools verify-sig
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="https://www.gnu.org/software/parted/"
+SRC_URI="
+ mirror://gnu/${PN}/${P}.tar.xz
+ verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+debug device-mapper nls readline"
+
+# util-linux for libuuid
+RDEPEND="
+ >=sys-fs/e2fsprogs-1.27
+ sys-apps/util-linux
+ device-mapper? ( >=sys-fs/lvm2-2.02.45 )
+ readline? (
+ >=sys-libs/ncurses-5.7-r7:0=
+ >=sys-libs/readline-5.2:0=
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( >=sys-devel/gettext-0.12.1-r2 )
+ verify-sig? ( >=sec-keys/openpgp-keys-bcl-20230315 )
+ virtual/pkgconfig
+"
+
+DOCS=(
+ AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp}
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch
+ "${FILESDIR}"/${PN}-3.3-atari.patch
+ # https://lists.gnu.org/archive/html/bug-parted/2022-02/msg00000.html
+ "${FILESDIR}"/${PN}-3.4-posix-printf.patch
+ # https://debbugs.gnu.org/61129
+ "${FILESDIR}"/${PN}-3.6-tests-unicode.patch
+ # https://debbugs.gnu.org/61128
+ "${FILESDIR}"/${PN}-3.6-tests-non-bash.patch
+ # bug #910487
+ "${FILESDIR}"/${P}-underlinked-util-linux.patch
+)
+
+# false positive
+QA_CONFIG_IMPL_DECL_SKIP="MIN"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ touch doc/pt_BR/Makefile.in || die
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug)
+ $(use_enable device-mapper)
+ $(use_enable nls)
+ $(use_with readline)
+ --disable-rpath
+ --disable-static
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}