summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-10-10 06:01:34 +0200
committerJeroen Roovers <jer@gentoo.org>2015-10-10 06:01:34 +0200
commit3a1036332df73333e2b01d5e6fedd91dad7415de (patch)
tree2cc8dcfd5dc14e4f9c74af02840a333c74ee3b91 /sys-block/parted/parted-3.2-r1.ebuild
parentdev-php/PEAR-DB_DataObject: Stable for PPC64 (bug #546654). (diff)
downloadgentoo-3a1036332df73333e2b01d5e6fedd91dad7415de.tar.gz
gentoo-3a1036332df73333e2b01d5e6fedd91dad7415de.tar.bz2
gentoo-3a1036332df73333e2b01d5e6fedd91dad7415de.zip
sys-block/parted: Fix crash on resizing FAT16 (bug #562136 by Nico R.).
Package-Manager: portage-2.2.22
Diffstat (limited to 'sys-block/parted/parted-3.2-r1.ebuild')
-rw-r--r--sys-block/parted/parted-3.2-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-block/parted/parted-3.2-r1.ebuild b/sys-block/parted/parted-3.2-r1.ebuild
new file mode 100644
index 000000000000..e48c62046256
--- /dev/null
+++ b/sys-block/parted/parted-3.2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="https://www.gnu.org/software/parted"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+debug device-mapper nls readline selinux static-libs"
+RESTRICT="test"
+
+# specific version for gettext needed
+# to fix bug 85999
+RDEPEND="
+ >=sys-fs/e2fsprogs-1.27
+ >=sys-libs/ncurses-5.7-r7:0=
+ device-mapper? ( >=sys-fs/lvm2-2.02.45 )
+ readline? ( >=sys-libs/readline-5.2:0= )
+ selinux? ( sys-libs/libselinux )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.12.1-r2 )
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-3.2-devmapper.patch \
+ "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch \
+ "${FILESDIR}"/${PN}-3.2-fix-resizing-FAT16.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable device-mapper) \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ $(use_enable static-libs static) \
+ $(use_with readline) \
+ --disable-rpath \
+ --disable-silent-rules
+}
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp} )
+
+src_install() {
+ default
+ prune_libtool_files
+}