summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-03-04 11:33:03 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-03-04 11:54:10 +0100
commitec8ef0d2ca1f65776491d39a3fa7213de18d2709 (patch)
tree3ba3c74b83134e80a8b0b8c4fa56c90737dbb47f /sys-block/open-isns
parentnet-misc/ntp: Removed old (diff)
downloadgentoo-ec8ef0d2ca1f65776491d39a3fa7213de18d2709.tar.gz
gentoo-ec8ef0d2ca1f65776491d39a3fa7213de18d2709.tar.bz2
gentoo-ec8ef0d2ca1f65776491d39a3fa7213de18d2709.zip
sys-block/open-isns: Bump to version 0.100
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-block/open-isns')
-rw-r--r--sys-block/open-isns/Manifest1
-rw-r--r--sys-block/open-isns/files/open-isns-0.100-no_Werror.patch41
-rw-r--r--sys-block/open-isns/open-isns-0.100.ebuild56
3 files changed, 98 insertions, 0 deletions
diff --git a/sys-block/open-isns/Manifest b/sys-block/open-isns/Manifest
index 6914def7947f..c5a7214517f9 100644
--- a/sys-block/open-isns/Manifest
+++ b/sys-block/open-isns/Manifest
@@ -1,3 +1,4 @@
+DIST open-isns-0.100.tar.gz 300611 BLAKE2B a40e8d2bd6e5ac8ed8475d3d50ed6256871134547a044a6b51102ad47c66c335f06372b29e5585df4e59ecd7a817e5f2e48c5e944eea31333ab9f45d51040306 SHA512 ccf49ba1c60d46ae49b75424a966abc1f7e104c8ffa13013951a58a8f0ccaa1cf550f24fd2743fcaba1211a0ec8033c5df5249b7a108ae5974d4f1144dd3b169
DIST open-isns-0.97.tar.gz 278317 BLAKE2B 7083b3ebef78a5afb35e8cc31e86674b407eb48224139745142238f559e95ceca8755e570031559bdf29ec691947693303e07b8f81b915a3b7f2396329bbd2b3 SHA512 78c934162d5a1d093bccd49449d4ef369b896d34309d76b4963d643a699640617c4fe064388c481c35b9be26e012f19713f3aad378af9ad88fa94c3d300e919d
DIST open-isns-0.98.tar.gz 278410 BLAKE2B f90df85de4d5fd2abdcd267e3c873dff62fcac523ee280e21def057eca366bbba21c2b3bfbf5cc0798b8d0f3b0d5028ebb49000cccc850abdfb85142a7b66c34 SHA512 04263b9ace9d272f4e3776c4e1a034815475590d4b4864217a6200fcd5baea391cd788723db3c17fe0d764efc9769a70a3d2167b00e5998fb4bcb8d5fe2547ed
DIST open-isns-0.99.tar.gz 282831 BLAKE2B 7140daf08fda894bcbed3e25b122909ad0ed86b4f3db2e42a23b97480dea554194d2a33a3ebdf4e2017a57c2023dd8589f2e2fcfa60470cc3a6a3fbfb0d0ccbc SHA512 90a2297535c5e939f83c761173ce5f5f88e68adc31e41e833b23d07b6dc6959572ae7184db0084b861918199a877b251ebae4b4a7456fdd8c93400dc8457adc9
diff --git a/sys-block/open-isns/files/open-isns-0.100-no_Werror.patch b/sys-block/open-isns/files/open-isns-0.100-no_Werror.patch
new file mode 100644
index 000000000000..2d966dd3a4fd
--- /dev/null
+++ b/sys-block/open-isns/files/open-isns-0.100-no_Werror.patch
@@ -0,0 +1,41 @@
+From 40eb9ce75518817762a0eac4a93016ab817add89 Mon Sep 17 00:00:00 2001
+From: Lee Duncan <lduncan@suse.com>
+Date: Sat, 1 Feb 2020 10:23:04 -0800
+Subject: [PATCH] Fix 586 compile issue and remove -Werror
+
+Using -Werror causes any issue to break the build, whereas
+I'd rather let the build continue and address the issue.
+
+Also, fixed one signed-vs-unsigned compare for time_t, which
+shows up only on 586 (32-bit).
+---
+ configure.ac | 2 +-
+ isnsdd.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index e4f3995..d956e58 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -17,7 +17,7 @@ AC_PATH_PROG(SH, sh)
+ dnl C Compiler features
+ AC_C_INLINE
+ if test "$GCC" = "yes"; then
+- CFLAGS="-Wall -Werror -Wextra $CFLAGS"
++ CFLAGS="-Wall -Wextra $CFLAGS"
+ CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE"
+ fi
+
+diff --git a/isnsdd.c b/isnsdd.c
+index 58825cc..9cedb9f 100644
+--- a/isnsdd.c
++++ b/isnsdd.c
+@@ -401,7 +401,7 @@ check_portal_registration(__attribute__((unused))void *ptr)
+ continue;
+
+ last_modified = isns_object_last_modified(obj);
+- if (last_modified + 2 * interval > now) {
++ if ((time_t)(last_modified + 2 * interval) > now) {
+ good_portals++;
+ continue;
+ }
diff --git a/sys-block/open-isns/open-isns-0.100.ebuild b/sys-block/open-isns/open-isns-0.100.ebuild
new file mode 100644
index 000000000000..878669c9073a
--- /dev/null
+++ b/sys-block/open-isns/open-isns-0.100.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="iSNS server and client for Linux"
+HOMEPAGE="https://github.com/open-iscsi/open-isns"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug libressl ssl static"
+
+DEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.98-libressl-compatibility.patch"
+
+ # Upstream patches (can usually be removed with next version bump)
+ "${FILESDIR}"/${P}-no_Werror.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI
+ append-lfs-flags
+ local myeconfargs=(
+ --without-slp
+ $(use_with ssl security)
+ $(use_enable !static shared)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install_hdrs
+ emake DESTDIR="${D}" install_lib
+ keepdir /var/lib/${PN/open-}
+ if ! use static ; then
+ find "${ED}" -type f -name "*.a" -delete || die
+ fi
+}