summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-01-16 22:46:12 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-01-16 22:48:33 -0800
commitdf63e44213f1c472330b7f7ddf889560e8f81247 (patch)
treeb86ce34290083f9ab13771ae181424720cb535ea /sys-block/lsiutil/lsiutil-1.62-r2.ebuild
parentmetadata: anchor projects.xml gitignore. (diff)
downloadgentoo-df63e44213f1c472330b7f7ddf889560e8f81247.tar.gz
gentoo-df63e44213f1c472330b7f7ddf889560e8f81247.tar.bz2
gentoo-df63e44213f1c472330b7f7ddf889560e8f81247.zip
sys-block/lsiutil: update for LSI->Avago company switch, upstream also no longer enforces a EULA and direct download is possible.
Package-Manager: portage-2.2.24
Diffstat (limited to 'sys-block/lsiutil/lsiutil-1.62-r2.ebuild')
-rw-r--r--sys-block/lsiutil/lsiutil-1.62-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-block/lsiutil/lsiutil-1.62-r2.ebuild b/sys-block/lsiutil/lsiutil-1.62-r2.ebuild
new file mode 100644
index 000000000000..210998dff6b2
--- /dev/null
+++ b/sys-block/lsiutil/lsiutil-1.62-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="LSI Logic Fusion MPT Command Line Interface management tool"
+HOMEPAGE="http://www.avagotech.com/"
+SRC_URI="http://docs.avagotech.com/docs-and-downloads/legacy-host-bus-adapters/legacy-host-bus-adapters-common-files/LSIUtil_${PV/./-}.zip"
+
+LICENSE="LSI"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+RESTRICT="mirror bindist"
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+QA_PRESTRIPPED="/opt/bin/lsiutil"
+
+S="${WORKDIR}"
+
+src_install() {
+ exeinto /opt/bin
+
+ if use x86; then
+ doexe Linux/lsiutil || die
+ elif use amd64; then
+ newexe Linux/lsiutil.x86_64 lsiutil || die
+ elif use ia64; then
+ newexe Linux/lsiutil.ia64 lsiutil || die
+ fi
+
+ dodoc changes.txt
+}