summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-03-13 22:53:24 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-03-13 22:53:24 +0300
commit8d60cfcb834ae457910f393d59d9f3eb2835f19b (patch)
treedd69bc21933c4b5bd6bebacde100c717d82f8ef8 /sys-auth/passwdqc
parentapp-admin/gopass: Drop old (diff)
downloadgentoo-8d60cfcb834ae457910f393d59d9f3eb2835f19b.tar.gz
gentoo-8d60cfcb834ae457910f393d59d9f3eb2835f19b.tar.bz2
gentoo-8d60cfcb834ae457910f393d59d9f3eb2835f19b.zip
sys-auth/passwdqc: Version bump (v2.0.1)
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-auth/passwdqc')
-rw-r--r--sys-auth/passwdqc/Manifest1
-rw-r--r--sys-auth/passwdqc/passwdqc-2.0.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-auth/passwdqc/Manifest b/sys-auth/passwdqc/Manifest
index bfba630bb160..974337dbd889 100644
--- a/sys-auth/passwdqc/Manifest
+++ b/sys-auth/passwdqc/Manifest
@@ -1,2 +1,3 @@
DIST passwdqc-1.4.0.tar.gz 55219 BLAKE2B 3f96a2d219ee23f11db2ad8ba433eaa56b97a263ad1a49159e0356b779cb4486ec9aa74cd7002fdd6d273e5a7bae4fe1b94e02f60256d331e5afc30d63e81360 SHA512 b9be6632688a1d7d929ec546679a366a67d44e7841e106c7f739a8e0656842866125160c87b04c8e0b3189a3e85eb182aa789196f68925b2f8ec71cd6a479800
DIST passwdqc-2.0.0.tar.gz 86235 BLAKE2B fa67007ca0477feafd8743eda0899b7e348bf75e00e7ff23b6acdf56a456d75bec89a4b7dead41d7889610669425ff0145d6e7c94db0ce93219de0c5c0b80909 SHA512 7e5c0a32361d604c47ad02f36beff3287f638f2911b398a21b89cea164bf9a161b3bc252e9c660eaa53c5e5fce458d1cb1fd6b2bb308bafdb729c9d7e67f5295
+DIST passwdqc-2.0.1.tar.gz 87804 BLAKE2B 0fbbe4dbb68104fb94dbb0a3a84759d2ad5ec3e8fb285a12534b0465e5c3ed4084e879f9322dbd26071338f4e39b01b3e42337e933bee921600e3a32f00069b8 SHA512 95d10099634dd15d2e93249b37e1d2727922fdeac9993ddb63b6c3f8ff39377c02fce0e0a77d120aed868d3a2cb51972eed4cf84f5ddcec8488f60e9769d4263
diff --git a/sys-auth/passwdqc/passwdqc-2.0.1.ebuild b/sys-auth/passwdqc/passwdqc-2.0.1.ebuild
new file mode 100644
index 000000000000..53fea839ad89
--- /dev/null
+++ b/sys-auth/passwdqc/passwdqc-2.0.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pam toolchain-funcs
+
+DESCRIPTION="Password strength checking library (and PAM module)"
+HOMEPAGE="http://www.openwall.com/passwdqc/"
+SRC_URI="http://www.openwall.com/${PN}/${P}.tar.gz"
+
+LICENSE="Openwall BSD public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sys-libs/pam"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ QA_FLAGS_IGNORED="/$(get_libdir)/security/pam_passwdqc.so
+ /usr/$(get_libdir)/libpasswdqc.so.1"
+}
+
+src_prepare() {
+ default
+ sed -i -e 's:`uname -s`:Linux:' Makefile || die
+
+ # ship our own default settings
+ cat <<- EOF > "${S}/passwdqc.conf"
+ min=8,8,8,8,8
+ max=40
+ passphrase=3
+ match=4
+ similar=deny
+ random=47
+ enforce=everyone
+ retry=3
+ EOF
+
+}
+
+_emake() {
+ emake -j1 \
+ SHARED_LIBDIR="/usr/$(get_libdir)" \
+ SECUREDIR="$(getpam_mod_dir)" \
+ CONFDIR="/etc/security" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ "$@"
+}
+
+src_compile() {
+ _emake pam utils
+}
+
+src_install() {
+ _emake DESTDIR="${ED}" install_lib install_pam install_utils
+ dodoc README PLATFORMS INTERNALS
+}