summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-07-21 16:48:17 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-07-21 17:02:41 +0200
commit157db3d9f2492e8c0ac454fc0d445124350d66f7 (patch)
treee9848b26fa618ca47235cef3bf7b03667f617ed8 /sys-apps
parentsys-apps/cpuid: drop 20240409 (diff)
downloadgentoo-157db3d9f2492e8c0ac454fc0d445124350d66f7.tar.gz
gentoo-157db3d9f2492e8c0ac454fc0d445124350d66f7.tar.bz2
gentoo-157db3d9f2492e8c0ac454fc0d445124350d66f7.zip
sys-apps/cpuid: add 20240716
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20240716.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index 660ec7261ace..182c258c077d 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1 +1,2 @@
DIST cpuid-20240709.src.tar.gz 156034 BLAKE2B c7487a0b9a21593d32df4a2eb42bf4deb7a357155d1dd28ec3d485349b7a3164f5a7c3ecb3b65c1c88c5c1a9132d158a33568d6f5d9398e0b8a75c54dd86f824 SHA512 c89d6d9a332c80a78698f3862dbb0e17df793b389ae6d522c9c68cb2818b932d7653f7c8d7e5344918b7e93f944c8f7ea02276148df4f25b720d4561fc6698ed
+DIST cpuid-20240716.src.tar.gz 155562 BLAKE2B 52625a547c70b7fd45d63fea88acfcc938443f1f53c686896f88ef193240b7b9ea76020a48b187689c27fddad4cba8cdd41044ab57f731e488af14fd1a608fa3 SHA512 1efbd3f98253700d2948573025733fb7a3354d008b968c83078d36ddac834c4adae4eeef288214066ad520d23fa1eb0ea2036f878cde20d982a1810e7305b7a4
diff --git a/sys-apps/cpuid/cpuid-20240716.ebuild b/sys-apps/cpuid/cpuid-20240716.ebuild
new file mode 100644
index 000000000000..c2868c0d5525
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20240716.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}