summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-03-29 14:23:54 +0000
committerMarek Szuba <marecki@gentoo.org>2024-03-29 14:24:55 +0000
commit1186f2046dd460413a7b2cf97a67fc137fb0ef85 (patch)
treefa65097b25da3cadaafaf8563906ea1393a05da2 /sys-apps
parentapp-forensics/radamsa: add 0.7 (diff)
downloadgentoo-1186f2046dd460413a7b2cf97a67fc137fb0ef85.tar.gz
gentoo-1186f2046dd460413a7b2cf97a67fc137fb0ef85.tar.bz2
gentoo-1186f2046dd460413a7b2cf97a67fc137fb0ef85.zip
sys-apps/gptfdisk: add 1.0.10
Closes: https://bugs.gentoo.org/926949 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gptfdisk/Manifest1
-rw-r--r--sys-apps/gptfdisk/gptfdisk-1.0.10.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/gptfdisk/Manifest b/sys-apps/gptfdisk/Manifest
index 6c36fd5ef132..50e5811b14e5 100644
--- a/sys-apps/gptfdisk/Manifest
+++ b/sys-apps/gptfdisk/Manifest
@@ -1 +1,2 @@
+DIST gptfdisk-1.0.10.tar.gz 220787 BLAKE2B 9047bf68a2c5c254bda9b2815488963dc19a9415c90fbf4a127268a37fe8a545b7d45a333e356bd9da22e37ef649d9f60896ffedfdc35b60c7642a48e4ed2e5a SHA512 76764e176cd92470648a1d7a8d2570ebc41005204e73b0f2dd5a7aff2fc1981d3bec61a3bd68b855cc3474bcb7cf49c1cb2ea25843d4e7945bef7648d548383d
DIST gptfdisk-1.0.9.tar.gz 215065 BLAKE2B 1939ffd75972a4d7f92af2bfab90c7b0223825b5478b6b808dd35af943c687d38ba81663cd7ba5e0f9400656db4dac019c13a9f75d90b7bd716568c676c24dd2 SHA512 c2489ac7e196cb53b9fdb18d0e421571eca43c366de8922c5c7f550aadf192558e7af69b181c30747d6cf607c1670126223465eaa5e231cc589402d94a4e97a2
diff --git a/sys-apps/gptfdisk/gptfdisk-1.0.10.ebuild b/sys-apps/gptfdisk/gptfdisk-1.0.10.ebuild
new file mode 100644
index 000000000000..980f14022408
--- /dev/null
+++ b/sys-apps/gptfdisk/gptfdisk-1.0.10.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="GPT partition table manipulator for Linux"
+HOMEPAGE="https://www.rodsbooks.com/gdisk/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="ncurses static"
+
+# libuuid from util-linux is required.
+RDEPEND="!static? (
+ dev-libs/popt
+ ncurses? ( sys-libs/ncurses:=[unicode(+)] )
+ kernel_linux? ( sys-apps/util-linux )
+ )"
+DEPEND="
+ ${RDEPEND}
+ static? (
+ dev-libs/popt[static-libs(+)]
+ ncurses? ( sys-libs/ncurses:=[unicode(+),static-libs(+)] )
+ kernel_linux? ( sys-apps/util-linux[static-libs(+)] )
+ )
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.9-build_flags.patch
+)
+
+src_prepare() {
+ default
+
+ tc-export CXX PKG_CONFIG
+
+ if ! use ncurses ; then
+ sed -i \
+ -e '/^all:/s: cgdisk::' \
+ Makefile || die
+ fi
+
+ sed \
+ -e '/g++/s:=:?=:g' \
+ -e 's:-lncursesw:$(shell $(PKG_CONFIG) --libs ncursesw):g' \
+ -i Makefile || die
+
+ use static && append-ldflags -static
+}
+
+src_install() {
+ dosbin gdisk sgdisk $(usex ncurses cgdisk '') fixparts
+ doman *.8
+ dodoc NEWS README
+}