summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-08-07 00:49:18 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-08-07 00:49:18 +0200
commit3fa4968f695f64a25f377df779c8e7c039c30843 (patch)
tree7d94b9f1fc69f957f8aeae8cfd888c548b3056ea /sys-apps/usbutils
parentsys-libs/glibc: Run compiler tests only when compiling (diff)
downloadgentoo-3fa4968f695f64a25f377df779c8e7c039c30843.tar.gz
gentoo-3fa4968f695f64a25f377df779c8e7c039c30843.tar.bz2
gentoo-3fa4968f695f64a25f377df779c8e7c039c30843.zip
sys-apps/usbutils: Bump to version 014
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/usbutils')
-rw-r--r--sys-apps/usbutils/Manifest1
-rw-r--r--sys-apps/usbutils/usbutils-014.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sys-apps/usbutils/Manifest b/sys-apps/usbutils/Manifest
index 347c2dfffd7c..91d8db1aaa15 100644
--- a/sys-apps/usbutils/Manifest
+++ b/sys-apps/usbutils/Manifest
@@ -1 +1,2 @@
DIST usbutils-013.tar.xz 98056 BLAKE2B d6e7925e180ba90f27ca12f13ed985f34e51b230ec08188c91bf39bb8e64baa319aa63d473318e1a4cb21b53808e8610f837ea0bb85657072f1c70107d037873 SHA512 eb1751e5b82f7a1bdffc667662cebee6fd42f466e59d4eb4c98f0d3723d740305377da1df1ba5831402fddbbd1697bbfa2abd22d9ed175e2dee55d6d007e9e54
+DIST usbutils-014.tar.xz 165884 BLAKE2B aea4f8edd3c7d7bc400fd63a8702b6d0bb50b8ed07196c4a0ed20a615eacf6373794afb9e7d5d81408dc3382848e965ecf8bc1bbec20837e4d1f96ba47cc40b5 SHA512 43c9f6ed14f8d01e014ef39a5d50b3b09031c6bda8261e0945b4cb4287c9107104175b386c2adc61dc7f9f476afb30f9a647a6ece6dee26b4133a4f10af72792
diff --git a/sys-apps/usbutils/usbutils-014.ebuild b/sys-apps/usbutils/usbutils-014.ebuild
new file mode 100644
index 000000000000..c92094e848bd
--- /dev/null
+++ b/sys-apps/usbutils/usbutils-014.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="USB enumeration utilities"
+HOMEPAGE="https://www.kernel.org/pub/linux/utils/usb/usbutils/
+ https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usbutils.git/"
+SRC_URI="https://www.kernel.org/pub/linux/utils/usb/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="virtual/libusb:1=
+ virtual/libudev:="
+BDEPEND="
+ app-arch/xz-utils
+ virtual/pkgconfig"
+RDEPEND="${DEPEND}
+ sys-apps/hwids
+ python? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+ use python && python_fix_shebang lsusb.py.in
+}
+
+src_configure() {
+ local myeconfargs=(
+ --datarootdir="${EPREFIX}/usr/share"
+ --datadir="${EPREFIX}/usr/share/misc"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ newdoc usbhid-dump/NEWS NEWS.usbhid-dump
+ dobin usbreset # noinst_PROGRAMS, but installed by other distros
+
+ use python || rm -f "${ED}"/usr/bin/lsusb.py
+}