summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-11-19 17:34:55 -0800
committerZac Medico <zmedico@gentoo.org>2017-11-19 17:47:23 -0800
commitf56e082cc2c2960031a34bb45c801ad23465bab8 (patch)
treeb2b1e74e5b1a3deadbfaee9c555f788b2246bf58 /sys-apps/portage
parentdev-util/kdevelop-python: 5.2.0 version bump (diff)
downloadgentoo-f56e082cc2c2960031a34bb45c801ad23465bab8.tar.gz
gentoo-f56e082cc2c2960031a34bb45c801ad23465bab8.tar.bz2
gentoo-f56e082cc2c2960031a34bb45c801ad23465bab8.zip
sys-apps/portage: fix -r1 htmldir (bug 638046)
Closes: https://bugs.gentoo.org/638046 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'sys-apps/portage')
-rw-r--r--sys-apps/portage/portage-2.3.13-r1.ebuild14
-rw-r--r--sys-apps/portage/portage-2.3.14.ebuild14
-rw-r--r--sys-apps/portage/portage-9999.ebuild10
3 files changed, 32 insertions, 6 deletions
diff --git a/sys-apps/portage/portage-2.3.13-r1.ebuild b/sys-apps/portage/portage-2.3.13-r1.ebuild
index b4ff41814d5f..9cd003779737 100644
--- a/sys-apps/portage/portage-2.3.13-r1.ebuild
+++ b/sys-apps/portage/portage-2.3.13-r1.ebuild
@@ -87,6 +87,10 @@ pkg_setup() {
python_prepare_all() {
distutils-r1_python_prepare_all
+ sed -e "s|user_options = install_data.user_options$|\0 + [\n\
+ ('htmldir=', None, 'HTML documentation install directory')]|" -i \
+ setup.py || die #638046
+
if use native-extensions; then
printf "[build_ext]\nportage-ext-modules=true\n" >> \
setup.cfg || die
@@ -189,8 +193,14 @@ python_install_all() {
distutils-r1_python_install_all
local targets=()
- use doc && targets+=( install_docbook )
- use epydoc && targets+=( install_epydoc )
+ use doc && targets+=(
+ install_docbook
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ use epydoc && targets+=(
+ install_epydoc
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
# install docs
if [[ ${targets[@]} ]]; then
diff --git a/sys-apps/portage/portage-2.3.14.ebuild b/sys-apps/portage/portage-2.3.14.ebuild
index 7ee7d2c75f30..e0d4b1ef1b38 100644
--- a/sys-apps/portage/portage-2.3.14.ebuild
+++ b/sys-apps/portage/portage-2.3.14.ebuild
@@ -87,6 +87,10 @@ pkg_setup() {
python_prepare_all() {
distutils-r1_python_prepare_all
+ sed -e "s|user_options = install_data.user_options$|\0 + [\n\
+ ('htmldir=', None, 'HTML documentation install directory')]|" -i \
+ setup.py || die #638046
+
if use native-extensions; then
printf "[build_ext]\nportage-ext-modules=true\n" >> \
setup.cfg || die
@@ -189,8 +193,14 @@ python_install_all() {
distutils-r1_python_install_all
local targets=()
- use doc && targets+=( install_docbook )
- use epydoc && targets+=( install_epydoc )
+ use doc && targets+=(
+ install_docbook
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ use epydoc && targets+=(
+ install_epydoc
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
# install docs
if [[ ${targets[@]} ]]; then
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index c7453d27b016..adb4f2b5bde8 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -188,8 +188,14 @@ python_install_all() {
distutils-r1_python_install_all
local targets=()
- use doc && targets+=( install_docbook )
- use epydoc && targets+=( install_epydoc )
+ use doc && targets+=(
+ install_docbook
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ use epydoc && targets+=(
+ install_epydoc
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
# install docs
if [[ ${targets[@]} ]]; then