summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-30 00:50:25 +0100
committerSam James <sam@gentoo.org>2023-09-30 00:50:25 +0100
commitc3d5d6f6277e862fce7df5c63632a6030e97d23a (patch)
treebfc190f890f9786ccd0d3903ed7808f091480442 /sys-apps/moar
parentsys-apps/moar: drop 1.15.3, 1.15.4, 1.16.0, 1.16.1 (diff)
downloadgentoo-c3d5d6f6277e862fce7df5c63632a6030e97d23a.tar.gz
gentoo-c3d5d6f6277e862fce7df5c63632a6030e97d23a.tar.bz2
gentoo-c3d5d6f6277e862fce7df5c63632a6030e97d23a.zip
sys-apps/moar: add 1.17.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/moar')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.17.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index 433b4da24b6b..7069981538cf 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -1,2 +1,4 @@
DIST moar-1.16.2-deps.tar.xz 4760036 BLAKE2B 6fd72d710a620fdf104766be84f3fa68652c760818cdee66bb8475cc8949872c82be026c04b54cb61c0108c5977cb1f787f9a4fa0316bde0293cdedb1f6f94f8 SHA512 f40520a1b2e94f4a3e97d6a4e19191484b66e13a57c7b30416c813d84cad3d29295e862d5b75870313cc905112425c731d052619d49e78b33fb3d5d8750df3df
DIST moar-1.16.2.tar.gz 2782878 BLAKE2B f713e13f9729ab6fb17a1f297551b765ee4a19d1fd7ae2da949d489a37fb2e91c0958cfe4ce4c4a57339dedadc1b77d276464a87522ede1c451cc906ed9a4d51 SHA512 934696264082d72b202339d2b30b0f382cb7ef7a1b3985d5fb23f8dd81306c657c4bd24c59c1338a090a56ae2af53dc0d576f2c482b33f782f27434add50b222
+DIST moar-1.17.0-deps.tar.xz 4760036 BLAKE2B 6fd72d710a620fdf104766be84f3fa68652c760818cdee66bb8475cc8949872c82be026c04b54cb61c0108c5977cb1f787f9a4fa0316bde0293cdedb1f6f94f8 SHA512 f40520a1b2e94f4a3e97d6a4e19191484b66e13a57c7b30416c813d84cad3d29295e862d5b75870313cc905112425c731d052619d49e78b33fb3d5d8750df3df
+DIST moar-1.17.0.tar.gz 2784572 BLAKE2B 56af0ca6df83e21e6844908230f0283fd42238cfa54b05b1ee5df055241b5cab54e502f0f588a8531b796b31bcbbce65ab8655b8aa8cae8b766812733d6a00f6 SHA512 280ce7adefbc8f6aa403f77c0e1261456dd53a23e0e9874ace0885b7d08698d012a901eabc3c3c14bd3387b69d55c98fec1d650c769b8cf469040fb029eefd73
diff --git a/sys-apps/moar/moar-1.17.0.ebuild b/sys-apps/moar/moar-1.17.0.ebuild
new file mode 100644
index 000000000000..091d314e2ac3
--- /dev/null
+++ b/sys-apps/moar/moar-1.17.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}