summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/lcdutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/lcdutils')
-rw-r--r--sys-apps/lcdutils/Manifest1
-rw-r--r--sys-apps/lcdutils/files/include-stdlib.h-for-exit.patch50
-rw-r--r--sys-apps/lcdutils/lcdutils-0.2.ebuild34
-rw-r--r--sys-apps/lcdutils/metadata.xml14
4 files changed, 99 insertions, 0 deletions
diff --git a/sys-apps/lcdutils/Manifest b/sys-apps/lcdutils/Manifest
new file mode 100644
index 000000000000..0da28332cf3b
--- /dev/null
+++ b/sys-apps/lcdutils/Manifest
@@ -0,0 +1 @@
+DIST lcdutils-0.2.tar.gz 10819 RMD160 6b746cb6616875340054017154400e50b7a423cb SHA1 fb516d07fb868de5642a0aa4696fdeffc6fe480f SHA256 fae6efe705f18fa5cf0b0ecb41ec8d3e009db18d9fcda838e23a1f455d3f2f58
diff --git a/sys-apps/lcdutils/files/include-stdlib.h-for-exit.patch b/sys-apps/lcdutils/files/include-stdlib.h-for-exit.patch
new file mode 100644
index 000000000000..81870496a529
--- /dev/null
+++ b/sys-apps/lcdutils/files/include-stdlib.h-for-exit.patch
@@ -0,0 +1,50 @@
+From 304013f4c81a13fa2aa3a06628e6a1c57248563c Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Mon, 13 Jun 2011 23:42:44 -0400
+Subject: [PATCH] include stdlib.h for exit
+
+---
+ buttond.c | 1 +
+ liblcd.c | 1 +
+ putlcd.c | 1 +
+ 3 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/buttond.c b/buttond.c
+index e99b0dd..40a85ae 100644
+--- a/buttond.c
++++ b/buttond.c
+@@ -16,6 +16,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include <stdlib.h>
+ #include <string.h>
+ #include <time.h>
+ #include <unistd.h>
+diff --git a/liblcd.c b/liblcd.c
+index e8fcacf..39bceea 100644
+--- a/liblcd.c
++++ b/liblcd.c
+@@ -16,6 +16,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include <stdlib.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+diff --git a/putlcd.c b/putlcd.c
+index c193712..18dc0af 100644
+--- a/putlcd.c
++++ b/putlcd.c
+@@ -16,6 +16,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include "liblcd.h"
+--
+1.7.3.4
+
diff --git a/sys-apps/lcdutils/lcdutils-0.2.ebuild b/sys-apps/lcdutils/lcdutils-0.2.ebuild
new file mode 100644
index 000000000000..35129fdf3922
--- /dev/null
+++ b/sys-apps/lcdutils/lcdutils-0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Cobalt RaQ/Qube LCD Writing and Button reading utilities"
+HOMEPAGE="http://people.debian.org/~pm/mips-cobalt/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~mips ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:CFLAGS=-O2 -Wall:CFLAGS=${CFLAGS}:g" Makefile
+ epatch "${FILESDIR}"/include-stdlib.h-for-exit.patch
+}
+
+src_compile() {
+ emake distclean || die "distclean failed"
+ emake all || die "all failed"
+}
+
+src_install() {
+ dobin buttond putlcd || die "dobin failed"
+ dodoc ChangeLog || die "dodoc failed"
+}
diff --git a/sys-apps/lcdutils/metadata.xml b/sys-apps/lcdutils/metadata.xml
new file mode 100644
index 000000000000..02914d70e14a
--- /dev/null
+++ b/sys-apps/lcdutils/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mips</herd>
+ <maintainer>
+ <email>mips@gentoo.org</email>
+ <name>Mips Team</name>
+ </maintainer>
+
+ <longdescription>
+ Provides utilities for Cobalt Microserver systems to write to the LCD and read button input
+ </longdescription>
+</pkgmetadata>
+