summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/inxi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/inxi')
-rw-r--r--sys-apps/inxi/Manifest2
-rw-r--r--sys-apps/inxi/inxi-2.2.14.ebuild39
-rw-r--r--sys-apps/inxi/inxi-2.2.19.ebuild39
-rw-r--r--sys-apps/inxi/metadata.xml8
4 files changed, 88 insertions, 0 deletions
diff --git a/sys-apps/inxi/Manifest b/sys-apps/inxi/Manifest
new file mode 100644
index 000000000000..e8c0f701c709
--- /dev/null
+++ b/sys-apps/inxi/Manifest
@@ -0,0 +1,2 @@
+DIST inxi-2.2.14.tar.gz 179900 SHA256 c7acc482e860864d69365c2548b2efcfd334432dc053568a4dce37d6699146e5 SHA512 0cc5c1a6d6e3611e3203ca9747477316b6171a8926c33ce4b6f2531fa9c644fa4a7de654e78958efb770fdd0fd1c7ec734bc32e98d9651e3154ab5a2aee58f2d WHIRLPOOL f74ac82c213bc5949da2602d5a38abd061889877ceb6f0e3a2e4988b205d1179e1eac8a42a2402e064773b8ca124cba544e9e37fbb1d1d16b2c4d83e58ce0728
+DIST inxi-2.2.19.tar.gz 181796 SHA256 8611d5c906234b348fc46cd287660b7676a1a5cd85bd38367dad2e0ceb2e92df SHA512 002c33d3cb13269b91732be4f8704b1022d99d46fbb8630bd6f35d8609cbcde22b650da5ff93480a2d1acedfec40b47e8154b757d1a0291eb9d6917009331659 WHIRLPOOL 323b359b0d92959b9504d5a77f6a20194604de98ce8e0bb4f9d5c20610e4787d0247e78e0d93bd01818a906ff421face76704717c4caf1f2313728b66d53aef3
diff --git a/sys-apps/inxi/inxi-2.2.14.ebuild b/sys-apps/inxi/inxi-2.2.14.ebuild
new file mode 100644
index 000000000000..2e9a941885ca
--- /dev/null
+++ b/sys-apps/inxi/inxi-2.2.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A newer, better system information script for irc, administration, and system troubleshooters."
+HOMEPAGE="http://code.google.com/p/inxi/"
+SRC_URI="https://inxi.googlecode.com/svn/tarballs/${PN}_${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ >=app-shells/bash-3.0
+ sys-apps/coreutils
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/pciutils
+ sys-process/procps
+ sys-apps/sed
+ "
+
+S=${WORKDIR}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1.gz
+}
+
+pkg_postinst() {
+ einfo "To view a short or full system information."
+ einfo "inxi -b for short information."
+ einfo "inxi -F for full information."
+ einfo "inxi also provides verbose levels '-v1 to -v7'."
+ einfo "inxi -h for help."
+}
diff --git a/sys-apps/inxi/inxi-2.2.19.ebuild b/sys-apps/inxi/inxi-2.2.19.ebuild
new file mode 100644
index 000000000000..f2d23b5986a7
--- /dev/null
+++ b/sys-apps/inxi/inxi-2.2.19.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A newer, better system information script for irc, administration, and system troubleshooters."
+HOMEPAGE="http://code.google.com/p/inxi/"
+SRC_URI="https://inxi.googlecode.com/svn/tarballs/${PN}_${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ >=app-shells/bash-3.0
+ sys-apps/coreutils
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/pciutils
+ sys-process/procps
+ sys-apps/sed
+ "
+
+S=${WORKDIR}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1.gz
+}
+
+pkg_postinst() {
+ einfo "To view a short or full system information."
+ einfo "inxi -b for short information."
+ einfo "inxi -F for full information."
+ einfo "inxi also provides verbose levels '-v1 to -v7'."
+ einfo "inxi -h for help."
+}
diff --git a/sys-apps/inxi/metadata.xml b/sys-apps/inxi/metadata.xml
new file mode 100644
index 000000000000..61c052a97a13
--- /dev/null
+++ b/sys-apps/inxi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dastergon@gentoo.org</email>
+ <name>Pavlos Ratis</name>
+ </maintainer>
+</pkgmetadata>