summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-06-14 22:25:51 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-06-14 22:27:20 -0700
commit85bf86f0ee5b866e8e67271ff283e933368148af (patch)
treefc23880df09ace4a9d536c65837bcbc7ad4b6e49 /sys-apps/hwloc
parentsys-apps/hwloc: rename useflag: libudev -> udev (diff)
downloadgentoo-85bf86f0ee5b866e8e67271ff283e933368148af.tar.gz
gentoo-85bf86f0ee5b866e8e67271ff283e933368148af.tar.bz2
gentoo-85bf86f0ee5b866e8e67271ff283e933368148af.zip
sys-apps/hwloc: EPREFIX -> ESYSROOT for cuda
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/hwloc-1.11.13.ebuild6
-rw-r--r--sys-apps/hwloc/hwloc-2.3.0.ebuild6
-rw-r--r--sys-apps/hwloc/hwloc-2.5.0.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/sys-apps/hwloc/hwloc-1.11.13.ebuild b/sys-apps/hwloc/hwloc-1.11.13.ebuild
index f9b7aae544d1..151384ff11a5 100644
--- a/sys-apps/hwloc/hwloc-1.11.13.ebuild
+++ b/sys-apps/hwloc/hwloc-1.11.13.ebuild
@@ -43,8 +43,8 @@ src_prepare() {
eautoreconf
if use cuda ; then
- append-cflags -I"${EPREFIX}"/opt/cuda/include
- append-cppflags -I"${EPREFIX}"/opt/cuda/include
+ append-cflags -I"${ESYSROOT}"/opt/cuda/include
+ append-cppflags -I"${ESYSROOT}"/opt/cuda/include
fi
}
@@ -53,7 +53,7 @@ multilib_src_configure() {
if use cuda ; then
local -x LDFLAGS="${LDFLAGS}"
- append-ldflags -L"${EPREFIX}"/opt/cuda/$(get_libdir)
+ append-ldflags -L"${ESYSROOT}"/opt/cuda/$(get_libdir)
fi
ECONF_SOURCE=${S} econf \
diff --git a/sys-apps/hwloc/hwloc-2.3.0.ebuild b/sys-apps/hwloc/hwloc-2.3.0.ebuild
index 6756f4000ac9..f98a08eb4cda 100644
--- a/sys-apps/hwloc/hwloc-2.3.0.ebuild
+++ b/sys-apps/hwloc/hwloc-2.3.0.ebuild
@@ -48,8 +48,8 @@ src_prepare() {
eautoreconf
if use cuda ; then
- append-cflags "-I${EPREFIX}/opt/cuda/include"
- append-cppflags "-I${EPREFIX}/opt/cuda/include"
+ append-cflags "-I${ESYSROOT}/opt/cuda/include"
+ append-cppflags "-I${ESYSROOT}/opt/cuda/include"
fi
}
@@ -58,7 +58,7 @@ multilib_src_configure() {
if use cuda ; then
local -x LDFLAGS="${LDFLAGS}"
- append-ldflags "-L${EPREFIX}/opt/cuda/$(get_libdir)"
+ append-ldflags "-L${ESYSROOT}/opt/cuda/$(get_libdir)"
fi
local myconf=(
diff --git a/sys-apps/hwloc/hwloc-2.5.0.ebuild b/sys-apps/hwloc/hwloc-2.5.0.ebuild
index 6756f4000ac9..f98a08eb4cda 100644
--- a/sys-apps/hwloc/hwloc-2.5.0.ebuild
+++ b/sys-apps/hwloc/hwloc-2.5.0.ebuild
@@ -48,8 +48,8 @@ src_prepare() {
eautoreconf
if use cuda ; then
- append-cflags "-I${EPREFIX}/opt/cuda/include"
- append-cppflags "-I${EPREFIX}/opt/cuda/include"
+ append-cflags "-I${ESYSROOT}/opt/cuda/include"
+ append-cppflags "-I${ESYSROOT}/opt/cuda/include"
fi
}
@@ -58,7 +58,7 @@ multilib_src_configure() {
if use cuda ; then
local -x LDFLAGS="${LDFLAGS}"
- append-ldflags "-L${EPREFIX}/opt/cuda/$(get_libdir)"
+ append-ldflags "-L${ESYSROOT}/opt/cuda/$(get_libdir)"
fi
local myconf=(