summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-02 05:16:30 +0100
committerSam James <sam@gentoo.org>2024-06-02 05:57:05 +0100
commit0dd454591d7f50808a53d22a478ab64760da0601 (patch)
tree52fadd45300970a564b244133edbedc1c6b7abde /sys-apps/firejail
parentdev-util/rpmdevtools: add 9.6 (diff)
downloadgentoo-0dd454591d7f50808a53d22a478ab64760da0601.tar.gz
gentoo-0dd454591d7f50808a53d22a478ab64760da0601.tar.bz2
gentoo-0dd454591d7f50808a53d22a478ab64760da0601.zip
sys-apps/firejail: drop 0.9.70
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/firejail')
-rw-r--r--sys-apps/firejail/Manifest1
-rw-r--r--sys-apps/firejail/firejail-0.9.70.ebuild118
2 files changed, 0 insertions, 119 deletions
diff --git a/sys-apps/firejail/Manifest b/sys-apps/firejail/Manifest
index 72515d1276d5..93387adafa9d 100644
--- a/sys-apps/firejail/Manifest
+++ b/sys-apps/firejail/Manifest
@@ -1,2 +1 @@
-DIST firejail-0.9.70.tar.xz 485096 BLAKE2B d5164ba5ee08e80415a84999e4152f1f9c897f50def669731098126cec117aed3cf4b21603aeb13ccbdb1bffa9d48de69dcb19fe7135691e891b9b83f48a5ca1 SHA512 a790ccb711da6c3e52677011d7eb38c482ffb5066498d4586018671ab4ee533e02edb31fda872e0647fd27c00014b04305eafcb56f1f1b07f470aa4fb701cbe5
DIST firejail-0.9.72.tar.xz 503192 BLAKE2B 3d57b345476cb62399859622c88f5d6c22842da5894045c09bc7d84229ec2a01c494e4e9393b6fba6c668f73c6b7046f9a014a315baa5bc56d1479b9cad178a7 SHA512 846fa5caf6e68c669f76a07d6321ed365bf3c45f7992e8be3784ed99ef508ea8dffc5d6cc5da75eeb37964ad358d61b7959e8590051950951de8ca904d8a49de
diff --git a/sys-apps/firejail/firejail-0.9.70.ebuild b/sys-apps/firejail/firejail-0.9.70.ebuild
deleted file mode 100644
index a35fe516d656..000000000000
--- a/sys-apps/firejail/firejail-0.9.70.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit toolchain-funcs python-single-r1 linux-info
-
-if [[ ${PV} != 9999 ]]; then
- SRC_URI="https://github.com/netblue30/${PN}/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="amd64 ~arm ~arm64 ~x86"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/netblue30/firejail.git"
- EGIT_BRANCH="master"
-fi
-
-DESCRIPTION="Security sandbox for any type of processes"
-HOMEPAGE="https://firejail.wordpress.com/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="apparmor +chroot contrib +dbusproxy +file-transfer +globalcfg +network +private-home test +userns X"
-# Needs a lot of work to function within sandbox/portage
-# bug #769731
-RESTRICT="test"
-
-RDEPEND="!sys-apps/firejail-lts
- apparmor? ( sys-libs/libapparmor )
- contrib? ( ${PYTHON_DEPS} )
- dbusproxy? ( sys-apps/xdg-dbus-proxy )"
-
-DEPEND="${RDEPEND}
- sys-libs/libseccomp
- test? ( dev-tcltk/expect )"
-
-REQUIRED_USE="contrib? ( ${PYTHON_REQUIRED_USE} )"
-
-PATCHES=(
- "${FILESDIR}/${P}-envlimits.patch"
- "${FILESDIR}/${P}-firecfg.config.patch"
- )
-
-pkg_setup() {
- CONFIG_CHECK="~SQUASHFS"
- local ERROR_SQUASHFS="CONFIG_SQUASHFS: required for firejail --appimage mode"
- check_extra_config
- use contrib && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- find -type f -name Makefile.in -exec sed -i -r -e '/CFLAGS/s: (-O2|-ggdb) : :g' {} + || die
-
- sed -i -r -e '/CFLAGS/s: (-O2|-ggdb) : :g' ./src/common.mk.in || die
-
- # fix up hardcoded paths to templates and docs
- local files=$(grep -E -l -r '/usr/share/doc/firejail([^-]|$)' ./RELNOTES ./src/man/ ./etc/profile*/ ./test/ || die)
- for file in ${files[@]} ; do
- sed -i -r -e "s:/usr/share/doc/firejail([^-]|\$):/usr/share/doc/${PF}\1:" "${file}" || die
- done
-
- # remove compression of man pages
- sed -i -r -e '/rm -f \$\$man.gz; \\/d; /gzip -9n \$\$man; \\/d; s|\*\.([[:digit:]])\) install -m 0644 \$\$man\.gz|\*\.\1\) install -m 0644 \$\$man|g' Makefile.in || die
-
- if use contrib; then
- python_fix_shebang -f contrib/*.py
- fi
-}
-
-src_configure() {
- econf \
- --disable-firetunnel \
- --enable-suid \
- $(use_enable apparmor) \
- $(use_enable chroot) \
- $(use_enable dbusproxy) \
- $(use_enable file-transfer) \
- $(use_enable globalcfg) \
- $(use_enable network) \
- $(use_enable private-home) \
- $(use_enable userns) \
- $(use_enable X x11)
-
- cat > 99firejail <<-EOF || die
- SANDBOX_WRITE="/run/firejail"
- EOF
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- default
-
- # Gentoo-specific profile customizations
- insinto /etc/${PN}
- local profile_local
- for profile_local in "${FILESDIR}"/profile_*local ; do
- newins "${profile_local}" "${profile_local/\/*profile_/}"
- done
-
- # Prevent sandbox violations when toolchain is firejailed
- insinto /etc/sandbox.d
- doins 99firejail
-
- rm "${ED}"/usr/share/doc/${PF}/COPYING || die
-
- if use contrib; then
- python_scriptinto /usr/$(get_libdir)/firejail
- python_doscript contrib/*.py
- insinto /usr/$(get_libdir)/firejail
- dobin contrib/*.sh
- fi
-}