summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-02 09:06:28 +0100
committerSam James <sam@gentoo.org>2023-07-02 09:33:01 +0100
commitb4f74f9d0f089f527b3b123ff0859e0462e86809 (patch)
tree5f01df256be6bff3fac6ef26be7bea1786c17102 /sys-apps/ethtool
parentmedia-libs/libsdl2: add 2.28.1 (diff)
downloadgentoo-b4f74f9d0f089f527b3b123ff0859e0462e86809.tar.gz
gentoo-b4f74f9d0f089f527b3b123ff0859e0462e86809.tar.bz2
gentoo-b4f74f9d0f089f527b3b123ff0859e0462e86809.zip
sys-apps/ethtool: add 6.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/ethtool')
-rw-r--r--sys-apps/ethtool/Manifest1
-rw-r--r--sys-apps/ethtool/ethtool-6.4.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/ethtool/Manifest b/sys-apps/ethtool/Manifest
index bf35a364d018..a56842293edc 100644
--- a/sys-apps/ethtool/Manifest
+++ b/sys-apps/ethtool/Manifest
@@ -3,3 +3,4 @@ DIST ethtool-5.19.tar.xz 324472 BLAKE2B 44cc292db04f411a57a0a5ae0cdfbef733c7ee73
DIST ethtool-6.1.tar.xz 327644 BLAKE2B 002a4edffda42520d77e8f0c27adf909090823f1a08689b67fc7c75de3048bdc9c94d7d32973bd17562d7dbf295479e796c2529b5db66b5fce42a2ede5851cd6 SHA512 6ca478ec75dae7cc347b859802e1965e6c78310ec4b276dec29bdf76d3464e4186c6e5ed0cb8f013171d6c0562c1156cb0442419f5b947c314e8b91ad9fd2d93
DIST ethtool-6.2.tar.xz 332708 BLAKE2B b3fa2571b1efef3b686eb4f20b33e6cc32bdb8cff5f2e642454ca3d41c427b1953df7b07e5ac8ef149f8b4be614210e05e593233655e5fe317c48630b20b68e8 SHA512 ff1f14c7876163bef93ca48e22a3429f09b4bcb3e1d101ef297d9f226e3fc2d3c3f19faf5b85f54cb558479e4a408ef5356a2d12e7ba132cc4cadaf92effccaf
DIST ethtool-6.3.tar.xz 338764 BLAKE2B c06509525db47f8ee7c220d0b880fe80323a4a00036e9698432b1b9c85ad75045e98b23498f6283497728cafd187ca173b15f3ad60f8e6f8b4d0c5688d84a1f9 SHA512 85e5ecd20abf737e94ddc093f15ab0b876f763a886e3327027c448c0efcc091628c3df42070f30583551fa12f866f5b49d41fb3333acdf854a59bba671646320
+DIST ethtool-6.4.tar.xz 340844 BLAKE2B 15fbd3f2db21b7a880d040bbd5fffc51f5335d182e1d3d23dc23d2cfd3b572fabb5914426f0e8470f4374ceddb07741ed1b57d058a57867b89c1ea2a78d13c10 SHA512 5e389564b41e9494df102f9fb703ae2d80ba38346d84ec6c89b024ec21c85eca9f58e88012290feaa88d3ce035d6f779913798b0ca177e8d0a08eff197eb6afd
diff --git a/sys-apps/ethtool/ethtool-6.4.ebuild b/sys-apps/ethtool/ethtool-6.4.ebuild
new file mode 100644
index 000000000000..a7eff7664c78
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-6.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils"
+
+src_configure() {
+ econf $(use_enable netlink)
+}