summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-02 14:49:46 +0000
committerSam James <sam@gentoo.org>2021-11-02 14:50:17 +0000
commite95da4d04a00591133eefbf8df6dd6121b4ea472 (patch)
tree5cd4c25678d824ad9b447be2f50dfd86b8fade8a /sec-policy
parentapp-crypt/qca: Drop 2.3.3 (diff)
downloadgentoo-e95da4d04a00591133eefbf8df6dd6121b4ea472.tar.gz
gentoo-e95da4d04a00591133eefbf8df6dd6121b4ea472.tar.bz2
gentoo-e95da4d04a00591133eefbf8df6dd6121b4ea472.zip
sec-policy/selinux-base: use python-any-r1 (needs Python to generate XML)
Noticed after checking downstream for any changes we should pick up: https://github.com/flatcar-linux/coreos-overlay/commit/3086ea99010fc51cced60a7badc572feaaf551f6. Closes: https://bugs.gentoo.org/770901 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sec-policy')
-rw-r--r--sec-policy/selinux-base/selinux-base-2.20210203-r1.ebuild5
-rw-r--r--sec-policy/selinux-base/selinux-base-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/sec-policy/selinux-base/selinux-base-2.20210203-r1.ebuild b/sec-policy/selinux-base/selinux-base-2.20210203-r1.ebuild
index 7597060e52e3..30334fc4b6f5 100644
--- a/sec-policy/selinux-base/selinux-base-2.20210203-r1.ebuild
+++ b/sec-policy/selinux-base/selinux-base-2.20210203-r1.ebuild
@@ -3,6 +3,10 @@
EAPI="7"
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="xml"
+inherit python-any-r1
+
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="${SELINUX_GIT_REPO:-https://anongit.gentoo.org/git/proj/hardened-refpolicy.git}"
EGIT_BRANCH="${SELINUX_GIT_BRANCH:-master}"
@@ -26,6 +30,7 @@ SLOT="0"
RDEPEND=">=sys-apps/policycoreutils-2.8"
DEPEND="${RDEPEND}"
BDEPEND="
+ ${PYTHON_DEPS}
>=sys-apps/checkpolicy-2.8
sys-devel/m4"
diff --git a/sec-policy/selinux-base/selinux-base-9999.ebuild b/sec-policy/selinux-base/selinux-base-9999.ebuild
index 72948d1e2c96..f9dcacae70f1 100644
--- a/sec-policy/selinux-base/selinux-base-9999.ebuild
+++ b/sec-policy/selinux-base/selinux-base-9999.ebuild
@@ -3,6 +3,10 @@
EAPI="7"
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="xml"
+inherit python-any-r1
+
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="${SELINUX_GIT_REPO:-https://anongit.gentoo.org/git/proj/hardened-refpolicy.git}"
EGIT_BRANCH="${SELINUX_GIT_BRANCH:-master}"
@@ -26,6 +30,7 @@ SLOT="0"
RDEPEND=">=sys-apps/policycoreutils-2.8"
DEPEND="${RDEPEND}"
BDEPEND="
+ ${PYTHON_DEPS}
>=sys-apps/checkpolicy-2.8
sys-devel/m4"