summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/gcalc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/gcalc')
-rw-r--r--sci-visualization/gcalc/Manifest1
-rw-r--r--sci-visualization/gcalc/gcalc-3.1_rc1.ebuild42
-rw-r--r--sci-visualization/gcalc/metadata.xml8
3 files changed, 51 insertions, 0 deletions
diff --git a/sci-visualization/gcalc/Manifest b/sci-visualization/gcalc/Manifest
new file mode 100644
index 000000000000..3d34003270d7
--- /dev/null
+++ b/sci-visualization/gcalc/Manifest
@@ -0,0 +1 @@
+DIST GCalc-3.1-rc1.tar.gz 543699 RMD160 8b5434869afc7cf23d2f3246373e85a6c4efa9e3 SHA1 42614aa974797216a38c58e6d3a840b6208c09dd SHA256 c22f0b2f0d11555d39cd9e6eacf025d84c736d01085d69592098489cba7ac99e
diff --git a/sci-visualization/gcalc/gcalc-3.1_rc1.ebuild b/sci-visualization/gcalc/gcalc-3.1_rc1.ebuild
new file mode 100644
index 000000000000..0ee0c5e512ea
--- /dev/null
+++ b/sci-visualization/gcalc/gcalc-3.1_rc1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils java-pkg-2
+
+MY_P="GCalc-${PV/_/-}"
+DESCRIPTION="Java Mathematical Graphing System"
+HOMEPAGE="http://gcalc.net/"
+SRC_URI="http://gcalc.net/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE=""
+SLOT="0"
+
+RDEPEND=">=virtual/jre-1.4
+ !!sci-mathematics/gcalc"
+DEPEND=">=virtual/jdk-1.4"
+
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ find -name '*.jar' -exec rm -v {} + || die
+}
+
+src_compile() {
+ cd src || die
+ ejavac $(find . -name '*.java')
+
+ jar cf ${PN}.jar resources pluginlist.xml $(find . -name '*.class') || die
+}
+
+src_install() {
+ java-pkg_dojar src/${PN}.jar
+ java-pkg_dolauncher gcalc --main net.gcalc.calc.GCalc
+
+ newicon src/resources/gicon.png ${PN}.png || die
+ make_desktop_entry ${PN} "GCalc Java Mathematical Graphing System"
+}
diff --git a/sci-visualization/gcalc/metadata.xml b/sci-visualization/gcalc/metadata.xml
new file mode 100644
index 000000000000..7c075e6e4efa
--- /dev/null
+++ b/sci-visualization/gcalc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<herd>sci</herd>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>