summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-03-06 01:12:16 -0700
committerChristoph Junghans <junghans@gentoo.org>2017-03-06 01:16:30 -0700
commitb2f23f09f4a9199ea5605bf0c3e786f69c8e6b2e (patch)
treefec542620942bc237c1352512473496c862c5550 /sci-physics
parentapp-emacs/ebuild-mode: Remove old. (diff)
downloadgentoo-b2f23f09f4a9199ea5605bf0c3e786f69c8e6b2e.tar.gz
gentoo-b2f23f09f4a9199ea5605bf0c3e786f69c8e6b2e.tar.bz2
gentoo-b2f23f09f4a9199ea5605bf0c3e786f69c8e6b2e.zip
sci-physics/espresso: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso/Manifest1
-rw-r--r--sci-physics/espresso/espresso-4.0_pre20170228.ebuild118
-rw-r--r--sci-physics/espresso/files/1056.patch190
3 files changed, 309 insertions, 0 deletions
diff --git a/sci-physics/espresso/Manifest b/sci-physics/espresso/Manifest
index 73ae97cdf72d..0b243949f69d 100644
--- a/sci-physics/espresso/Manifest
+++ b/sci-physics/espresso/Manifest
@@ -1,2 +1,3 @@
DIST espresso-3.3.0.tar.gz 18952622 SHA256 64ea2684e4fc0d31c11969e49ec74c25138b4f74686f67b93c7e1103833ff08f SHA512 90edbbdc8d7f7247b5179fce0fad796a9488f82a1754519918c6588c932050675397d36e0167aae770db9803b6c22f7d14d23c04cf307d10802afd3d5d5edc20 WHIRLPOOL 3e9547f2da6676edf3de415fa848301f2959c3dfeef1c3f461b4e1eb202224ead7635748b47d42edb9f661dc5d672f38168e15ab6c55a9c9d7f102ae11f8574e
DIST espresso-3.3.1.tar.gz 18986557 SHA256 8576fc1fe59e04dec4fa0d354b7ec52365622860099624f36bddbb2b472c0c70 SHA512 3fc6e681e625f2cf98ac0aa3b1c16fbe17b9f9aa8f79f2e89926501cbb68621d171d6c6a22f42f9f60298ee31520ca712ace57d57738d2cf76f7ae2f7c0436b1 WHIRLPOOL 7075cbb8fba944cda8290a3f27650fcdd2b466495c6d4697ae3074c60ded86e08ea4ea0d9336c8ca859f7b3303cd496dba2972c9c8205a7b3cafbe36fcfc8a40
+DIST espresso-4.0_pre20170228.tar.gz 23621395 SHA256 01e6770949db7bfad9dba3776a644dd0c0758e3781edf23363d7d2671ee14b01 SHA512 7d35648d447af3282a76d9d68cfe681734ec18794a38b09e0ae9233f63b62450c643643bcec999ea9c7d4ba070d4fc6f8dc64db8145f536ae017a67ff2d0e0e2 WHIRLPOOL 02ef0d937726a1abe3f8df4f19ed62008b69494304cf4d569d74936d834bcb20e4a0bd5d6edff009c74c8e16f6b14f9c794ff209c8e39e6d8eed785e5356d6d6
diff --git a/sci-physics/espresso/espresso-4.0_pre20170228.ebuild b/sci-physics/espresso/espresso-4.0_pre20170228.ebuild
new file mode 100644
index 000000000000..252f74e2e5c6
--- /dev/null
+++ b/sci-physics/espresso/espresso-4.0_pre20170228.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils python-single-r1 savedconfig
+
+DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
+HOMEPAGE="http://espressomd.org"
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://github.com/espressomd/espresso.git https://github.com/espressomd/espresso.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ COMMIT="8a021f5e8b1d508f356f4419d360bd9dfb7fec2c"
+ SRC_URI="https://github.com/${PN}md/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="cuda doc examples +fftw +hdf5 test"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >dev-python/cython-0.22[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
+ fftw? ( sci-libs/fftw:3.0 )
+ dev-libs/boost:=[mpi]
+ hdf5? ( sci-libs/hdf5:=[cxx] )"
+
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-latexextra
+ virtual/latex-base )"
+
+DOCS=( AUTHORS NEWS README ChangeLog )
+
+PATCHES=( "${FILESDIR}"/1056.patch )
+
+src_prepare() {
+ use cuda && cuda_src_prepare
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_CUDA=$(usex cuda)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DWITH_TESTS=$(usex test)
+ -DWITH_SCAFACOS=ON
+ -DINSTALL_PYPRESSO=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_FFTW3=$(usex !fftw)
+ -DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex !hdf5)
+ -DCMAKE_SKIP_RPATH=YES
+ -DLIBDIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && cmake-utils_src_make doxygen
+ [[ ${PV} = 9999 ]] && use doc && cmake-utils_src_make ug dg tutorials
+}
+
+src_install() {
+ local i docdir="${S}"
+
+ cmake-utils_src_install
+
+ insinto /usr/share/${PN}/
+ doins ${CMAKE_BUILD_DIR}/myconfig-sample.hpp
+
+ save_config ${CMAKE_BUILD_DIR}/src/core/myconfig-final.hpp
+
+ if use doc; then
+ [[ ${PV} = 9999 ]] && docdir="${CMAKE_BUILD_DIR}"
+ newdoc "${docdir}"/doc/dg/dg.pdf developer_guide.pdf
+ newdoc "${docdir}"/doc/ug/ug.pdf user_guide.pdf
+ for i in "${docdir}/doc/tutorials/python"/*/[0-9]*.pdf; do
+ newdoc "${i}" "tutorial_${i##*/}"
+ done
+ dodoc -r ${CMAKE_BUILD_DIR}/doc/doxygen/html
+ fi
+
+ if use examples; then
+ insinto "/usr/share/${PN}/examples/"
+ doins -r samples/python/.
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "Please read and cite:"
+ elog "ESPResSo, Comput. Phys. Commun. 174(9) ,704, 2006."
+ elog "http://dx.doi.org/10.1016/j.cpc.2005.10.005"
+ echo
+ elog "If you need more features, change"
+ elog "/etc/portage/savedconfig/${CATEGORY}/${PF}"
+ elog "and reemerge with USE=savedconfig"
+ echo
+ elog "For a full feature list see:"
+ elog "/usr/share/${PN}/myconfig-sample.hpp"
+ echo
+}
diff --git a/sci-physics/espresso/files/1056.patch b/sci-physics/espresso/files/1056.patch
new file mode 100644
index 000000000000..18a478e446b1
--- /dev/null
+++ b/sci-physics/espresso/files/1056.patch
@@ -0,0 +1,190 @@
+From d075cbaa80ce0b484c8422be27c5b5680f6abee4 Mon Sep 17 00:00:00 2001
+From: Christoph Junghans <junghans@votca.org>
+Date: Fri, 3 Mar 2017 16:05:45 -0700
+Subject: [PATCH] cmake: install all shared libs in back in libdir
+
+some libraries weren't installed and the python module path
+isn't in the LD_LIBRARY_PATH and hence partly revert
+80ad49e954f4a6590707fd86e4fd586682ad626d
+---
+ CMakeLists.txt | 4 ++++
+ src/core/CMakeLists.txt | 4 ++--
+ src/core/actor/CMakeLists.txt | 4 ++--
+ src/core/constraints/CMakeLists.txt | 1 +
+ src/core/correlators/CMakeLists.txt | 1 +
+ src/core/immersed_boundary/CMakeLists.txt | 4 ++--
+ src/core/object-in-fluid/CMakeLists.txt | 2 +-
+ src/core/observables/CMakeLists.txt | 1 +
+ src/core/scafacos/CMakeLists.txt | 2 +-
+ src/core/shapes/CMakeLists.txt | 1 +
+ src/core/utils/CMakeLists.txt | 1 +
+ src/script_interface/CMakeLists.txt | 1 +
+ 12 files changed, 18 insertions(+), 8 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index cf49c40..7a8bc15 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -238,6 +238,10 @@ if (NOT DEFINED DATA)
+ set(DATA "share/espresso")
+ endif(NOT DEFINED DATA)
+
++if (NOT DEFINED LIBDIR)
++ set(LIBDIR "lib")
++endif(NOT DEFINED LIBDIR)
++
+ if (NOT DEFINED BINDIR)
+ set(BINDIR "bin")
+ endif(NOT DEFINED BINDIR)
+diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
+index 9982a54..13bb052 100644
+--- a/src/core/CMakeLists.txt
++++ b/src/core/CMakeLists.txt
+@@ -23,7 +23,7 @@ add_custom_target(EspressoConfig DEPENDS config-features.hpp config-features.cpp
+ add_dependencies(EspressoConfig myconfig)
+
+ add_library(EspressoCore SHARED ${EspressoCore_SRC} config-features.cpp config-version.cpp)
+-install(TARGETS EspressoCore LIBRARY DESTINATION ${PYTHON_INSTDIR})
++install(TARGETS EspressoCore LIBRARY DESTINATION ${LIBDIR})
+ add_dependencies(EspressoCore EspressoConfig)
+
+ target_link_libraries(EspressoCore ${LIBRARIES} Actor ObjectInFluid ImmersedBoundary Shapes Constraints EspressoUtils Correlators Observables)
+@@ -43,7 +43,7 @@ if(CUDA)
+ cuda_include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+ cuda_add_library(EspressoCuda SHARED ${EspressoCuda_SRC})
+- install(TARGETS EspressoCuda DESTINATION ${PYTHON_INSTDIR})
++ install(TARGETS EspressoCuda DESTINATION ${PYTHON_INSTDIR}/espressomd)
+ add_dependencies(EspressoCuda EspressoConfig)
+
+ set_target_properties(EspressoCuda PROPERTIES MACOSX_RPATH TRUE)
+diff --git a/src/core/actor/CMakeLists.txt b/src/core/actor/CMakeLists.txt
+index 0421243..1b5eafe 100644
+--- a/src/core/actor/CMakeLists.txt
++++ b/src/core/actor/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ file(GLOB Actor_SRC *.cpp)
+
+ add_library(Actor SHARED ${Actor_SRC})
+-install(TARGETS Actor LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION ${PYTHON_INSTDIR})
++install(TARGETS Actor LIBRARY DESTINATION ${LIBDIR} ARCHIVE DESTINATION ${LIBDIR})
+ add_dependencies(Actor EspressoConfig)
+
+ set_target_properties(Actor PROPERTIES MACOSX_RPATH TRUE)
+@@ -9,7 +9,7 @@ set_target_properties(Actor PROPERTIES MACOSX_RPATH TRUE)
+ if(CUDA)
+ file(GLOB ActorCuda_SRC *.cu)
+ cuda_add_library(ActorCuda SHARED ${ActorCuda_SRC})
+- install(TARGETS ActorCuda DESTINATION ${PYTHON_INSTDIR})
++ install(TARGETS ActorCuda DESTINATION ${PYTHON_INSTDIR}/espressomd)
+ add_dependencies(ActorCuda EspressoConfig)
+
+ add_dependencies(Actor ActorCuda)
+diff --git a/src/core/constraints/CMakeLists.txt b/src/core/constraints/CMakeLists.txt
+index 0f5c043..d07ad77 100644
+--- a/src/core/constraints/CMakeLists.txt
++++ b/src/core/constraints/CMakeLists.txt
+@@ -1,4 +1,5 @@
+ file(GLOB Constraints_SRC Constraint.cpp)
+ add_library(Constraints SHARED ${Constraints_SRC})
++install(TARGETS Constraints LIBRARY DESTINATION ${LIBDIR})
+ add_dependencies(Constraints EspressoConfig)
+ set_target_properties(Constraints PROPERTIES MACOSX_RPATH TRUE)
+diff --git a/src/core/correlators/CMakeLists.txt b/src/core/correlators/CMakeLists.txt
+index c5ff02f..fcc3611 100644
+--- a/src/core/correlators/CMakeLists.txt
++++ b/src/core/correlators/CMakeLists.txt
+@@ -1,4 +1,5 @@
+ file(GLOB Correlators_SRC *.?pp)
+ add_library(Correlators SHARED ${Correlators_SRC})
++install(TARGETS Correlators LIBRARY DESTINATION ${LIBDIR})
+ add_dependencies(Correlators EspressoConfig)
+ set_target_properties(Correlators PROPERTIES MACOSX_RPATH TRUE)
+diff --git a/src/core/immersed_boundary/CMakeLists.txt b/src/core/immersed_boundary/CMakeLists.txt
+index ec7fb85..8e7285f 100644
+--- a/src/core/immersed_boundary/CMakeLists.txt
++++ b/src/core/immersed_boundary/CMakeLists.txt
+@@ -1,13 +1,13 @@
+ file(GLOB ImmersedBoundary_SRC *.cpp)
+ add_library(ImmersedBoundary SHARED ${ImmersedBoundary_SRC})
+ set_target_properties(ImmersedBoundary PROPERTIES MACOSX_RPATH TRUE)
+-install(TARGETS ImmersedBoundary LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION ${PYTHON_INSTDIR})
++install(TARGETS ImmersedBoundary LIBRARY DESTINATION ${LIBDIR} ARCHIVE DESTINATION ${LIBDIR})
+ add_dependencies(ImmersedBoundary EspressoConfig)
+
+ if(CUDA)
+ file(GLOB ImmersedBoundaryCuda_SRC *.cu)
+ cuda_add_library(ImmersedBoundaryCuda SHARED ${ImmersedBoundaryCuda_SRC})
+- install(TARGETS ImmersedBoundaryCuda DESTINATION ${PYTHON_INSTDIR})
++ install(TARGETS ImmersedBoundaryCuda DESTINATION ${PYTHON_INSTDIR}/espressomd)
+ add_dependencies(ImmersedBoundaryCuda EspressoConfig)
+
+ set_target_properties(ImmersedBoundaryCuda PROPERTIES MACOSX_RPATH TRUE)
+diff --git a/src/core/object-in-fluid/CMakeLists.txt b/src/core/object-in-fluid/CMakeLists.txt
+index 7154486..c25228a 100644
+--- a/src/core/object-in-fluid/CMakeLists.txt
++++ b/src/core/object-in-fluid/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ file(GLOB ObjectInFluid_SRC *.cpp)
+ add_library(ObjectInFluid SHARED ${ObjectInFluid_SRC})
+-install(TARGETS ObjectInFluid LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION ${PYTHON_INSTDIR})
++install(TARGETS ObjectInFluid LIBRARY DESTINATION ${LIBDIR} ARCHIVE DESTINATION ${LIBDIR})
+ add_dependencies(ObjectInFluid EspressoConfig)
+ set_target_properties(ObjectInFluid PROPERTIES MACOSX_RPATH TRUE)
+diff --git a/src/core/observables/CMakeLists.txt b/src/core/observables/CMakeLists.txt
+index 9813d86..51ab79d 100644
+--- a/src/core/observables/CMakeLists.txt
++++ b/src/core/observables/CMakeLists.txt
+@@ -1,4 +1,5 @@
+ file(GLOB Observables_SRC *.?pp)
+ add_library(Observables SHARED ${Observables_SRC})
++install(TARGETS Observables LIBRARY DESTINATION ${LIBDIR})
+ add_dependencies(Observables EspressoConfig)
+ set_target_properties(Observables PROPERTIES MACOSX_RPATH TRUE)
+diff --git a/src/core/scafacos/CMakeLists.txt b/src/core/scafacos/CMakeLists.txt
+index 1479683..3028ca0 100644
+--- a/src/core/scafacos/CMakeLists.txt
++++ b/src/core/scafacos/CMakeLists.txt
+@@ -2,7 +2,7 @@ include_directories(${SCAFACOS_INCLUDE_DIRS})
+
+ file(GLOB Scafacos_SRC *.cpp)
+ add_library(Scafacos SHARED ${Scafacos_SRC})
+-install(TARGETS Scafacos DESTINATION ${PYTHON_INSTDIR})
++install(TARGETS Scafacos DESTINATION ${PYTHON_INSTDIR}/espressomd)
+ add_dependencies(Scafacos EspressoConfig)
+
+ target_link_libraries(Scafacos ${SCAFACOS_LDFLAGS})
+diff --git a/src/core/shapes/CMakeLists.txt b/src/core/shapes/CMakeLists.txt
+index 0e5ecaa..5be3a9d 100644
+--- a/src/core/shapes/CMakeLists.txt
++++ b/src/core/shapes/CMakeLists.txt
+@@ -1,4 +1,5 @@
+ file(GLOB Shapes_SRC *.cpp)
+ add_library(Shapes SHARED ${Shapes_SRC})
++install(TARGETS Shapes LIBRARY DESTINATION ${LIBDIR})
+ add_dependencies(Shapes EspressoConfig)
+ set_target_properties(Shapes PROPERTIES MACOSX_RPATH TRUE)
+diff --git a/src/core/utils/CMakeLists.txt b/src/core/utils/CMakeLists.txt
+index ec0f6f7..4cd8ada 100644
+--- a/src/core/utils/CMakeLists.txt
++++ b/src/core/utils/CMakeLists.txt
+@@ -1,3 +1,4 @@
+ file(GLOB EspressoUtils_SRC *.cpp)
+ add_library(EspressoUtils SHARED ${EspressoUtils_SRC})
++install(TARGETS EspressoUtils LIBRARY DESTINATION ${LIBDIR})
+ set_target_properties(EspressoUtils PROPERTIES MACOSX_RPATH TRUE)
+diff --git a/src/script_interface/CMakeLists.txt b/src/script_interface/CMakeLists.txt
+index 8aff034..59c1c9d 100644
+--- a/src/script_interface/CMakeLists.txt
++++ b/src/script_interface/CMakeLists.txt
+@@ -28,6 +28,7 @@ if(H5MD)
+ )
+ endif(H5MD)
+ add_library(EspressoScriptInterface SHARED ${EspressoScriptInterface_SRC})
++install(TARGETS EspressoScriptInterface LIBRARY DESTINATION ${LIBDIR})
+ add_dependencies(EspressoScriptInterface EspressoConfig EspressoConfig)
+ set_target_properties(EspressoScriptInterface PROPERTIES MACOSX_RPATH TRUE)
+ target_link_libraries(EspressoScriptInterface EspressoCore)
+--
+2.10.2
+