summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-03-07 17:01:31 +0100
committerGuilherme Amadio <amadio@gentoo.org>2024-03-08 09:59:31 +0100
commit3a9f4fcb4cf6a2403b9567e0edd83e7795faf2d9 (patch)
treed4a144d149c48de5ef80c70d9c40bce198c16d3c /sci-physics
parentdev-cpp/scitokens-cpp: add 1.1.1 (diff)
downloadgentoo-3a9f4fcb4cf6a2403b9567e0edd83e7795faf2d9.tar.gz
gentoo-3a9f4fcb4cf6a2403b9567e0edd83e7795faf2d9.tar.bz2
gentoo-3a9f4fcb4cf6a2403b9567e0edd83e7795faf2d9.zip
sci-physics/hepmc: Filter lto flags
Closes: https://bugs.gentoo.org/863284 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/hepmc/hepmc-2.06.11.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sci-physics/hepmc/hepmc-2.06.11.ebuild b/sci-physics/hepmc/hepmc-2.06.11.ebuild
index 2a135d0936c4..9d22aed74fd1 100644
--- a/sci-physics/hepmc/hepmc-2.06.11.ebuild
+++ b/sci-physics/hepmc/hepmc-2.06.11.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
MYP=HepMC-${PV}
@@ -70,6 +70,9 @@ src_prepare() {
}
src_configure() {
+ # error: ‘hepevt_’ violates the C++ One Definition Rule [-Werror=odr]
+ # Bug 863284
+ filter-lto
# use MeV over GeV and mm over cm
local mycmakeargs=(
-Dlength=$(usex cm CM MM)