summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-03-22 12:45:49 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-03-22 12:45:49 +0100
commit4875f227f3e4a733d1290d85d275e3225ae05e27 (patch)
tree247b41d9a2495863c5c08ec5adc3b83577adbeda /sci-misc/flashdot
parentkde-apps/kwave: Add missing KCoreAddons link (diff)
downloadgentoo-4875f227f3e4a733d1290d85d275e3225ae05e27.tar.gz
gentoo-4875f227f3e4a733d1290d85d275e3225ae05e27.tar.bz2
gentoo-4875f227f3e4a733d1290d85d275e3225ae05e27.zip
sci-misc/flashdot: make it build again
Closes: https://bugs.gentoo.org/641894 Closes: https://bugs.gentoo.org/770799 Closes: https://bugs.gentoo.org/804663 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-misc/flashdot')
-rw-r--r--sci-misc/flashdot/files/flashdot-1.1.4-Makefile.patch10
-rw-r--r--sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch11
-rw-r--r--sci-misc/flashdot/flashdot-1.1.4-r1.ebuild24
3 files changed, 44 insertions, 1 deletions
diff --git a/sci-misc/flashdot/files/flashdot-1.1.4-Makefile.patch b/sci-misc/flashdot/files/flashdot-1.1.4-Makefile.patch
new file mode 100644
index 000000000000..077367bd2ab0
--- /dev/null
+++ b/sci-misc/flashdot/files/flashdot-1.1.4-Makefile.patch
@@ -0,0 +1,10 @@
+--- a/mathexpr/Makefile 2022-03-22 10:51:43.081062080 +0100
++++ b/mathexpr/Makefile 2022-03-22 10:53:37.226190652 +0100
+@@ -72,6 +72,6 @@
+ # Dependencies
+ depend:
+- $(OCAMLDEP) $(OCAMLINCS) *.mli *.ml > depend
++ $(OCAMLDEP) -I $(XMLLIGHTDIR) $(OCAMLINCSLOCAL) *.mli *.ml > depend
+
+ include depend
+
diff --git a/sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch b/sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch
index 8b00b86d52b7..285a2c746e20 100644
--- a/sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch
+++ b/sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch
@@ -9,3 +9,14 @@
fill_buff ()
in
let s = fill_buff () in
+--- a/mathexpr/mathexpr.ml 2022-03-22 12:36:30.252580025 +0100
++++ b/mathexpr/mathexpr.ml 2022-03-22 12:32:10.594137416 +0100
+@@ -2859,7 +2859,7 @@
+ while true do
+ let n = input f strbuf 0 1024 in
+ if n = 0 then raise Exit else
+- Buffer.add_substring resbuf strbuf 0 n
++ Buffer.add_subbytes resbuf strbuf 0 n
+ done;
+ Buffer.contents resbuf
+ with Exit -> Buffer.contents resbuf
diff --git a/sci-misc/flashdot/flashdot-1.1.4-r1.ebuild b/sci-misc/flashdot/flashdot-1.1.4-r1.ebuild
index 8d31eba90241..3266f2b6d7d3 100644
--- a/sci-misc/flashdot/flashdot-1.1.4-r1.ebuild
+++ b/sci-misc/flashdot/flashdot-1.1.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,6 +22,7 @@ DEPEND="
RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-gsl-ocaml.patch"
+ "${FILESDIR}"/${P}-Makefile.patch
"${FILESDIR}"/${P}-ocaml-4.09.patch
)
@@ -29,6 +30,27 @@ src_prepare() {
default
MAKEOPTS+=" -j1 VERSION=${PV}"
use ocamlopt || MAKEOPTS+=" TARGETS=flashdot_bytecode BYTECODENAME=flashdot"
+ sed -i \
+ -e 's:Gsl_matrix:Gsl.Matrix:g' \
+ -e 's:Gsl_rng:Gsl.Rng:g' \
+ -e 's:Gsl_randist:Gsl.Randist:g' \
+ -e 's:Gsl_sf:Gsl.Sf:g' \
+ -e 's:Gsl_math:Gsl.Math:g' \
+ -e 's:Gsl_vector:Gsl.Vector:g' \
+ -e 's:Gsl_permut:Gsl.Permut:g' \
+ -e 's:Gsl_linalg:Gsl.Linalg:g' \
+ -e 's:Gsl_cdf:Gsl.Cdf:g' \
+ mathexpr/mathexpr.ml \
+ mathexpr/mathexpr.mli \
+ mathexpr/random_rng.ml \
+ mathexpr/sequences.ml \
+ mathexpr/multibin.ml \
+ flashdot.ml \
+ || die
+}
+
+src_configure() {
+ ./configure --prefix=/usr || die
}
src_install() {