summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-15 23:51:05 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-16 00:17:01 +0200
commit77b45431c0630096031a3350e5040b7d11ddb559 (patch)
tree805f8a41a4b4b9e63a1b94137710150dff5caace /sci-mathematics
parentmedia-video/mpv: loosen libplacebo requirement in live (diff)
downloadgentoo-77b45431c0630096031a3350e5040b7d11ddb559.tar.gz
gentoo-77b45431c0630096031a3350e5040b7d11ddb559.tar.bz2
gentoo-77b45431c0630096031a3350e5040b7d11ddb559.zip
sci-mathematics/coq: add pkg_preinst upgrade from 8.12
Closes: https://bugs.gentoo.org/910236 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/coq-8.15.2.ebuild9
-rw-r--r--sci-mathematics/coq/coq-8.16.1.ebuild9
-rw-r--r--sci-mathematics/coq/coq-8.17.0.ebuild9
-rw-r--r--sci-mathematics/coq/coq-8.17.1.ebuild9
4 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/coq/coq-8.15.2.ebuild b/sci-mathematics/coq/coq-8.15.2.ebuild
index c94ce21f129a..5348f67f9136 100644
--- a/sci-mathematics/coq/coq-8.15.2.ebuild
+++ b/sci-mathematics/coq/coq-8.15.2.ebuild
@@ -109,3 +109,12 @@ src_install() {
dosym $(ocamlc -where)/${sym} /usr/$(get_libdir)/${sym}
done
}
+
+pkg_preinst() {
+ # bug https://bugs.gentoo.org/910236
+ if has_version "sci-mathematics/coq:0/8.12.0" && [[ ! -L /usr/lib64/coq ]]
+ then
+ einfo "Removing colliding directory from version 8.12: /usr/lib64/coq"
+ rm -rf /usr/lib64/coq
+ fi
+}
diff --git a/sci-mathematics/coq/coq-8.16.1.ebuild b/sci-mathematics/coq/coq-8.16.1.ebuild
index a8dc37656492..374b1e3334e1 100644
--- a/sci-mathematics/coq/coq-8.16.1.ebuild
+++ b/sci-mathematics/coq/coq-8.16.1.ebuild
@@ -109,3 +109,12 @@ src_install() {
dosym $(ocamlc -where)/${sym} /usr/$(get_libdir)/${sym}
done
}
+
+pkg_preinst() {
+ # bug https://bugs.gentoo.org/910236
+ if has_version "sci-mathematics/coq:0/8.12.0" && [[ ! -L /usr/lib64/coq ]]
+ then
+ einfo "Removing colliding directory from version 8.12: /usr/lib64/coq"
+ rm -rf /usr/lib64/coq
+ fi
+}
diff --git a/sci-mathematics/coq/coq-8.17.0.ebuild b/sci-mathematics/coq/coq-8.17.0.ebuild
index 495f48055a82..45b99385ac67 100644
--- a/sci-mathematics/coq/coq-8.17.0.ebuild
+++ b/sci-mathematics/coq/coq-8.17.0.ebuild
@@ -110,3 +110,12 @@ src_install() {
einstalldocs
}
+
+pkg_preinst() {
+ # bug https://bugs.gentoo.org/910236
+ if has_version "sci-mathematics/coq:0/8.12.0" && [[ ! -L /usr/lib64/coq ]]
+ then
+ einfo "Removing colliding directory from version 8.12: /usr/lib64/coq"
+ rm -rf /usr/lib64/coq
+ fi
+}
diff --git a/sci-mathematics/coq/coq-8.17.1.ebuild b/sci-mathematics/coq/coq-8.17.1.ebuild
index f634026e1cda..fb5c53f57eed 100644
--- a/sci-mathematics/coq/coq-8.17.1.ebuild
+++ b/sci-mathematics/coq/coq-8.17.1.ebuild
@@ -110,3 +110,12 @@ src_install() {
einstalldocs
}
+
+pkg_preinst() {
+ # bug https://bugs.gentoo.org/910236
+ if has_version "sci-mathematics/coq:0/8.12.0" && [[ ! -L /usr/lib64/coq ]]
+ then
+ einfo "Removing colliding directory from version 8.12: /usr/lib64/coq"
+ rm -rf /usr/lib64/coq
+ fi
+}