summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-12-30 20:38:36 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-12-30 20:38:36 +0700
commit494cb4ade67b218c49cd94e7fc0d857c5abe2429 (patch)
treea6f00c09079a35ae7139e8ba1cdd59f1345bb69d /sci-mathematics
parentmedia-gfx/asymptote: bump to 2.95 (diff)
downloadgentoo-494cb4ade67b218c49cd94e7fc0d857c5abe2429.tar.gz
gentoo-494cb4ade67b218c49cd94e7fc0d857c5abe2429.tar.bz2
gentoo-494cb4ade67b218c49cd94e7fc0d857c5abe2429.zip
sci-mathematics/wxmaxima: bump to 24.11.0
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-24.11.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index 87911066a6c7..e8ef015deabf 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,3 +1,4 @@
DIST wxmaxima-24.02.1.tar.gz 17048739 BLAKE2B 207365951d911d160c55c9e10308b2645129082d0ce72c1b4a2ad8e6d5d0469beb4f8faeb8c48965bfa1c4df8f4ecb7ace8f0f9a5193f0bbc4d002437bc8fe77 SHA512 f16b4c974e0bb3d2454465498fae09d3995278a4ac1f1f8c756716bcf5e560925c115259e6540b57a08910b65e897fba896be7f527ed80ba4e3cb7c4863ca6cc
DIST wxmaxima-24.05.0.tar.gz 16824007 BLAKE2B b6d6db89c20b76713c19b810d24571d6ded3937573ef72f8c8a73cdf870e164da6916b602f4e6970e6094eb1c4e575de62f06a20f14ee75679c70cff6a6629cb SHA512 62a5911220fc1a9403ca3af11110b9043cffcf0b3a1ef6e6a87f74e63de6a00e2bf809db1a05fe2b5bc40da155746c05d68ff247c424c63a6bd6724b5fe12be9
DIST wxmaxima-24.08.0.tar.gz 15868393 BLAKE2B 45aa10b0d1844c988110afdf23516e68e33ff2d482aaae4d560b62dc349976963515113073b58e3610ee376664a3bc7d6401a8d67c59ad6ef6a9f603e901d9f0 SHA512 2e0a46c9cedc938cfa9deb444b9f3f222c2f49db762b617deba0ee67710454e5cecb1611bfac64385b4161724a1356eae57fd433e5c44486df799d3675dcd8c4
+DIST wxmaxima-24.11.0.tar.gz 15949384 BLAKE2B e91af88739a8b636a217ea1b62b2df6757bf1f615c2b52f5b1a6f5d07f9f2b5a7ffe536d8fb4ea4c52df64d06f382bd187eac378adc270eeba832aa3cfd51037 SHA512 ff547154f172c0f008febb10d1258d7ee1635b1dc6f3ae9e1b39cfad4ac65ab4710c3d65318fc0c6b7f04a4c9d0d0ac66553e7a98e4fe5b05b5f4e6c8854077e
diff --git a/sci-mathematics/wxmaxima/wxmaxima-24.11.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-24.11.0.ebuild
new file mode 100644
index 000000000000..18b5ffff5949
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-24.11.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake plocale wxwidgets xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test webkit"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}[webkit?]"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "s|GPL.txt ||g" -e "s|share/doc/${PN}|share/doc/${PF}|g" -i CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f locales/manual/${1}.po
+ rm -f info/${PN}.${1}.md
+ rm -f info/${PN}.${1}.html
+ sed -e "\\|/${1}/wxmaxima.1|d" -i data/CMakeLists.txt
+ }
+ plocale_find_changes locales/wxMaxima '' '.po'
+ plocale_for_each_disabled_locale rm_po
+}
+
+src_configure() {
+ setup-wxwidgets
+
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ -DWXM_DISABLE_WEBVIEW=$(usex webkit OFF ON)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ )
+
+ local test
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake_src_install
+}