summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/xmds
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/xmds')
-rw-r--r--sci-mathematics/xmds/Manifest3
-rw-r--r--sci-mathematics/xmds/files/xmds-1.6.5-gcc43.patch108
-rw-r--r--sci-mathematics/xmds/metadata.xml18
-rw-r--r--sci-mathematics/xmds/xmds-1.6.5.ebuild58
-rw-r--r--sci-mathematics/xmds/xmds-1.6.6.ebuild51
5 files changed, 238 insertions, 0 deletions
diff --git a/sci-mathematics/xmds/Manifest b/sci-mathematics/xmds/Manifest
new file mode 100644
index 000000000000..e0146b2f4798
--- /dev/null
+++ b/sci-mathematics/xmds/Manifest
@@ -0,0 +1,3 @@
+DIST xmds-1.6.5.tar.gz 528593 SHA256 f7128c7c847bafd3a5ed582415cbddd1f31234278d62231faaeb9bec04d6b5ff
+DIST xmds-1.6.6.tar.gz 607585 SHA256 0deb74cf52ea9df58d1a5714d7edd42e027c06ae3eb2cfc12f1fcf477f69f11e
+DIST xmds_doc_20080226.pdf 8093270 SHA256 93ca478d70cfc684cabb24e278181a50f70f4a2b769e8cf7028b6ecc1cb10009
diff --git a/sci-mathematics/xmds/files/xmds-1.6.5-gcc43.patch b/sci-mathematics/xmds/files/xmds-1.6.5-gcc43.patch
new file mode 100644
index 000000000000..766056d5ae51
--- /dev/null
+++ b/sci-mathematics/xmds/files/xmds-1.6.5-gcc43.patch
@@ -0,0 +1,108 @@
+diff -Naurp xmds-1.6.5-orig/source/xmds_integrate_ark45.cc xmds-1.6.5/source/xmds_integrate_ark45.cc
+--- xmds-1.6.5-orig/source/xmds_integrate_ark45.cc 2008-06-28 21:48:21.000000000 +0200
++++ xmds-1.6.5/source/xmds_integrate_ark45.cc 2008-06-28 21:48:57.000000000 +0200
+@@ -35,6 +35,7 @@
+ #include <xmds_simulation.h>
+ #include <xmds_vector.h>
+ #include <cstdlib>
++#include <cstring>
+
+ // **************************************************************************
+ // **************************************************************************
+@@ -289,7 +290,7 @@ void xmdsIntegrateARK45::writeTimestepEr
+ fprintf(outfile, "for(unsigned long _i0=0; _i0<_%s_size; _i0++){\n", fieldName);
+ }
+ fprintf(outfile, " for(unsigned long _i1=0; _i1<_%s_main_ncomponents; _i1++){\n", fieldName);
+- if (strcmp(typeName, "complex") == 0) {
++ if (std::strcmp(typeName, "complex") == 0) {
+ fprintf(outfile, " _temp_mod=mod2(_%s_main[_%s_main_index_pointer + _i1]);\n", fieldName, fieldName);
+ }
+ else {
+@@ -347,7 +348,7 @@ void xmdsIntegrateARK45::writeTimestepEr
+ }
+ fprintf(outfile, " for(unsigned long _i1=0; _i1<_%s_main_ncomponents; _i1++)\n", fieldName);
+
+- if (strcmp(typeName, "complex") == 0) {
++ if (std::strcmp(typeName, "complex") == 0) {
+ fprintf(outfile, " if(mod2(_%s_main[_%s_main_index_pointer + _i1])>_peak[_i1]){\n", fieldName, fieldName);
+ fprintf(outfile, " _temp_error=mod(_%s_main[_%s_main_index_pointer + _i1]-_checkfield[_%s_main_index_pointer + _i1])/(mod(_%s_main[_%s_main_index_pointer + _i1])+1e-20);\n", fieldName, fieldName, fieldName, fieldName, fieldName);
+ }
+@@ -364,7 +365,7 @@ void xmdsIntegrateARK45::writeTimestepEr
+ else{ // if ndims==0
+ fprintf(outfile, " for(unsigned long _i1=0; _i1<_%s_main_ncomponents; _i1++){\n", fieldName);
+
+- if (strcmp(typeName, "complex") == 0) {
++ if (std::strcmp(typeName, "complex") == 0) {
+ fprintf(outfile, " _temp_error=mod(_%s_main[_i1]-_checkfield[_i1])/(mod(_%s_main[_i1])+1e-20);\n", fieldName, fieldName);
+ }
+ else{
+diff -Naurp xmds-1.6.5-orig/source/xmds_integrate_ark89.cc xmds-1.6.5/source/xmds_integrate_ark89.cc
+--- xmds-1.6.5-orig/source/xmds_integrate_ark89.cc 2008-06-28 21:48:21.000000000 +0200
++++ xmds-1.6.5/source/xmds_integrate_ark89.cc 2008-06-28 21:48:57.000000000 +0200
+@@ -35,6 +35,7 @@
+ #include <xmds_simulation.h>
+ #include <xmds_vector.h>
+ #include <cstdlib>
++#include <cstring>
+
+ // **************************************************************************
+ // **************************************************************************
+@@ -284,7 +285,7 @@ void xmdsIntegrateARK89::writeTimestepEr
+ fprintf(outfile, "for (unsigned long _i0=0; _i0<_%s_size; _i0++){\n", fieldName);
+ }
+ fprintf(outfile, " for (unsigned long _i1=0; _i1<_%s_main_ncomponents; _i1++){\n", fieldName);
+- if (strcmp(typeName, "complex") == 0) {
++ if (std::strcmp(typeName, "complex") == 0) {
+ fprintf(outfile, " _temp_mod=mod2(_%s_main[_%s_main_index_pointer + _i1]);\n", fieldName, fieldName);
+ }
+ else {
+@@ -334,7 +335,7 @@ void xmdsIntegrateARK89::writeTimestepEr
+ }
+ fprintf(outfile, " for (unsigned long _i1=0; _i1<_%s_main_ncomponents; _i1++)\n", fieldName);
+
+- if (strcmp(typeName, "complex") == 0) {
++ if (std::strcmp(typeName, "complex") == 0) {
+ fprintf(outfile, " if (mod2(_%s_main[_%s_main_index_pointer + _i1])>_peak[_i1]){\n", fieldName, fieldName);
+ fprintf(outfile, " _temp_error=mod(_%s_main[_%s_main_index_pointer + _i1]-_checkfield[_%s_main_index_pointer + _i1])/(mod(_%s_main[_%s_main_index_pointer + _i1])+1e-20);\n", fieldName, fieldName, fieldName, fieldName, fieldName);
+ }
+@@ -352,7 +353,7 @@ void xmdsIntegrateARK89::writeTimestepEr
+
+ fprintf(outfile, " for (unsigned long _i1=0; _i1<_%s_main_ncomponents; _i1++){\n", fieldName);
+
+- if (strcmp(typeName, "complex") == 0){
++ if (std::strcmp(typeName, "complex") == 0){
+ fprintf(outfile, " _temp_error=mod(_%s_main[_i1]-_checkfield[_i1])/(mod(_%s_main[_i1])+1e-20);\n", fieldName, fieldName);
+ }
+ else{
+diff -Naurp xmds-1.6.5-orig/source/xmds_simulation.h xmds-1.6.5/source/xmds_simulation.h
+--- xmds-1.6.5-orig/source/xmds_simulation.h 2008-06-28 21:48:21.000000000 +0200
++++ xmds-1.6.5/source/xmds_simulation.h 2008-06-28 21:48:57.000000000 +0200
+@@ -40,6 +40,8 @@
+ #include <xmds_sequence.h>
+ #include <xmds_globals.h>
+
++#include <string>
++
+ // *****************************************************************************
+ // *****************************************************************************
+ // xmdsSimulation
+diff -Naurp xmds-1.6.5-orig/source/xsil2graphics.cc xmds-1.6.5/source/xsil2graphics.cc
+--- xmds-1.6.5-orig/source/xsil2graphics.cc 2008-06-28 21:48:21.000000000 +0200
++++ xmds-1.6.5/source/xsil2graphics.cc 2008-06-28 21:48:57.000000000 +0200
+@@ -40,6 +40,7 @@
+ #include <xsil_field.h>
+ #include <getopt_xmds.h>
+ #include <iostream>
++#include <cstring>
+
+ // **********************************************************************
+
+@@ -306,7 +307,7 @@ int main(
+
+ const DOMString *mgName = nextElement->getAttribute("Name");
+ int mgNumber = i+1;
+- if (strcmp("breakpoint", mgName->c_str()) == 0) {
++ if (std::strcmp("breakpoint", mgName->c_str()) == 0) {
+ mgNumber = 1;
+ }
+ else {
diff --git a/sci-mathematics/xmds/metadata.xml b/sci-mathematics/xmds/metadata.xml
new file mode 100644
index 000000000000..607ce9407204
--- /dev/null
+++ b/sci-mathematics/xmds/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>tomka@gentoo.org</email>
+ <name>Thomas Kahle</name>
+ </maintainer>
+ <longdescription lang="en">
+XMDS is a code generator that integrates differential equations (ODEs, PDEs and
+SDEs are all supported). The system of equations to be integrated is specified
+in a XML file, which XMDS then uses to generate a C++ integrator. The code can
+autamatically take advantage of MPI and FFTW.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">xmds</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/xmds/xmds-1.6.5.ebuild b/sci-mathematics/xmds/xmds-1.6.5.ebuild
new file mode 100644
index 000000000000..4ddb29d68b82
--- /dev/null
+++ b/sci-mathematics/xmds/xmds-1.6.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+doc_ver=20080226
+
+DESCRIPTION="XMDS - The eXtensible Multi-Dimensional Simulator"
+HOMEPAGE="http://www.xmds.org"
+SRC_URI="mirror://sourceforge/xmds/${P}.tar.gz
+ doc? ( mirror://sourceforge/xmds/xmds_doc_${doc_ver}.pdf )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples mpi threads"
+
+DEPEND="sci-libs/fftw
+ mpi? ( virtual/mpi )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.6.5-gcc43.patch
+ touch "${S}/source/version.h"
+
+ # Fix broken installation of sample scripts.
+ sed -i -e 's/install-data-am: install-dist_doc_examplesDATA install-man/install-data-am: install-man/' Makefile.in
+}
+
+src_compile() {
+ local my_opts=""
+
+ if has_version "=sci-libs/fftw-3*" ; then
+ my_opts="${my_opts} --enable-fftw3"
+ fi
+
+ econf \
+ $(use_enable mpi) \
+ $(use_enable threads) \
+ ${my_opts} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}/xmds_doc_${doc_ver}.pdf"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}
diff --git a/sci-mathematics/xmds/xmds-1.6.6.ebuild b/sci-mathematics/xmds/xmds-1.6.6.ebuild
new file mode 100644
index 000000000000..9d3e48b854d2
--- /dev/null
+++ b/sci-mathematics/xmds/xmds-1.6.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+doc_ver=20080226
+
+DESCRIPTION="XMDS - The eXtensible Multi-Dimensional Simulator"
+HOMEPAGE="http://www.xmds.org"
+SRC_URI="mirror://sourceforge/xmds/${P}.tar.gz
+ doc? ( mirror://sourceforge/xmds/xmds_doc_${doc_ver}.pdf )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples mpi threads"
+
+DEPEND="sci-libs/fftw
+ mpi? ( virtual/mpi )"
+
+src_compile() {
+ local my_opts=""
+
+ if has_version "=sci-libs/fftw-3*" ; then
+ my_opts="${my_opts} --enable-fftw3"
+ fi
+
+ econf \
+ $(use_enable mpi) \
+ $(use_enable threads) \
+ ${my_opts} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}/xmds_doc_${doc_ver}.pdf"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ for i in "${D}"/usr/share/doc/${PN}/examples/* ; do
+ doins "$i"
+ done
+ fi
+
+ rm -rf "${D}/usr/share/doc/${PN}"
+}