summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-10-03 19:37:03 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-10-03 19:37:41 +0200
commitf74471c1125c53d761662448593e52e92b816b75 (patch)
tree9f81076d0285c64095f162aeca81f46083ead9ea /sci-libs
parentRevert "www-client/firefox: enable wayland+pgo build on rapid" (diff)
downloadgentoo-f74471c1125c53d761662448593e52e92b816b75.tar.gz
gentoo-f74471c1125c53d761662448593e52e92b816b75.tar.bz2
gentoo-f74471c1125c53d761662448593e52e92b816b75.zip
sci-libs/armadillo: add 11.4.0
Enable tests properly too. Closes: https://bugs.gentoo.org/771669 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/armadillo/Manifest1
-rw-r--r--sci-libs/armadillo/armadillo-11.4.0.ebuild156
-rw-r--r--sci-libs/armadillo/files/armadillo-11.4.0-extratests.patch12
3 files changed, 169 insertions, 0 deletions
diff --git a/sci-libs/armadillo/Manifest b/sci-libs/armadillo/Manifest
index 09b6ea909b92..d8c0ddb187dc 100644
--- a/sci-libs/armadillo/Manifest
+++ b/sci-libs/armadillo/Manifest
@@ -1,3 +1,4 @@
DIST armadillo-10.2.0.tar.xz 6042348 BLAKE2B e85f24ca7137c3a8c8fc53db15b382f2e4d468673c99e036ef9b4a4436be47d24a37664dfa88ff9effa08a4c868bd212d03c204dda09cd26038a0f8ccbf61375 SHA512 c5d6f4bac0acba63fbd7681653d521249fd303ffbbc5b18df71500eb111514c1d09db600a580091d6a23c83748c109c30938bbcd80a3a0b2c25e2fdea932f2cd
DIST armadillo-10.7.1.tar.xz 6258792 BLAKE2B cc820638dd7b571b5654e14bb82ced3586cb2950b1fb5aebf6bdd9439151353c4750296aaa4d15144ade6ed13e52743ac41e3cf34b824809931c3c031804bddf SHA512 b9be6a38165a4d23a61715a3c3f970dcb9b813bebd51b7372a4e8349ab2c351cd5c74f662d860911b30b2b816f2eb1255768fab1497ec087a63a07f56f74327f
DIST armadillo-10.8.2.tar.xz 6262832 BLAKE2B f8a5a66464614661bcccffb8138434d117ad07dcea5f89ddde45df293df5dd4f10def2085b85d37386337fd8bd0152914a957e0b1b7919a47ec8b1a79e92b90b SHA512 720fadad491dfeeb894544b0305cd64a0e0402e66fc788949ecd54c0b1a3b9c3ede9f75b081f832931d59d2bd59529cebb9d5b57b8582df869765cac01c2979b
+DIST armadillo-11.4.0.tar.xz 6804388 BLAKE2B cb44d248cf817f66cc0b6aa968535e266282775b20035f46f3158687100c0f49c6cf4fad8d1f2ec1741f9bceb06c5a841f20f3b7e59146f2fe57c86d00741434 SHA512 21d58b383229f55bf6a3b217c04901982b484b6d806dd3c4a72ebe5a9614f63f9429ca31ea7cfc26672b70e01a0b9263a9d4edf69a0080706ade87852f94970c
diff --git a/sci-libs/armadillo/armadillo-11.4.0.ebuild b/sci-libs/armadillo/armadillo-11.4.0.ebuild
new file mode 100644
index 000000000000..415194976a72
--- /dev/null
+++ b/sci-libs/armadillo/armadillo-11.4.0.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake toolchain-funcs multilib
+
+DESCRIPTION="Streamlined C++ linear algebra library"
+HOMEPAGE="http://arma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arma/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0/11"
+KEYWORDS="~amd64 ~arm ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="arpack blas doc examples hdf5 lapack mkl superlu test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( arpack lapack superlu )"
+
+# atlas? ( sci-libs/atlas[lapack] )
+
+RDEPEND="
+ dev-libs/boost
+ arpack? ( sci-libs/arpack )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )
+ superlu? ( >=sci-libs/superlu-5.2 )
+"
+
+DEPEND="${RDEPEND}
+ arpack? ( virtual/pkgconfig )
+ blas? ( virtual/pkgconfig )
+ hdf5? ( sci-libs/hdf5:= )
+ lapack? ( virtual/pkgconfig )
+ mkl? ( sci-libs/mkl )
+"
+PDEPEND="${RDEPEND}
+ hdf5? ( sci-libs/hdf5:= )
+ mkl? ( sci-libs/mkl )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-extratests.patch"
+)
+
+src_prepare() {
+ # avoid the automagic cmake macros...
+ sed -i -e 's/^ *include(ARMA_Find/# No automagic include(ARMA_Find/g' CMakeLists.txt || die
+
+ # ... except for mkl, since without a license it's hard to figure out what to do there
+ if use mkl; then
+ sed -i -e 's/^# No automagic include(ARMA_FindMKL)/include(ARMA_FindMKL)/g' CMakeLists.txt || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_LIB_DIR="${EPREFIX}/usr/$(get_libdir)"
+ )
+ if use arpack; then
+ mycmakeargs+=(
+ -DARPACK_FOUND=ON
+ -DARPACK_LIBRARY="$($(tc-getPKG_CONFIG) --libs arpack)"
+ )
+ else
+ mycmakeargs+=(
+ -DARPACK_FOUND=OFF
+ )
+ fi
+# if use atlas; then
+# local c=atlas-cblas l=atlas-clapack
+# $(tc-getPKG_CONFIG) --exists ${c}-threads && c+=-threads
+# $(tc-getPKG_CONFIG) --exists ${l}-threads && l+=-threads
+# mycmakeargs+=(
+# -DCBLAS_FOUND=ON
+# -DCBLAS_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${c} | sed 's/-I//')"
+# -DCBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${c})"
+# -DCLAPACK_FOUND=ON
+# -DCLAPACK_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${l} | sed 's/-I//')"
+# -DCLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${l})"
+# )
+# fi
+ if use blas; then
+ mycmakeargs+=(
+ -DBLAS_FOUND=ON
+ -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
+ )
+ else
+ mycmakeargs+=(
+ -DBLAS_FOUND=OFF
+ )
+ fi
+ if use hdf5; then
+ mycmakeargs+=(
+ -DDETECT_HDF5=ON
+ -DHDF5_LIBRARIES="-lhdf5"
+ -DHDF5_INCLUDE_DIRS=/usr/include
+ )
+ else
+ mycmakeargs+=(
+ -DDETECT_HDF5=OFF
+ )
+ fi
+ if use lapack; then
+ mycmakeargs+=(
+ -DLAPACK_FOUND=ON
+ -DLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ else
+ mycmakeargs+=(
+ -DLAPACK_FOUND=OFF
+ )
+ fi
+ if use superlu; then
+ mycmakeargs+=(
+ -DSuperLU_FOUND=ON
+ -DSuperLU_LIBRARY="$($(tc-getPKG_CONFIG) --libs superlu)"
+ -DSuperLU_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I superlu | awk '{print $1}' | sed 's/-I//')"
+ )
+ else
+ mycmakeargs+=(
+ -DSuperLU_FOUND=OFF
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_src_test || die
+
+ pushd tests2 > /dev/null
+ emake \
+ CXX="$(tc-getCXX)" \
+ CXX_FLAGS="-I../include ${CXXFLAGS} -DARMA_USE_BLAS -DARMA_USE_LAPACK" \
+ LIB_FLAGS="-L.. -larmadillo $($(tc-getPKG_CONFIG) --libs blas lapack)"
+ LD_LIBRARY_PATH="..:${LD_LIBRARY_PATH}" ./main || die
+ emake clean
+ popd > /dev/null
+}
+
+src_install() {
+ cmake_src_install
+
+ dodoc README.md
+ use doc && dodoc *pdf *html
+
+ if use examples; then
+ docinto examples
+ dodoc -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/sci-libs/armadillo/files/armadillo-11.4.0-extratests.patch b/sci-libs/armadillo/files/armadillo-11.4.0-extratests.patch
new file mode 100644
index 000000000000..7efb67b5b139
--- /dev/null
+++ b/sci-libs/armadillo/files/armadillo-11.4.0-extratests.patch
@@ -0,0 +1,12 @@
+diff -ruN armadillo-11.4.0.orig/tests2/Makefile armadillo-11.4.0/tests2/Makefile
+--- armadillo-11.4.0.orig/tests2/Makefile 2022-10-03 19:26:59.699937940 +0200
++++ armadillo-11.4.0/tests2/Makefile 2022-10-03 19:27:24.954277418 +0200
+@@ -3,7 +3,7 @@
+ #LIB_FLAGS = -lblas -llapack
+ #LIB_FLAGS = -lopenblas -llapack
+
+-CXX_FLAGS = -std=c++11 -Wshadow -Wall -pedantic -O0
++#CXX_FLAGS = -std=c++11 -Wshadow -Wall -pedantic -O0
+ #CXX_FLAGS = -std=c++11 -Wshadow -Wall -pedantic -O0 -fopenmp
+ #CXX_FLAGS = -std=c++11 -Wshadow -Wall -pedantic -O0 -DARMA_DONT_USE_WRAPPER
+ #CXX_FLAGS = -std=c++11 -Wshadow -Wall -pedantic -O0 -fsanitize=address -fsanitize=leak -fsanitize=undefined -fsanitize=bounds -fsanitize=bounds-strict -g