summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-07-13 16:46:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-07-13 17:01:04 +0200
commite0bfe4de9e72f5ed0d4675624b966babb254cd08 (patch)
tree794f779fd653dca7fe373ad41e195383725d7303 /sci-libs
parentsci-visualization/labplot: add kde-invent upstream metadata (diff)
downloadgentoo-e0bfe4de9e72f5ed0d4675624b966babb254cd08.tar.gz
gentoo-e0bfe4de9e72f5ed0d4675624b966babb254cd08.tar.bz2
gentoo-e0bfe4de9e72f5ed0d4675624b966babb254cd08.zip
sci-libs/stellarsolver: add 2.6
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/stellarsolver/Manifest1
-rw-r--r--sci-libs/stellarsolver/stellarsolver-2.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/stellarsolver/Manifest b/sci-libs/stellarsolver/Manifest
index 5b8e51985b49..c75842ef8603 100644
--- a/sci-libs/stellarsolver/Manifest
+++ b/sci-libs/stellarsolver/Manifest
@@ -1 +1,2 @@
DIST stellarsolver-2.5.tar.gz 23402988 BLAKE2B ec1ab428413104a329128e3e90883884eedf2c031fb4f3f5a8ab7579243a7b7a496579f3127ad0324176cf825d02a417e1538272b931a87090f1373adf0d1239 SHA512 003522ac0b4130e0ca16ccb617743e3716aa2a182ad63abfb901ea0b47c28a745e8ca1e5b7874d17636ff948b1ebc055277557f89a159e425af7d2a64f513fe8
+DIST stellarsolver-2.6.tar.gz 26565848 BLAKE2B 35cceedca14b6fc062d963a47954b1c06ef908f4f8572776ca4de6a4b618eb72445cf05aefc5c62fa7a0a55e3719e6201f5734a827fc2fe752b919a30bd9c0cc SHA512 28c15e1cbc4e5d9b852001b80e8183ea98557ef0bdf0c9b3a238485d9594058bbd7003abc77cb41caf6717c809c7a3d1babd236adbeac6bb0e383f5a73815e95
diff --git a/sci-libs/stellarsolver/stellarsolver-2.6.ebuild b/sci-libs/stellarsolver/stellarsolver-2.6.ebuild
new file mode 100644
index 000000000000..e257a6f5826b
--- /dev/null
+++ b/sci-libs/stellarsolver/stellarsolver-2.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Cross-platform Sextractor and Astrometry.net-Based internal astrometric solver"
+HOMEPAGE="https://github.com/rlancaste/stellarsolver"
+SRC_URI="https://github.com/rlancaste/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ sci-libs/cfitsio:=
+ sci-libs/gsl:=
+ sci-astronomy/wcslib:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # bug #862930
+ filter-lto
+
+ local mycmakeargs=(
+ -DUSE_QT5=ON # future TODO: check if Qt6 can be enabled safely
+ -DBUILD_CLI=OFF # nothing is installed (yet?)
+ )
+
+ cmake_src_configure
+}