summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-02-19 19:17:21 +0100
committerDavid Seifert <soap@gentoo.org>2018-02-19 20:40:47 +0100
commit26131763888b487694813b33de0eda81a6caf998 (patch)
treeb1304bbc653ca4a95f178dff6a1e9a37f64f7563 /sci-libs/xdmf2
parentsci-libs/libdap: Always build in C++14 mode (diff)
downloadgentoo-26131763888b487694813b33de0eda81a6caf998.tar.gz
gentoo-26131763888b487694813b33de0eda81a6caf998.tar.bz2
gentoo-26131763888b487694813b33de0eda81a6caf998.zip
sci-libs/xdmf2: Always build in C++14 mode
Closes: https://bugs.gentoo.org/619604 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sci-libs/xdmf2')
-rw-r--r--sci-libs/xdmf2/xdmf2-1.0_p141226-r1.ebuild7
-rw-r--r--sci-libs/xdmf2/xdmf2-1.0_p141226-r2.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/sci-libs/xdmf2/xdmf2-1.0_p141226-r1.ebuild b/sci-libs/xdmf2/xdmf2-1.0_p141226-r1.ebuild
index fc04d4922d93..a0cf89a25299 100644
--- a/sci-libs/xdmf2/xdmf2-1.0_p141226-r1.ebuild
+++ b/sci-libs/xdmf2/xdmf2-1.0_p141226-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils multilib python-single-r1
+inherit cmake-utils flag-o-matic multilib python-single-r1
DESCRIPTION="eXtensible Data Model and Format"
HOMEPAGE="http://xdmf.org/index.php/Main_Page"
@@ -49,6 +49,9 @@ src_prepare() {
}
src_configure() {
+ # bug 619604
+ append-cxxflags -std=c++14
+
local mycmakeargs=(
$(cmake-utils_use doc XDMF_BUILD_DOCUMENTATION)
$(cmake-utils_use_build test TESTING)
diff --git a/sci-libs/xdmf2/xdmf2-1.0_p141226-r2.ebuild b/sci-libs/xdmf2/xdmf2-1.0_p141226-r2.ebuild
index c7d39a5b0c8c..605039d40cff 100644
--- a/sci-libs/xdmf2/xdmf2-1.0_p141226-r2.ebuild
+++ b/sci-libs/xdmf2/xdmf2-1.0_p141226-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-single-r1
+inherit cmake-utils flag-o-matic python-single-r1
DESCRIPTION="eXtensible Data Model and Format"
HOMEPAGE="http://xdmf.org/index.php/Main_Page"
@@ -53,6 +53,9 @@ src_prepare() {
}
src_configure() {
+ # bug 619604
+ append-cxxflags -std=c++14
+
local mycmakeargs=(
-DBUILD_SHARED_LIBS=1
-DXDMF_BUILD_DOCUMENTATION=$(usex doc)