summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-06-05 16:35:33 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-05 17:10:31 +0200
commit2a2c79e8b4346c594ee2c97cee54fa7a45ea2766 (patch)
treedb9cd4c67676be6b3618a563efdd25b18d75a904 /sci-libs/plplot
parentdev-python/CppHeaderParser: enable py3.9,py3.10 (diff)
downloadgentoo-2a2c79e8b4346c594ee2c97cee54fa7a45ea2766.tar.gz
gentoo-2a2c79e8b4346c594ee2c97cee54fa7a45ea2766.tar.bz2
gentoo-2a2c79e8b4346c594ee2c97cee54fa7a45ea2766.zip
sci-libs/plplot: add support for python-3.9
Bugday 2021-06-05 Byte-compile python package to avoid QA warning Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/21131 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs/plplot')
-rw-r--r--sci-libs/plplot/plplot-5.15.0-r101.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-libs/plplot/plplot-5.15.0-r101.ebuild b/sci-libs/plplot/plplot-5.15.0-r101.ebuild
index a8ca91a4eed2..6941579942fd 100644
--- a/sci-libs/plplot/plplot-5.15.0-r101.ebuild
+++ b/sci-libs/plplot/plplot-5.15.0-r101.ebuild
@@ -6,7 +6,7 @@ EAPI=7
WX_GTK_VER=3.0-gtk3
FORTRAN_NEEDED=fortran
LUA_COMPAT=( lua5-1 )
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit cmake flag-o-matic fortran-2 java-pkg-opt-2 lua-single python-single-r1 toolchain-funcs virtualx wxwidgets
@@ -290,6 +290,8 @@ src_install() {
rm -r "${ED}"/usr/share/doc/${PF}/examples || die
fi
+ use python & python_optimize
+
if use java; then
java-pkg_dojar "${BUILD_DIR}"/examples/java/${PN}.jar
java-pkg_regso "${EPREFIX}"/usr/$(get_libdir)/jni/plplotjavac_wrap.so