summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 23:27:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 08:55:13 +0100
commit06f859cbe85c7d020af20631e4da8d6a6750acda (patch)
treebd380c06cb324f9e8e4c73a4fe9ac7255a4eaae7 /sci-libs/indilib
parentsci-geosciences/qgis: Use appropriate cmake patch (diff)
downloadgentoo-06f859cbe85c7d020af20631e4da8d6a6750acda.tar.gz
gentoo-06f859cbe85c7d020af20631e4da8d6a6750acda.tar.bz2
gentoo-06f859cbe85c7d020af20631e4da8d6a6750acda.zip
sci-libs/indilib: Fix udev rules install path
Thanks-to: James Bates <james.h.bates@gmail.com> Closes: https://bugs.gentoo.org/703952 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/indilib')
-rw-r--r--sci-libs/indilib/indilib-1.8.2-r2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sci-libs/indilib/indilib-1.8.2-r2.ebuild b/sci-libs/indilib/indilib-1.8.2-r2.ebuild
new file mode 100644
index 000000000000..f8b0dd3086fa
--- /dev/null
+++ b/sci-libs/indilib/indilib-1.8.2-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake udev
+
+DESCRIPTION="INDI Astronomical Control Protocol library"
+HOMEPAGE="https://www.indilib.org/"
+SRC_URI="https://github.com/${PN}/${PN/lib/}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+ LGPL-2+ LGPL-2.1+"
+SLOT="0/1"
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
+IUSE="ogg test websocket"
+
+RDEPEND="
+ net-misc/curl
+ sci-libs/cfitsio:=
+ sci-libs/fftw:3.0=
+ sci-libs/gsl:=
+ sci-libs/libnova:=
+ sys-libs/zlib
+ virtual/jpeg:0
+ virtual/libusb:0
+ ogg? (
+ media-libs/libogg
+ media-libs/libtheora
+ )
+ websocket? ( dev-libs/boost:= )
+"
+DEPEND="${RDEPEND}
+ kernel_linux? ( sys-kernel/linux-headers )
+ test? ( >=dev-cpp/gtest-1.8.0 )
+ websocket? ( dev-cpp/websocketpp )
+"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${P/lib/}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINDI_BUILD_QT5_CLIENT=OFF
+ -DINDI_BUILD_UNITTESTS=$(usex test)
+ -DUDEVRULES_INSTALL_DIR="$(get_udevdir)"/rules.d
+ $(cmake_use_find_package ogg OggTheora)
+ -DINDI_BUILD_WEBSOCKET=$(usex websocket)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ BUILD_DIR="${BUILD_DIR}"/test cmake_src_test
+}