summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2015-12-05 23:16:33 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2015-12-05 23:16:33 -0500
commita4952c16e644ae9e7b8be6c3a402cad6eaed8150 (patch)
tree3d18993b3dcf9c8f127afacaab1cee09edf65cd6 /sci-libs/geos/geos-3.5.0.ebuild
parentprofiles/package.mask: re-pmask old vns. ~xen*-4.2.5 since rdeps now use.masked (diff)
downloadgentoo-a4952c16e644ae9e7b8be6c3a402cad6eaed8150.tar.gz
gentoo-a4952c16e644ae9e7b8be6c3a402cad6eaed8150.tar.bz2
gentoo-a4952c16e644ae9e7b8be6c3a402cad6eaed8150.zip
Version Bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-libs/geos/geos-3.5.0.ebuild')
-rw-r--r--sci-libs/geos/geos-3.5.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-libs/geos/geos-3.5.0.ebuild b/sci-libs/geos/geos-3.5.0.ebuild
new file mode 100644
index 000000000000..212c82fbb3ac
--- /dev/null
+++ b/sci-libs/geos/geos-3.5.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_{6,7} )
+inherit autotools eutils python-single-r1 python-utils-r1
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://trac.osgeo.org/geos/"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc php python ruby static-libs"
+
+RDEPEND="
+ php? ( >=dev-lang/php-5.3:* )
+ ruby? ( dev-lang/ruby:* )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ php? ( dev-lang/swig )
+ python? ( dev-lang/swig ${PYTHON_DEPS} )
+ ruby? ( dev-lang/swig )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/3.4.2-solaris-isnan.patch
+ eautoreconf
+ echo "#!${EPREFIX}/bin/bash" > py-compile
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ruby) \
+ $(use_enable php) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+
+ use doc && emake -C "${S}/doc" doxygen-html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use doc && dohtml -r doc/doxygen_docs/html/*
+ use python && python_optimize "${D}$(python_get_sitedir)"/geos/
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}