summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-15 02:33:56 -0400
committerSam James <sam@gentoo.org>2024-03-15 06:46:15 +0000
commiteecdd47e4d8acbe92493140b2ba0a80358d28791 (patch)
tree29788453d12d49ff63ae54f15383129b8f0e2556 /sci-geosciences
parentsys-apps/ethq: filter LTO (diff)
downloadgentoo-eecdd47e4d8acbe92493140b2ba0a80358d28791.tar.gz
gentoo-eecdd47e4d8acbe92493140b2ba0a80358d28791.tar.bz2
gentoo-eecdd47e4d8acbe92493140b2ba0a80358d28791.zip
sci-geosciences/grass: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/862579 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/grass/grass-8.3.1.ebuild10
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/sci-geosciences/grass/grass-8.3.1.ebuild b/sci-geosciences/grass/grass-8.3.1.ebuild
index 166049f1b309..8a3ea23d393d 100644
--- a/sci-geosciences/grass/grass-8.3.1.ebuild
+++ b/sci-geosciences/grass/grass-8.3.1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="sqlite" # bug 572440
-inherit desktop python-single-r1 toolchain-funcs xdg
+inherit desktop flag-o-matic python-single-r1 toolchain-funcs xdg
DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
HOMEPAGE="https://grass.osgeo.org/"
@@ -163,6 +163,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862579
+ # https://github.com/OSGeo/grass/issues/3506
+ #
+ # Do not trust it with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
addwrite /dev/dri/renderD128
local myeconfargs=(
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index 850b3a402fe1..ed68dea0c142 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="sqlite" # bug 572440
-inherit desktop python-single-r1 toolchain-funcs xdg
+inherit desktop flag-o-matic python-single-r1 toolchain-funcs xdg
DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
HOMEPAGE="https://grass.osgeo.org/"
@@ -158,6 +158,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862579
+ # https://github.com/OSGeo/grass/issues/3506
+ #
+ # Do not trust it with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
addwrite /dev/dri/renderD128
local myeconfargs=(