summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-13 21:30:38 -0400
committerSam James <sam@gentoo.org>2024-03-14 01:59:50 +0000
commit9ab2a18c756f5ff7b962584d3563fa7c554add79 (patch)
treecc194a620ded7d9ca7ae29c2f87a28ea4ec8ae58 /sci-geosciences
parentsci-geosciences/gpsbabel: add 1.9.0 (diff)
downloadgentoo-9ab2a18c756f5ff7b962584d3563fa7c554add79.tar.gz
gentoo-9ab2a18c756f5ff7b962584d3563fa7c554add79.tar.bz2
gentoo-9ab2a18c756f5ff7b962584d3563fa7c554add79.zip
sci-geosciences/gpsbabel: mark as LTO-unsafe
Only in older versions. It is fixed starting 1.9.0 Closes: https://bugs.gentoo.org/862576 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsbabel/gpsbabel-1.7.0-r1.ebuild9
-rw-r--r--sci-geosciences/gpsbabel/gpsbabel-1.8.0-r1.ebuild9
2 files changed, 14 insertions, 4 deletions
diff --git a/sci-geosciences/gpsbabel/gpsbabel-1.7.0-r1.ebuild b/sci-geosciences/gpsbabel/gpsbabel-1.7.0-r1.ebuild
index f6c49d49af26..36dfe7b2188f 100644
--- a/sci-geosciences/gpsbabel/gpsbabel-1.7.0-r1.ebuild
+++ b/sci-geosciences/gpsbabel/gpsbabel-1.7.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit qmake-utils
+inherit flag-o-matic qmake-utils
MY_PV="${PV//./_}"
MY_P="${PN}_${MY_PV}"
@@ -64,6 +64,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/862576
+ # Fixed in newer versions: https://github.com/GPSBabel/gpsbabel/pull/824
+ filter-lto
+
econf \
$(use_with doc doc "${S}"/doc/manual) \
QMAKE=$(qt5_get_bindir)/qmake \
diff --git a/sci-geosciences/gpsbabel/gpsbabel-1.8.0-r1.ebuild b/sci-geosciences/gpsbabel/gpsbabel-1.8.0-r1.ebuild
index cfe639e603e8..7e4d5bf44ef1 100644
--- a/sci-geosciences/gpsbabel/gpsbabel-1.8.0-r1.ebuild
+++ b/sci-geosciences/gpsbabel/gpsbabel-1.8.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
CMAKE_IN_SOURCE_BUILD=1
-inherit cmake desktop xdg
+inherit cmake desktop flag-o-matic xdg
MY_PV="${PV//./_}"
MY_P="${PN}_${MY_PV}"
@@ -76,6 +76,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/862576
+ # Fixed in newer versions: https://github.com/GPSBabel/gpsbabel/pull/824
+ filter-lto
+
local mycmakeargs=(
-DGPSBABEL_WITH_LIBUSB=pkgconfig
-DGPSBABEL_WITH_SHAPELIB=pkgconfig