summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-13 21:49:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-13 22:27:50 +0100
commit7a2318a35d03633708e179573341ba25cfb2f816 (patch)
treeeb9da0f7bd5deef09dcf1bdb0a639c85e9275cfe /sci-geosciences/osm2pgsql
parentsci-geosciences/osm2pgsql: Drop 0.94.0 (diff)
downloadgentoo-7a2318a35d03633708e179573341ba25cfb2f816.tar.gz
gentoo-7a2318a35d03633708e179573341ba25cfb2f816.tar.bz2
gentoo-7a2318a35d03633708e179573341ba25cfb2f816.zip
sci-geosciences/osm2pgsql: Sync live w/ release and back
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-geosciences/osm2pgsql')
-rw-r--r--sci-geosciences/osm2pgsql/osm2pgsql-0.96.0.ebuild4
-rw-r--r--sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild14
2 files changed, 10 insertions, 8 deletions
diff --git a/sci-geosciences/osm2pgsql/osm2pgsql-0.96.0.ebuild b/sci-geosciences/osm2pgsql/osm2pgsql-0.96.0.ebuild
index a6cb7e42a469..e5e751831c5d 100644
--- a/sci-geosciences/osm2pgsql/osm2pgsql-0.96.0.ebuild
+++ b/sci-geosciences/osm2pgsql/osm2pgsql-0.96.0.ebuild
@@ -5,9 +5,9 @@ EAPI=7
inherit cmake flag-o-matic
-DESCRIPTION="Converts OSM data to SQL and insert into PostgreSQL db"
+DESCRIPTION="Converts OSM planet.osm data to a PostgreSQL/PostGIS database"
HOMEPAGE="https://wiki.openstreetmap.org/wiki/Osm2pgsql
- https://github.com/openstreetmap/osm2pgsql"
+ https://github.com/openstreetmap/osm2pgsql"
SRC_URI="https://github.com/openstreetmap/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
diff --git a/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild b/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
index 44e16db48041..78b4534c993e 100644
--- a/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
+++ b/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils git-r3
+inherit cmake flag-o-matic git-r3
EGIT_REPO_URI="https://github.com/openstreetmap/${PN}.git"
DESCRIPTION="Converts OSM planet.osm data to a PostgreSQL/PostGIS database"
-HOMEPAGE="https://wiki.openstreetmap.org/wiki/Osm2pgsql"
+HOMEPAGE="https://wiki.openstreetmap.org/wiki/Osm2pgsql
+ https://github.com/openstreetmap/osm2pgsql"
SRC_URI=""
LICENSE="GPL-2"
@@ -20,7 +21,7 @@ COMMON_DEPEND="
app-arch/bzip2
dev-db/postgresql:=
dev-libs/expat
- sci-libs/proj
+ sci-libs/proj:=
sys-libs/zlib
lua? ( dev-lang/lua:= )
"
@@ -35,9 +36,10 @@ RDEPEND="${COMMON_DEPEND}
RESTRICT="test"
src_configure() {
+ append-cppflags -DACCEPT_USE_OF_DEPRECATED_PROJ_API_H=1
local mycmakeargs=(
-DWITH_LUA=$(usex lua)
-DBUILD_TESTS=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}