summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/gmt/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/gmt/files')
-rw-r--r--sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch62
-rw-r--r--sci-geosciences/gmt/files/gmt-4.5.6-respect-ldflags.patch56
-rw-r--r--sci-geosciences/gmt/files/gmt-4.5.8-bfr-overflow.patch27
-rw-r--r--sci-geosciences/gmt/files/gmt-4.5.8-impl-dec.patch16
-rw-r--r--sci-geosciences/gmt/files/gmt-4.5.9-no-strip.patch38
-rw-r--r--sci-geosciences/gmt/files/gmt-4.5.9-unistd.h.patch19
6 files changed, 218 insertions, 0 deletions
diff --git a/sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch b/sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch
new file mode 100644
index 000000000000..f0fe4c3e833e
--- /dev/null
+++ b/sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch
@@ -0,0 +1,62 @@
+Drop manipulation of several flags:
+
+* stripping of -g from CFLAGS, as it interferes with deliberate
+ generation of debug symbols and breaks on flags like -ggdb.
+* Addition of -s resp. -Wl,-x to LDFLAGS, as stipping of binaries is
+ done as a separate step on Gentoo (and many other distros) in order
+ to faciliate retention or splitting of debug symbols.
+* Setting of optimization flags, as the user should be free to choose
+ them.
+
+2009-07-27 Martin von Gagern
+
+Reference: http://bugs.gentoo.org/279268
+
+Index: GMT4.5.0/configure
+===================================================================
+--- GMT4.5.0.orig/configure
++++ GMT4.5.0/configure
+@@ -10665,19 +10665,6 @@ if test "X$enable_debug" = "Xyes" ; then
+ echo "${ECHO_T}yes" >&6; }
+ CFLAGS="$CFLAGS -g"
+ else
+- CFLAGS=`echo $CFLAGS | sed 's/-g//'`
+- if test "$os" = "Darwin" ; then
+- LDFLAGS="$LDFLAGS -Wl,-x"
+- else
+- LDFLAGS="$LDFLAGS -s"
+- fi
+- if test "$GCC" = "yes" || test "$os" = "Linux" || test "$os" = "AIX"; then
+- CFLAGS="$CFLAGS -O2"
+- elif test "$chip" = "alpha" || test "$os" = "AUX" || test "$os" = "HP-UX"; then
+- CFLAGS="$CFLAGS"
+- else
+- CFLAGS="$CFLAGS -O"
+- fi
+ { echo "$as_me:$LINENO: result: no" >&5
+ echo "${ECHO_T}no" >&6; }
+ fi
+Index: GMT4.5.0/configure.ac
+===================================================================
+--- GMT4.5.0.orig/configure.ac
++++ GMT4.5.0/configure.ac
+@@ -527,19 +527,6 @@ if test "X$enable_debug" = "Xyes" ; then
+ AC_MSG_RESULT(yes)
+ CFLAGS="$CFLAGS -g"
+ else
+- CFLAGS=`echo $CFLAGS | sed 's/-g//'`
+- if test "$os" = "Darwin" ; then
+- LDFLAGS="$LDFLAGS -Wl,-x"
+- else
+- LDFLAGS="$LDFLAGS -s"
+- fi
+- if test "$GCC" = "yes" || test "$os" = "Linux" || test "$os" = "AIX"; then
+- CFLAGS="$CFLAGS -O2"
+- elif test "$chip" = "alpha" || test "$os" = "AUX" || test "$os" = "HP-UX"; then
+- CFLAGS="$CFLAGS"
+- else
+- CFLAGS="$CFLAGS -O"
+- fi
+ AC_MSG_RESULT(no)
+ fi
+ dnl -----------------------------------------------------------------
diff --git a/sci-geosciences/gmt/files/gmt-4.5.6-respect-ldflags.patch b/sci-geosciences/gmt/files/gmt-4.5.6-respect-ldflags.patch
new file mode 100644
index 000000000000..07494380fdfb
--- /dev/null
+++ b/sci-geosciences/gmt/files/gmt-4.5.6-respect-ldflags.patch
@@ -0,0 +1,56 @@
+diff -urN GMT4.5.6/src/Makefile GMT4.5.6.new/src/Makefile
+--- GMT4.5.6/src/Makefile 2011-03-03 22:02:50.000000000 +0100
++++ GMT4.5.6.new/src/Makefile 2011-06-07 14:48:00.969500019 +0200
+@@ -195,13 +195,13 @@
+ $(RANLIB) $@
+
+ libpsl.$(SL): libpsl.a
+- $(LD) $(LD_OPT) pslib.o $(LIBS) -o $@
++ $(LD) $(LD_OPT) $(LDFLAGS) pslib.o $(LIBS) -o $@
+
+ libgmt.$(SL): libgmt.a
+- $(LD) $(LD_OPT) $(LIB_O) $(TRIANGLE_O) $(ALPHA_SINCOS_O) $(NETCDF_LIB) $(GDAL_LIB) $(LIBS) -o $@
++ $(LD) $(LD_OPT) $(LDFLAGS) $(LIB_O) $(TRIANGLE_O) $(ALPHA_SINCOS_O) $(NETCDF_LIB) $(GDAL_LIB) $(LIBS) -o $@
+
+ libgmtps.$(SL): libgmtps.a libgmt.$(SL) libpsl.$(SL)
+- $(LD) $(LD_OPT) $(LIBPS_O) libgmt.$(SL) libpsl.$(SL) $(LIBS) -o $@
++ $(LD) $(LD_OPT) $(LDFLAGS) $(LIBPS_O) libgmt.$(SL) libpsl.$(SL) $(LIBS) -o $@
+
+ #-------------------------------------------------------------------------------
+ # program rules
+diff -urN GMT4.5.6/src/mgd77/Makefile GMT4.5.6.new/src/mgd77/Makefile
+--- GMT4.5.6/src/mgd77/Makefile 2010-11-01 23:39:16.000000000 +0100
++++ GMT4.5.6.new/src/mgd77/Makefile 2011-06-07 14:53:46.394181616 +0200
+@@ -93,7 +93,7 @@
+ $(RANLIB) $@
+
+ libmgd77.$(SL): libmgd77.a
+- $(LD) $(LD_OPT) $(LIB_O) $(GMT_LIB) $(NETCDF_LIB) $(LIBS) -o $@
++ $(LD) $(LD_OPT) $(LDFLAGS) $(LIB_O) $(GMT_LIB) $(NETCDF_LIB) $(LIBS) -o $@
+
+ #-------------------------------------------------------------------------------
+ # program rules
+diff -urN GMT4.5.6/src/mgg/Makefile GMT4.5.6.new/src/mgg/Makefile
+--- GMT4.5.6/src/mgg/Makefile 2010-11-01 23:39:16.000000000 +0100
++++ GMT4.5.6.new/src/mgg/Makefile 2011-06-07 14:54:48.096410233 +0200
+@@ -95,7 +95,7 @@
+ $(RANLIB) $@
+
+ libgmt_mgg.$(SL): libgmt_mgg.a
+- $(LD) $(LD_OPT) $(LIB_O) $(GMT_LIB) $(NETCDF_LIB) $(LIBS) -o $@
++ $(LD) $(LD_OPT) $(LDFLAGS) $(LIB_O) $(GMT_LIB) $(NETCDF_LIB) $(LIBS) -o $@
+
+ #-------------------------------------------------------------------------------
+ # program rules
+diff -urN GMT4.5.6/src/x2sys/Makefile GMT4.5.6.new/src/x2sys/Makefile
+--- GMT4.5.6/src/x2sys/Makefile 2010-11-01 23:39:16.000000000 +0100
++++ GMT4.5.6.new/src/x2sys/Makefile 2011-06-07 14:54:15.124822433 +0200
+@@ -83,7 +83,7 @@
+ $(RANLIB) $@
+
+ libx2sys.$(SL): libx2sys.a
+- $(LD) $(LD_OPT) x2sys.o $(ALLLIB) -o $@
++ $(LD) $(LD_OPT) $(LDFLAGS) x2sys.o $(ALLLIB) -o $@
+
+ #-------------------------------------------------------------------------------
+ # program rules
diff --git a/sci-geosciences/gmt/files/gmt-4.5.8-bfr-overflow.patch b/sci-geosciences/gmt/files/gmt-4.5.8-bfr-overflow.patch
new file mode 100644
index 000000000000..216149d93f78
--- /dev/null
+++ b/sci-geosciences/gmt/files/gmt-4.5.8-bfr-overflow.patch
@@ -0,0 +1,27 @@
+diff --git a/src/mgd77/mgd77.c b/src/mgd77/mgd77.c
+index b27b1d9..6a25576 100644
+--- a/src/mgd77/mgd77.c
++++ b/src/mgd77/mgd77.c
+@@ -854,7 +854,7 @@ int MGD77_Decode_Header_m77t (struct MGD77_HEADER_PARAMS *P, char *record)
+ case 3: strcpy (P->Parameters_Surveyed_Code, word); break;
+ case 4: strncpy (P->File_Creation_Year, word, 4);
+ strncpy (P->File_Creation_Month, &word[4], 2);
+- strncpy (P->File_Creation_Day, &word[6], 4); break;
++ strncpy (P->File_Creation_Day, &word[6], 2); break;
+ case 5: strcpy (P->Source_Institution, word); break;
+ case 6: strcpy (P->Country, word); break;
+ case 7: strcpy (P->Platform_Name, word); break;
+@@ -865,11 +865,11 @@ int MGD77_Decode_Header_m77t (struct MGD77_HEADER_PARAMS *P, char *record)
+ case 12: strcpy (P->Funding, word); break;
+ case 13: strncpy (P->Survey_Departure_Year, word, 4);
+ strncpy (P->Survey_Departure_Month, &word[4], 2);
+- strncpy (P->Survey_Departure_Day, &word[6], 4); break;
++ strncpy (P->Survey_Departure_Day, &word[6], 2); break;
+ case 14: strcpy (P->Port_of_Departure, word); break;
+ case 15: strncpy (P->Survey_Arrival_Year, word, 4);
+ strncpy (P->Survey_Arrival_Month, &word[4], 2);
+- strncpy (P->Survey_Arrival_Day, &word[6], 4); break;
++ strncpy (P->Survey_Arrival_Day, &word[6], 2); break;
+ case 16: strcpy (P->Port_of_Arrival, word); break;
+ case 17: strcpy (P->Navigation_Instrumentation, word); break;
+ case 18: strcpy (P->Geodetic_Datum_Position_Determination_Method, word); break;
diff --git a/sci-geosciences/gmt/files/gmt-4.5.8-impl-dec.patch b/sci-geosciences/gmt/files/gmt-4.5.8-impl-dec.patch
new file mode 100644
index 000000000000..5c63bb209578
--- /dev/null
+++ b/sci-geosciences/gmt/files/gmt-4.5.8-impl-dec.patch
@@ -0,0 +1,16 @@
+diff --git a/src/gmt.h b/src/gmt.h
+index d4c9c20..ea6ddc5 100644
+--- a/src/gmt.h
++++ b/src/gmt.h
+@@ -34,9 +34,11 @@ extern "C" {
+
+ /* GMT is POSIX.1 COMPLIANT */
+
++/*
+ #ifndef _POSIX_SOURCE
+ #define _POSIX_SOURCE 1
+ #endif
++*/
+
+ /* Declaration modifiers for DLL support (MSC et al) */
+ \ No newline at end of file
diff --git a/sci-geosciences/gmt/files/gmt-4.5.9-no-strip.patch b/sci-geosciences/gmt/files/gmt-4.5.9-no-strip.patch
new file mode 100644
index 000000000000..f57f1d811b05
--- /dev/null
+++ b/sci-geosciences/gmt/files/gmt-4.5.9-no-strip.patch
@@ -0,0 +1,38 @@
+Drop manipulation of several flags:
+
+* stripping of -g from CFLAGS, as it interferes with deliberate
+ generation of debug symbols and breaks on flags like -ggdb.
+* Addition of -s resp. -Wl,-x to LDFLAGS, as stipping of binaries is
+ done as a separate step on Gentoo (and many other distros) in order
+ to faciliate retention or splitting of debug symbols.
+* Setting of optimization flags, as the user should be free to choose
+ them.
+
+2009-07-27 Martin von Gagern
+
+Reference: http://bugs.gentoo.org/279268
+
+Index: GMT4.5.0/configure.ac
+===================================================================
+--- GMT4.5.0.orig/configure.ac
++++ GMT4.5.0/configure.ac
+@@ -527,19 +527,6 @@ if test "X$enable_debug" = "Xyes" ; then
+ AC_MSG_RESULT(yes)
+ CFLAGS="$CFLAGS -g"
+ else
+- CFLAGS=`echo $CFLAGS | sed 's/-g//'`
+- if test "$os" = "Darwin" ; then
+- LDFLAGS="$LDFLAGS -Wl,-x"
+- else
+- LDFLAGS="$LDFLAGS -s"
+- fi
+- if test "$GCC" = "yes" || test "$os" = "Linux" || test "$os" = "AIX"; then
+- CFLAGS="$CFLAGS -O2"
+- elif test "$chip" = "alpha" || test "$os" = "AUX" || test "$os" = "HP-UX"; then
+- CFLAGS="$CFLAGS"
+- else
+- CFLAGS="$CFLAGS -O"
+- fi
+ AC_MSG_RESULT(no)
+ fi
+ dnl -----------------------------------------------------------------
diff --git a/sci-geosciences/gmt/files/gmt-4.5.9-unistd.h.patch b/sci-geosciences/gmt/files/gmt-4.5.9-unistd.h.patch
new file mode 100644
index 000000000000..e724b4ceab79
--- /dev/null
+++ b/sci-geosciences/gmt/files/gmt-4.5.9-unistd.h.patch
@@ -0,0 +1,19 @@
+Fix "gmtdigitize.c:77:2: error: unknown type name 'gid_t'"
+build failure; patch from upstream version 4.5.11
+
+https://bugs.gentoo.org/show_bug.cgi?id=543624
+
+--- a/src/misc/gmtdigitize.c
++++ b/src/misc/gmtdigitize.c
+@@ -37,6 +37,11 @@
+ *
+ */
+
++#define _XOPEN_SOURCE
++#ifdef HAVE_UNISTD_H
++#include <unistd.h>
++#endif
++
+ #include "gmt.h"
+
+ #ifndef WIN32