summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2023-08-24 22:16:07 -0700
committerSam James <sam@gentoo.org>2023-09-23 10:50:04 +0100
commit45cf81cd3a19e14df00106ca22ab57948a35a409 (patch)
tree3dd37d66280181a087c50ef5b9b440833066b888 /sci-electronics
parentsci-electronics/kicad: add 7.0.7 (diff)
downloadgentoo-45cf81cd3a19e14df00106ca22ab57948a35a409.tar.gz
gentoo-45cf81cd3a19e14df00106ca22ab57948a35a409.tar.bz2
gentoo-45cf81cd3a19e14df00106ca22ab57948a35a409.zip
sci-electronics/kicad-footprints: add 7.0.7
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad-footprints/Manifest1
-rw-r--r--sci-electronics/kicad-footprints/kicad-footprints-7.0.7.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-electronics/kicad-footprints/Manifest b/sci-electronics/kicad-footprints/Manifest
index 98441c599725..761c4ae7d731 100644
--- a/sci-electronics/kicad-footprints/Manifest
+++ b/sci-electronics/kicad-footprints/Manifest
@@ -1,3 +1,4 @@
DIST kicad-footprints-7.0.1.tar.bz2 23942389 BLAKE2B 06408aaf1a388287dc0929f8f99e70bcab62051da1a4674f48ea264a75fd5780fe355420dafe96fd8548679c508a3860bdc0ba8ef287a3c7b3c6c78c0fdc2975 SHA512 1bc7ffdf089414c40e74a2b8c155e83900d406f46036d0803f115e505e25f7071111acc5bc85456de4c96af26d8a13ca81bd28dca5dfe48e26e5944f4478a688
DIST kicad-footprints-7.0.2.tar.bz2 23956893 BLAKE2B dd86bea1ad8d61eec3d755ac29b13f94a0037cd99455843cd8d711f655be98ed3fda5e4620302d05ccc1a95910f83f0a4ce1465b9e8e5e69baab8306229709ba SHA512 ad49198a72747ce892eb2a58393fd4bd57dbc4c95d0ffb02ab8318d61f0693077203d97a81fd62cb98435de3928e827b90a67c7d5b00018ae80abd6034512e31
DIST kicad-footprints-7.0.6.tar.bz2 24045275 BLAKE2B 7efb3e5b256f94ac657283d2a0bd19b8e6eb5ae65ed31d6e4aa64a8a37423392e6c890ed0231b2d81f9b223241873ee07cf2c9935d042d167e340b43c7ce55ef SHA512 16eb37e5c26b940c46193a36bc93f0debbabb13bfeb07d1cdb56a8221f1a1f6167ebc16fecdbcfdf0f258f1a1cffc06864126ffbc337dd736b15b70d024d1bc8
+DIST kicad-footprints-7.0.7.tar.bz2 24411508 BLAKE2B 1abedfbc3dfab302b5f929b01f2a83e83a4fee6b1d5056bf2c3579068c56807c656dea918f4c37fe030b727d3effbc35063f4f4103c4cfa6071f95c22d507597 SHA512 8af1fb371034bd5b22e0a8a896fa61e4eb0bda5b282759e17872bf4b466f49b39aa56ae068ac3d7d5a7453d9a7d511a81317d3f267a90d2764b2b8282f64aef0
diff --git a/sci-electronics/kicad-footprints/kicad-footprints-7.0.7.ebuild b/sci-electronics/kicad-footprints/kicad-footprints-7.0.7.ebuild
new file mode 100644
index 000000000000..ba02cb94ca78
--- /dev/null
+++ b/sci-electronics/kicad-footprints/kicad-footprints-7.0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Electronic Schematic and PCB design tools footprint libraries"
+HOMEPAGE="https://gitlab.com/kicad/libraries/kicad-footprints"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/kicad/libraries/kicad-footprints.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.com/kicad/libraries/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=sci-electronics/kicad-7.0.0"
+
+if [[ ${PV} == 9999 ]] ; then
+# x11-misc-util/macros only required on live ebuilds
+ BDEPEND+=" >=x11-misc/util-macros-1.18"
+fi