summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/solve-resolve-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/solve-resolve-bin')
-rw-r--r--sci-chemistry/solve-resolve-bin/Manifest2
-rw-r--r--sci-chemistry/solve-resolve-bin/metadata.xml8
-rw-r--r--sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild68
3 files changed, 78 insertions, 0 deletions
diff --git a/sci-chemistry/solve-resolve-bin/Manifest b/sci-chemistry/solve-resolve-bin/Manifest
new file mode 100644
index 000000000000..0d3b66530d29
--- /dev/null
+++ b/sci-chemistry/solve-resolve-bin/Manifest
@@ -0,0 +1,2 @@
+DIST solve-2.13-linux-64.tar.gz 74444830 SHA256 e03250bb550686fc6e5f59d4e885b83b88cd342dfb4975eb31ddf95d9515650e SHA512 8f20715c3fb73940f03ba8a4bb3528f89ba01520cacead001796609bc15259ab7ab7f2d4960ea97efc43029863bc31e630c9e93f528a233652928220dafe0b4d WHIRLPOOL 125efe76024148656f3bb357ad1bc78d17f51eb8268c83241f4da9a94356170d0259fe48fadf6bf1ffe4b10b57bb27ed79199063dc95d0eef8d9e22de653c84a
+DIST solve-2.13-linux.tar.gz 71902534 SHA256 975466fe92d8f6256de20ea0b5101876f3e5a7e3093199946c9f4824236c79d3
diff --git a/sci-chemistry/solve-resolve-bin/metadata.xml b/sci-chemistry/solve-resolve-bin/metadata.xml
new file mode 100644
index 000000000000..ae9ec7c5f6a4
--- /dev/null
+++ b/sci-chemistry/solve-resolve-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild b/sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild
new file mode 100644
index 000000000000..6deae178afdd
--- /dev/null
+++ b/sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Automated crystallographic structure solution for MIR, SAD, and MAD"
+HOMEPAGE="http://www.solve.lanl.gov/index.html"
+SRC_URI="
+ x86? ( https://solve.lanl.gov/pub/solve/${PV}/solve-${PV}-linux.tar.gz )
+ amd64? ( https://solve.lanl.gov/pub/solve/${PV}/solve-${PV}-linux-64.tar.gz )"
+
+SLOT="0"
+LICENSE="solve"
+KEYWORDS="-* x86 amd64"
+IUSE="examples"
+
+RDEPEND="sci-libs/ccp4-libs"
+DEPEND=""
+
+RESTRICT="mirror"
+
+S="${WORKDIR}"/solve-${PV}
+
+QA_PREBUILT="opt/solve-resolve/bin/*"
+
+src_install(){
+ local IN_PATH="/opt/solve-resolve/"
+
+ exeinto ${IN_PATH}bin/
+ doexe bin/*
+
+ insinto ${IN_PATH}lib/
+ doins -r lib/{*sym,sym*,hist*,*dat,segments,patterns}
+
+ docinto html
+ dodoc -r lib/html/*
+
+ sed \
+ -e 's:/usr/local/lib/solve/:${EPREFIX}/opt/solve-resolve/lib/:' \
+ -i lib/examples_solve/p9/solve* || die
+ if use examples; then
+ sed \
+ -e 's:/usr/local/lib/resolve/:${EPREFIX}/opt/solve-resolve/lib/:' \
+ -i lib/examples_resolve/{resolve.csh,prime_and_switch.csh} || die
+ insinto /usr/share/${PF}/
+ doins -r lib/examples_*solve
+ fi
+
+ cat >> "${T}"/20solve-resolve <<- EOF
+ CCP4_OPEN="UNKNOWN"
+ SYMOP="${EPREFIX}/usr/share/ccp4/data/symop.lib"
+ SYMINFO="${EPREFIX}/usr/share/ccp4/data/syminfo.lib"
+ SOLVEDIR="${EPREFIX}/${IN_PATH}lib/"
+ PATH="${EPREFIX}/${IN_PATH}bin"
+ EOF
+
+ doenvd "${T}"/20solve-resolve
+}
+
+pkg_postinst(){
+ einfo "Get a valid license key from"
+ einfo "http://solve.lanl.gov/license.html"
+ einfo "and place it in"
+ einfo "${EPREFIX}${IN_PATH}lib/"
+}