summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-calculators/galculator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-calculators/galculator')
-rw-r--r--sci-calculators/galculator/Manifest2
-rw-r--r--sci-calculators/galculator/galculator-2.1.2.ebuild28
-rw-r--r--sci-calculators/galculator/galculator-2.1.3.ebuild31
-rw-r--r--sci-calculators/galculator/metadata.xml8
4 files changed, 69 insertions, 0 deletions
diff --git a/sci-calculators/galculator/Manifest b/sci-calculators/galculator/Manifest
new file mode 100644
index 000000000000..424ef14336d9
--- /dev/null
+++ b/sci-calculators/galculator/Manifest
@@ -0,0 +1,2 @@
+DIST galculator-2.1.2.tar.bz2 427684 SHA256 23e7e8d02ec49bf06e061e7fa56c779fd0f353ec294c30fd88858786d8e4a79b SHA512 e327ca9e6845a3022b4a2bcdaccf68c60d569f839f5cc3706886ff952fbac369f4022887ed4d5b39d6631c67f9de895db4cae4b0f39a681ef9b29747228d81b1 WHIRLPOOL 255a159841ad0bd523fd6933d4b8f3a27cbe14f4465c9db19d68046dd4eed2b1eddeb596795a5782c2114b36f093ab2f51afbd5356b931b50689debb4e88ec48
+DIST galculator-2.1.3.tar.bz2 466288 SHA256 91ac62d6d74da910cb79c68f7bf3f4505ac0efe51091150c4ea54fe1c1306235 SHA512 782b5a672fa40bab01dc39fb32e79e8da08993bace6c37768db2ca11a2bb996fdc07e773a0f70b7bba73c018de6ea6e3f71afc3885ccbc94d345fef62cdfa74a WHIRLPOOL 188c80101d41e93b6ddfaf4c65aadcb65c5639e4cf0c2cd75dba77f7dd4d405164ce0fb5af48c7a5599de7574e06e39d047d42424454310555500f304bd3daf2
diff --git a/sci-calculators/galculator/galculator-2.1.2.ebuild b/sci-calculators/galculator/galculator-2.1.2.ebuild
new file mode 100644
index 000000000000..5646bc0537d8
--- /dev/null
+++ b/sci-calculators/galculator/galculator-2.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG=no
+
+inherit gnome2
+
+DESCRIPTION="GTK+ based algebraic and RPN calculator"
+HOMEPAGE="http://galculator.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ppc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:3
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/flex
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS doc/shortcuts"
diff --git a/sci-calculators/galculator/galculator-2.1.3.ebuild b/sci-calculators/galculator/galculator-2.1.3.ebuild
new file mode 100644
index 000000000000..68439a669a31
--- /dev/null
+++ b/sci-calculators/galculator/galculator-2.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG=no
+
+inherit gnome2
+
+DESCRIPTION="GTK+ based algebraic and RPN calculator"
+HOMEPAGE="http://galculator.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ppc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/flex
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS doc/shortcuts"
diff --git a/sci-calculators/galculator/metadata.xml b/sci-calculators/galculator/metadata.xml
new file mode 100644
index 000000000000..2ad6e98df1b7
--- /dev/null
+++ b/sci-calculators/galculator/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <upstream>
+ <remote-id type="sourceforge">galculator</remote-id>
+ </upstream>
+</pkgmetadata>