summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/tree-puzzle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/tree-puzzle')
-rw-r--r--sci-biology/tree-puzzle/Manifest1
-rw-r--r--sci-biology/tree-puzzle/files/tree-puzzle-impl-dec.patch14
-rw-r--r--sci-biology/tree-puzzle/metadata.xml25
-rw-r--r--sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild57
4 files changed, 97 insertions, 0 deletions
diff --git a/sci-biology/tree-puzzle/Manifest b/sci-biology/tree-puzzle/Manifest
new file mode 100644
index 000000000000..4b855c8b51b8
--- /dev/null
+++ b/sci-biology/tree-puzzle/Manifest
@@ -0,0 +1 @@
+DIST tree-puzzle-5.2.tar.gz 875142 SHA256 3396d3b80b03b0600afb479dc33f0bd3e5631298337295a4fa454211ac44c3fb SHA512 5b9a729b120cba59f59ba426acd439cf396826ea01e75361b23387ccb9baf295d2512f21af96071a5f7b7507db4ff4d6b135cf6c5b6233a8b438532d31abe751 WHIRLPOOL 145afdfc266809638d7b049beb65cdfc8fb6c108ecba831ba36fae938d58edd141fdf1762d9ce86269f0098043e7314b0ddefaa5e7f9b11cc6fd56a480b54d61
diff --git a/sci-biology/tree-puzzle/files/tree-puzzle-impl-dec.patch b/sci-biology/tree-puzzle/files/tree-puzzle-impl-dec.patch
new file mode 100644
index 000000000000..93b960f5c2b4
--- /dev/null
+++ b/sci-biology/tree-puzzle/files/tree-puzzle-impl-dec.patch
@@ -0,0 +1,14 @@
+ src/sprng/primes-lcg64.c | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/src/sprng/primes-lcg64.c b/src/sprng/primes-lcg64.c
+index 8e5a7c9..fb04373 100644
+--- a/src/sprng/primes-lcg64.c
++++ b/src/sprng/primes-lcg64.c
+@@ -1,5 +1,6 @@
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include "primes-lcg64.h"
+ #include "primelist-lcg64.h"
+
diff --git a/sci-biology/tree-puzzle/metadata.xml b/sci-biology/tree-puzzle/metadata.xml
new file mode 100644
index 000000000000..cbdeede346fa
--- /dev/null
+++ b/sci-biology/tree-puzzle/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription>
+ TREE-PUZZLE is a computer program to reconstruct phylogenetic trees
+ from molecular sequence data by maximum likelihood. It implements a
+ fast tree search algorithm, quartet puzzling, that allows analysis of
+ large data sets and automatically assigns estimations of support to
+ each internal branch. TREE-PUZZLE also computes pairwise maximum
+ likelihood distances as well as branch lengths for user specified
+ trees. Branch lengths can be calculated under the clock-assumption. In
+ addition, TREE-PUZZLE offers a novel method, likelihood mapping, to
+ investigate the support of a hypothesized internal branch without
+ computing an overall tree and to visualize the phylogenetic content of
+ a sequence alignment. TREE-PUZZLE also conducts a number of statistical
+ tests on the data set (chi-square test for homogeneity of base
+ composition, likelihood ratio clock test, Kishino-Hasegawa test). The
+ models of substitution provided by TREE-PUZZLE are TN, HKY, F84, SH for
+ nucleotides, Dayhoff, JTT, mtREV24, VT, WAG, BLOSUM 62 for amino acids,
+ and F81 for two-state data. Rate heterogeneity is modeled by a discrete
+ Gamma distribution and by allowing invariable sites. The corresponding
+ parameters can be inferred from the data set.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
new file mode 100644
index 000000000000..fd2b06f1d159
--- /dev/null
+++ b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data"
+HOMEPAGE="http://www.tree-puzzle.de"
+SRC_URI="http://www.tree-puzzle.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="mpi"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+pkg_setup () {
+ use mpi && [ $(tc-getCC) = icc ] && die "The parallelized version of tree-puzzle cannot be compiled using icc.
+ Either disable the \"mpi\" USE flag to compile only the non-parallelized
+ version of the program, or use gcc as your compiler (CC=\"gcc\")."
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-impl-dec.patch
+}
+
+src_configure() {
+ default
+
+ if ! use mpi; then
+ sed \
+ -e 's:bin_PROGRAMS = puzzle$(EXEEXT) ppuzzle:bin_PROGRAMS = puzzle :' \
+ -e 's:DIST_SOURCES = $(ppuzzle_SOURCES) $(puzzle_SOURCES):DIST_SOURCES = $(puzzle_SOURCES):' \
+ -i "${S}"/src/Makefile || die
+ fi
+}
+
+src_install() {
+ dobin src/puzzle
+ use mpi && dobin src/ppuzzle
+ dodoc AUTHORS ChangeLog README
+
+ # User manual
+ insinto /usr/share/doc/${PF}
+ doins doc/tree-puzzle.pdf
+
+ # Example data files
+ insinto /usr/share/${PN}/data
+ rm data/Makefile*
+ doins data/*
+}