summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/exonerate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/exonerate')
-rw-r--r--sci-biology/exonerate/Manifest1
-rw-r--r--sci-biology/exonerate/exonerate-2.2.0-r1.ebuild50
-rw-r--r--sci-biology/exonerate/files/exonerate-2.2.0-asneeded.patch15
-rw-r--r--sci-biology/exonerate/metadata.xml15
4 files changed, 81 insertions, 0 deletions
diff --git a/sci-biology/exonerate/Manifest b/sci-biology/exonerate/Manifest
new file mode 100644
index 000000000000..3619350ee4d0
--- /dev/null
+++ b/sci-biology/exonerate/Manifest
@@ -0,0 +1 @@
+DIST exonerate-2.2.0.tar.gz 509870 SHA256 0ea2720b1388fa329f889522f43029b416ae311f57b229129a65e779616fe5ff SHA512 c0aec4df83fbf6bcd1b27242397349769211ab88d71e2d081e20cb5453a03acd805807535a69841e991cf543d99fcd458cbd22d60b21f0fc6ce813eac45b838c WHIRLPOOL dd7ba7a94b93f41d5ddbc66cc14740973dde20e875f37814229614c85312dcc1de031faab5153bc28be3284144d0f8451bd5e5115f8d9e312e4f88d771ce620c
diff --git a/sci-biology/exonerate/exonerate-2.2.0-r1.ebuild b/sci-biology/exonerate/exonerate-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..966f7c2f8e01
--- /dev/null
+++ b/sci-biology/exonerate/exonerate-2.2.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils toolchain-funcs
+
+DESCRIPTION="Generic tool for pairwise sequence comparison"
+HOMEPAGE="http://www.ebi.ac.uk/~guy/exonerate/"
+SRC_URI="http://www.ebi.ac.uk/~guy/exonerate/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+IUSE="utils test threads"
+
+REQUIRED_USE="test? ( utils )"
+
+DEPEND="dev-libs/glib:2"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}"/${P}-asneeded.patch )
+
+src_prepare() {
+ tc-export CC
+ sed \
+ -e 's: -O3 -finline-functions::g' \
+ -i configure.in || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable utils utilities)
+ $(use_enable threads pthreads)
+ --enable-largefile
+ --enable-glib2
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ doman doc/man/man1/*.1
+}
diff --git a/sci-biology/exonerate/files/exonerate-2.2.0-asneeded.patch b/sci-biology/exonerate/files/exonerate-2.2.0-asneeded.patch
new file mode 100644
index 000000000000..3268055cd544
--- /dev/null
+++ b/sci-biology/exonerate/files/exonerate-2.2.0-asneeded.patch
@@ -0,0 +1,15 @@
+Fix build with --as-needed
+
+https://bugs.gentoo.org/268094
+
+--- configure.in
++++ configure.in
+@@ -289,7 +289,7 @@
+ if test "$enable_pthreads" = yes; then
+ echo "Using PTHREADS"
+ CFLAGS="$CFLAGS -DUSE_PTHREADS"
+- LDFLAGS="$LDFLAGS -lpthread"
++ LIBS="$LIBS -lpthread"
+ elif test "$enable_pthreads" = no; then
+ echo "Not using pthreads"
+ else
diff --git a/sci-biology/exonerate/metadata.xml b/sci-biology/exonerate/metadata.xml
new file mode 100644
index 000000000000..711d805d77e7
--- /dev/null
+++ b/sci-biology/exonerate/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <maintainer>
+ <email>je_fro@gentoo.org</email>
+ <name>Jeff Gardner</name>
+ </maintainer>
+ <longdescription lang="en">
+ exonerate is a generic tool for pairwise sequence comparison
+ </longdescription>
+ <use>
+ <flag name="utils">Install all utilities</flag>
+ </use>
+</pkgmetadata>