summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2024-01-03 14:30:18 -0500
committerRick Farina <zerochaos@gentoo.org>2024-01-03 14:31:56 -0500
commit3719f5cfec4ca504373c4c5eb8a2175defeb872a (patch)
tree15dc8469fa33ed73ca9f6a8cf17fbcd51cd4b97c /net-wireless
parentnet-wireless/gr-osmosdr: drop 0.2.4 (diff)
downloadgentoo-3719f5cfec4ca504373c4c5eb8a2175defeb872a.tar.gz
gentoo-3719f5cfec4ca504373c4c5eb8a2175defeb872a.tar.bz2
gentoo-3719f5cfec4ca504373c4c5eb8a2175defeb872a.zip
net-wireless/gr-osmosdr: rm foot gun USE=python
USE=python controls the gnuradio-companion source and sink blocks, disabling it causes a super bad user experience. Additionally the use flag doesn't even control the deps properly so this never saved anyone much. Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/gr-osmosdr/gr-osmosdr-0.2.5-r1.ebuild (renamed from net-wireless/gr-osmosdr/gr-osmosdr-0.2.5.ebuild)15
-rw-r--r--net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild15
2 files changed, 12 insertions, 18 deletions
diff --git a/net-wireless/gr-osmosdr/gr-osmosdr-0.2.5.ebuild b/net-wireless/gr-osmosdr/gr-osmosdr-0.2.5-r1.ebuild
index 9ff0faaaba65..459a7b7e0e51 100644
--- a/net-wireless/gr-osmosdr/gr-osmosdr-0.2.5.ebuild
+++ b/net-wireless/gr-osmosdr/gr-osmosdr-0.2.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,7 +23,7 @@ fi
LICENSE="GPL-3"
SLOT="0/${PV}"
-IUSE="airspy bladerf doc hackrf iqbalance python rtlsdr sdrplay soapy uhd xtrx"
+IUSE="airspy bladerf doc hackrf iqbalance rtlsdr sdrplay soapy uhd xtrx"
RDEPEND="${PYTHON_DEPS}
dev-libs/boost:=
@@ -62,7 +62,7 @@ src_configure() {
-DENABLE_BLADERF="$(usex bladerf ON OFF)"
-DENABLE_HACKRF="$(usex hackrf ON OFF)"
-DENABLE_IQBALANCE="$(usex iqbalance ON OFF)"
- -DENABLE_PYTHON="$(usex python ON OFF)"
+ -DENABLE_PYTHON=ON
-DENABLE_RTL="$(usex rtlsdr ON OFF)"
-DENABLE_RTL_TCP="$(usex rtlsdr ON OFF)"
-DENABLE_SDRPLAY="$(usex sdrplay ON OFF)"
@@ -78,10 +78,7 @@ src_configure() {
src_install() {
cmake_src_install
- if use python; then
- find "${ED}" -name '*.py[oc]' -delete || die
- python_fix_shebang "${ED}"/usr/bin
- python_optimize
- fi
- mv "${ED}/usr/share/doc/${PN}" "${ED}/usr/share/doc/${P}"
+ find "${ED}" -name '*.py[oc]' -delete || die
+ python_fix_shebang "${ED}"/usr/bin
+ python_optimize
}
diff --git a/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild b/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild
index 9ff0faaaba65..459a7b7e0e51 100644
--- a/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild
+++ b/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,7 +23,7 @@ fi
LICENSE="GPL-3"
SLOT="0/${PV}"
-IUSE="airspy bladerf doc hackrf iqbalance python rtlsdr sdrplay soapy uhd xtrx"
+IUSE="airspy bladerf doc hackrf iqbalance rtlsdr sdrplay soapy uhd xtrx"
RDEPEND="${PYTHON_DEPS}
dev-libs/boost:=
@@ -62,7 +62,7 @@ src_configure() {
-DENABLE_BLADERF="$(usex bladerf ON OFF)"
-DENABLE_HACKRF="$(usex hackrf ON OFF)"
-DENABLE_IQBALANCE="$(usex iqbalance ON OFF)"
- -DENABLE_PYTHON="$(usex python ON OFF)"
+ -DENABLE_PYTHON=ON
-DENABLE_RTL="$(usex rtlsdr ON OFF)"
-DENABLE_RTL_TCP="$(usex rtlsdr ON OFF)"
-DENABLE_SDRPLAY="$(usex sdrplay ON OFF)"
@@ -78,10 +78,7 @@ src_configure() {
src_install() {
cmake_src_install
- if use python; then
- find "${ED}" -name '*.py[oc]' -delete || die
- python_fix_shebang "${ED}"/usr/bin
- python_optimize
- fi
- mv "${ED}/usr/share/doc/${PN}" "${ED}/usr/share/doc/${P}"
+ find "${ED}" -name '*.py[oc]' -delete || die
+ python_fix_shebang "${ED}"/usr/bin
+ python_optimize
}