summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/wireless-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/wireless-tools')
-rw-r--r--net-wireless/wireless-tools/Manifest1
-rw-r--r--net-wireless/wireless-tools/files/wireless-tools-29-asneeded.patch13
-rw-r--r--net-wireless/wireless-tools/metadata.xml17
-rw-r--r--net-wireless/wireless-tools/wireless-tools-30_pre9.ebuild62
4 files changed, 93 insertions, 0 deletions
diff --git a/net-wireless/wireless-tools/Manifest b/net-wireless/wireless-tools/Manifest
new file mode 100644
index 000000000000..dec07191e717
--- /dev/null
+++ b/net-wireless/wireless-tools/Manifest
@@ -0,0 +1 @@
+DIST wireless_tools.30.pre9.tar.gz 348477 SHA256 abd9c5c98abf1fdd11892ac2f8a56737544fe101e1be27c6241a564948f34c63 SHA512 0561923bca075af4754d21e1be303cbd1ce3558cb6481c9c12bc7d330a353acf8ad81a822488570e859480287999c3bb2a698c993556a92f0699743e0a527ff1 WHIRLPOOL e4c1d0d2484b6336ece81019e6cc035103da22c82bab0473401af5c9c75d5a55af7e0eef5fbcbc0700077e09a92f21555862a706bce56b37a235b687775bcf5a
diff --git a/net-wireless/wireless-tools/files/wireless-tools-29-asneeded.patch b/net-wireless/wireless-tools/files/wireless-tools-29-asneeded.patch
new file mode 100644
index 000000000000..04f2d869b6d2
--- /dev/null
+++ b/net-wireless/wireless-tools/files/wireless-tools-29-asneeded.patch
@@ -0,0 +1,13 @@
+Index: wireless_tools.29/Makefile
+===================================================================
+--- wireless_tools.29.orig/Makefile
++++ wireless_tools.29/Makefile
+@@ -145,7 +145,7 @@ wireless.h:
+
+ # Compilation of the dynamic library
+ $(DYNAMIC): $(OBJS:.o=.so)
+- $(CC) -shared -o $@ -Wl,-soname,$@ $(STRIPFLAGS) $(LIBS) -lc $^
++ $(CC) $(LDFLAGS) -shared -o $@ -Wl,-soname,$@ $(STRIPFLAGS) $^ $(LIBS) -lc
+
+ # Compilation of the static library
+ $(STATIC): $(OBJS:.o=.so)
diff --git a/net-wireless/wireless-tools/metadata.xml b/net-wireless/wireless-tools/metadata.xml
new file mode 100644
index 000000000000..338d98ef1d4b
--- /dev/null
+++ b/net-wireless/wireless-tools/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package provides all the command line tools for configuring
+ wireless networking devices with drivers that implement the Linux
+ Wireless Extensions (almost all recent IEEE 802.11a/b/g drivers).
+ </longdescription>
+ <use>
+ <flag name='multicall'>Build the most commonly used tools as one
+ binary</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-wireless/wireless-tools/wireless-tools-30_pre9.ebuild b/net-wireless/wireless-tools/wireless-tools-30_pre9.ebuild
new file mode 100644
index 000000000000..a9f979661aaa
--- /dev/null
+++ b/net-wireless/wireless-tools/wireless-tools-30_pre9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs multilib eutils
+
+# The following works with both pre-releases and releases
+MY_P=${PN/-/_}.${PV/_/.}
+S="${WORKDIR}/${MY_P/\.pre*/}"
+
+DESCRIPTION="A collection of tools to configure IEEE 802.11 wireless LAN cards"
+HOMEPAGE="http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html"
+SRC_URI="http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sh ~sparc x86"
+IUSE="linguas_cs linguas_fr multicall"
+
+DEPEND="sys-apps/sed"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-29-asneeded.patch
+
+ sed -i \
+ -e "s:^\(CC\) = gcc:\1 = $(tc-getCC):" \
+ -e "s:^\(AR\) = ar:\1 = $(tc-getAR):" \
+ -e "s:^\(RANLIB\) = ranlib:\1 = $(tc-getRANLIB):" \
+ -e "s:^\(CFLAGS=-Os\):#\1:" \
+ -e "s:\(@\$(LDCONFIG).*\):#\1:" \
+ -e "s:^\(INSTALL_MAN= \$(PREFIX)\)/man:\1/usr/share/man:" \
+ -e "s:^\(INSTALL_LIB= \$(PREFIX)\)/lib:\1/$(get_libdir)/:" \
+ -e "s:^\(INSTALL_INC= \$(PREFIX)\)/include:\1/usr/include:" \
+ -e "s:^\(BUILD_STATIC = y\):#\1:" \
+ -e '/\$(CC)/s:-Wl,-s\>::' \
+ "${S}"/Makefile || die
+}
+
+src_compile() {
+ emake
+
+ use multicall && emake iwmulticall
+}
+
+src_install() {
+ emake PREFIX="${ED}" install
+
+ if use multicall; then
+ # 'make install-iwmulticall' will overwrite some of the tools
+ # with symlinks - this is intentional (brix)
+ emake PREFIX="${ED}" install-iwmulticall
+ fi
+
+ has cs ${LINGUAS} || rm -rf "${ED}"/usr/share/man/cs
+ has fr ${LINGUAS} || rm -rf "${ED}"/usr/share/man/fr.{ISO8859-1,UTF-8}
+
+ dodoc CHANGELOG.h HOTPLUG-UDEV.txt IFRENAME-VS-XXX.txt PCMCIA.txt README
+ has fr ${LINGUAS} && dodoc README.fr
+}