summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgentoo-setan <gentoo-setan@protonmail.com>2024-05-31 21:19:02 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-06-07 16:15:06 +0300
commit5a5e29269e93b520856cb5978448088ab3450976 (patch)
tree987f6df44e5354cc530e7dfeed909cc60b15c013 /net-p2p
parentgui-apps/wmenu: add 9999 (diff)
downloadgentoo-5a5e29269e93b520856cb5978448088ab3450976.tar.gz
gentoo-5a5e29269e93b520856cb5978448088ab3450976.tar.bz2
gentoo-5a5e29269e93b520856cb5978448088ab3450976.zip
net-p2p/nicotine+: update to 3.3.4, add GTK4 support and optfeatures
Also removed a Python dependency dropped by upstream. Big thanks to Parona! Signed-off-by: gentoo-setan <gentoo-setan@protonmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine+/Manifest1
-rw-r--r--net-p2p/nicotine+/nicotine+-3.3.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-p2p/nicotine+/Manifest b/net-p2p/nicotine+/Manifest
index 662641e950a2..a36e2fd2c735 100644
--- a/net-p2p/nicotine+/Manifest
+++ b/net-p2p/nicotine+/Manifest
@@ -1,2 +1,3 @@
DIST nicotine+-3.2.8.tar.gz 2984416 BLAKE2B 8ca996e67a296535a158d1929579c4f479630bf4b666b53e91939fd61dcac90de657bfccd30521da9cc4468f3beecf1be433790ca711c67d0cf6d1e0a901be90 SHA512 92298b97ce34d713b0a4626602757a9215b57a0c3ac00c2845ff66597f0a361243f47c8abf3e8548f9f8c1829e56eb036e202242340bf268bf008b6ad6d016a5
DIST nicotine+-3.2.9.tar.gz 2985424 BLAKE2B 1768d9f13ee15593661997ac0ad49c6c2d3aead685f83b86ae0ca05615f5fda04ea3abd3137a595d8457ef9643c4fd77adb47a76417b90d6c876bf55c56c4b31 SHA512 bc828bf8e6b194b23df8c7cce900704b918b71669ff9e0cf17b2c954838e265cc074dcb54e0abbcf563b19f10cf3199cc1980771b57e0af613ef2eed2ee4a3a8
+DIST nicotine+-3.3.4.tar.gz 3838006 BLAKE2B 09660558a1f07a4393cf272ef532c5fb15f1653008e73ec796c8bd16a177bdcb03c55fb3743d8d8e573ce9db2ac42d7fa0d92544a433007179ce00733c5a2381 SHA512 5dab8a1fe718cfd6b0a3e4645e025f42ccc4c86031f65741a3cbfb67e8abfb82cefeb7fc93f5037b9d5f5972ac034cc3ef5a2bac7ae9744533edc894e6e93ef4
diff --git a/net-p2p/nicotine+/nicotine+-3.3.4.ebuild b/net-p2p/nicotine+/nicotine+-3.3.4.ebuild
new file mode 100644
index 000000000000..4fc1a765a7f4
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-3.3.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 optfeature xdg
+
+DESCRIPTION="Graphical client for the Soulseek peer to peer network written in Python"
+HOMEPAGE="https://nicotine-plus.org/"
+SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/nicotine-plus-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# NOTE: good link - https://github.com/nicotine-plus/nicotine-plus/blob/master/doc/DEPENDENCIES.md
+BDEPEND="sys-devel/gettext" # TODO(setan): maybe add pycodestyle and pylint here if use test
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ || ( >=gui-libs/gtk-4.6.9[introspection] >=x11-libs/gtk+-3.22.20:3[introspection] )
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.md NEWS.md README.md TRANSLATORS.md )
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "Nicotine can work with both gtk3+ and gtk4."
+ elog "The newer version is preferred but it has worse screen reader support"
+ elog "If you need it you can switch to gtk3+ by running nicotine"
+ elog "with an environmental variable like this:"
+ elog " $ NICOTINE_GTK_VERSION=3 nicotine"
+
+ optfeature "Adwaita theme on GNOME (GTK 4)" gui-libs/libadwaita
+ optfeature "Chat spellchecking (GTK 3)" app-text/gspell
+}