summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Lunev <cheembox573@gmail.com>2023-10-16 23:29:57 +0300
committerFlorian Schmaus <flow@gentoo.org>2023-10-19 15:17:04 +0200
commit73ce9e854e0ec71abf11e90aeac0354fa7f6473d (patch)
tree1ccf35b049f214fd96586c72eaf201eeba414017 /net-p2p/qbittorrent/qbittorrent-9999.ebuild
parentacct-user/qbittorrent: new package, add 0 (diff)
downloadgentoo-73ce9e854e0ec71abf11e90aeac0354fa7f6473d.tar.gz
gentoo-73ce9e854e0ec71abf11e90aeac0354fa7f6473d.tar.bz2
gentoo-73ce9e854e0ec71abf11e90aeac0354fa7f6473d.zip
net-p2p/qbittorrent: bump to 4.5.5, add openrc service & qt6
Closes: https://bugs.gentoo.org/914197 Closes: https://github.com/gentoo/gentoo/pull/33365 Signed-off-by: Alexey Lunev <cheembox573@gmail.com> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-9999.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index eeba63e2c817..9ff0a380b472 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,7 +19,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+dbus +gui qt6 test webui"
+IUSE="+dbus +gui qt6 test webui systemd"
RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( gui webui )"
@@ -47,7 +47,9 @@ RDEPEND="
dev-qt/qtnetwork:5[ssl]
dev-qt/qtsql:5[sqlite]
dev-qt/qtxml:5
- )"
+ )
+ acct-group/qbittorrent
+ acct-user/qbittorrent"
DEPEND="
${RDEPEND}
dev-libs/boost
@@ -98,6 +100,9 @@ src_configure() {
mycmakeargs+=(
-DGUI=OFF
-DDBUS=OFF
+ )
+
+ use systemd && mycmakeargs+=(
# The systemd service calls qbittorrent-nox, which is only
# installed when GUI=OFF.
-DSYSTEMD=ON
@@ -127,4 +132,7 @@ src_test() {
src_install() {
multibuild_foreach_variant cmake_src_install
einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
}