summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2018-11-25 15:05:56 +0100
committerThomas Sachau <tommy@gentoo.org>2018-11-25 15:07:33 +0100
commita2a356041423c1d13e7ab8f350c6af9b99a39fc4 (patch)
tree9586fb1d10de155b89b7dac0fe58958972644e7f /net-p2p/fms
parentapp-editors/emacs-vcs: 26.1.90 snapshot from upstream. (diff)
downloadgentoo-a2a356041423c1d13e7ab8f350c6af9b99a39fc4.tar.gz
gentoo-a2a356041423c1d13e7ab8f350c6af9b99a39fc4.tar.bz2
gentoo-a2a356041423c1d13e7ab8f350c6af9b99a39fc4.zip
net-p2p/fms: Version bump, EAPI bump
Bug: https://bugs.gentoo.org/605540 Package-Manager: Portage-2.3.48, Repoman-2.3.12 RepoMan-Options: --force Signed-off-by: Thomas Sachau <tommy@gentoo.org>
Diffstat (limited to 'net-p2p/fms')
-rw-r--r--net-p2p/fms/Manifest1
-rw-r--r--net-p2p/fms/files/fms3
-rw-r--r--net-p2p/fms/files/fms-use-system-libs4.patch40
-rw-r--r--net-p2p/fms/fms-0.3.80.ebuild76
-rw-r--r--net-p2p/fms/metadata.xml3
5 files changed, 121 insertions, 2 deletions
diff --git a/net-p2p/fms/Manifest b/net-p2p/fms/Manifest
index f717d08dc018..472d84ae559f 100644
--- a/net-p2p/fms/Manifest
+++ b/net-p2p/fms/Manifest
@@ -1 +1,2 @@
DIST fms-src-0.3.79.zip 3847775 BLAKE2B e6087ef6e0e22f79e3d399f08ed531e839faf8199bdb3d0c0e148553dd6b7cab9dd35dbc74081a628d4456fadc4f9dd83a7a767f1dab8ac511f94eac1685d2ee SHA512 aa9f505c5ef55b1f462b16de6d870d02dc102fd184cc353c6c6b8a346978a9953b34e878f262f4190a3d15d76c5a37f065c4e5ebdbc0e43a4a5c22d61fa9fba7
+DIST fms-src-0.3.80.zip 4583891 BLAKE2B 363fe148c622d999398d2f435f49e312d3bea22ad6b69865a618593616b47b632c1a56bcc8fc75bd40590e3858aad7e3f1d70991a21936e38562e10f1813b49c SHA512 d3aa5eb7d417bb135d88a515702fac9c451054d071374bb7f475add9af7e1fda90f4d9c61569e3e9040b2a241efa7fcc7ecac32a7f652327d15ed8d1ea1418c4
diff --git a/net-p2p/fms/files/fms b/net-p2p/fms/files/fms
index 07f1a0551637..d98f3b29e4a8 100644
--- a/net-p2p/fms/files/fms
+++ b/net-p2p/fms/files/fms
@@ -1,6 +1,7 @@
#!/sbin/openrc-run
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/files/fms,v 1.4 2010/03/31 19:19:27 tommy Exp $
# Check for OpenRC/Baselayout 2 - see bug #270646
is_openrc() {
diff --git a/net-p2p/fms/files/fms-use-system-libs4.patch b/net-p2p/fms/files/fms-use-system-libs4.patch
new file mode 100644
index 000000000000..fc017ce0023b
--- /dev/null
+++ b/net-p2p/fms/files/fms-use-system-libs4.patch
@@ -0,0 +1,40 @@
+--- /CMakeLists.txt 2016-06-04 22:18:20.000000000 +0200
++++ /CMakeLists.txt.new 2018-11-25 14:05:45.000000000 +0100
+@@ -373,11 +373,17 @@
+ ENDIF(AUDIO_CAPTCHA)
+
+ IF(FROST_SUPPORT OR FCP_SSL_SUPPORT)
+- ADD_SUBDIRECTORY(libs/mbedtls)
+- TARGET_LINK_LIBRARIES(fms mbedtls)
+- TARGET_LINK_LIBRARIES(fms mbedcrypto)
+- TARGET_LINK_LIBRARIES(fms mbedx509)
+- INCLUDE_DIRECTORIES(libs/mbedtls/include)
++ FIND_LIBRARY(MBEDTLS_LIBRARY NAMES mbedtls )
++ FIND_LIBRARY(MBEDCRYPTO_LIBRARY NAMES mbedcrypto mbedx509)
++ FIND_LIBRARY(MBEDX509_LIBRARY NAMES mbedx509)
++
++ IF(MBEDTLS_LIBRARY)
++ TARGET_LINK_LIBRARIES(fms ${MBEDTLS_LIBRARY})
++ TARGET_LINK_LIBRARIES(fms ${MBEDCRYPTO_LIBRARY})
++ TARGET_LINK_LIBRARIES(fms ${MBEDX509_LIBRARY})
++ ELSE(MBEDTLS_LIBRARY)
++ MESSAGE(FATAL ERROR: "Could not find mbedtls library.")
++ ENDIF(MBEDTLS_LIBRARY)
+
+ IF(FROST_SUPPORT)
+ ADD_DEFINITIONS(-DFROST_SUPPORT)
+@@ -405,3 +411,14 @@
+ IF(BUILD_PLUGIN)
+ ADD_SUBDIRECTORY(plugin)
+ ENDIF(BUILD_PLUGIN)
++
++MESSAGE(STATUS "<<< Gentoo configuration >>>
++Build type ${CMAKE_BUILD_TYPE}
++Install path ${CMAKE_INSTALL_PREFIX}
++Compiler flags:
++C ${CMAKE_C_FLAGS}
++C++ ${CMAKE_CXX_FLAGS}
++Linker flags:
++Executable ${CMAKE_EXE_LINKER_FLAGS}
++Module ${CMAKE_MODULE_LINKER_FLAGS}
++Shared ${CMAKE_SHARED_LINKER_FLAGS}\n")
diff --git a/net-p2p/fms/fms-0.3.80.ebuild b/net-p2p/fms/fms-0.3.80.ebuild
new file mode 100644
index 000000000000..1b85e8e83668
--- /dev/null
+++ b/net-p2p/fms/fms-0.3.80.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils cmake-utils user
+
+DESCRIPTION="A spam-resistant message board application for Freenet"
+HOMEPAGE="http://freenetproject.org/tools.html"
+SRC_URI="mirror://gentoo/${PN}-src-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="frost ssl"
+
+RDEPEND="virtual/libiconv
+ frost? ( net-libs/mbedtls )
+ ssl? ( net-libs/mbedtls )
+ >=dev-libs/poco-1.4.3_p1
+ >=dev-db/sqlite-3.6.15"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+PATCHES=( "${FILESDIR}"/${PN}-use-system-libs4.patch )
+
+pkg_setup() {
+ enewgroup freenet
+ enewuser freenet -1 -1 /var/freenet freenet
+}
+
+src_prepare() {
+ rm -rv libs
+ edos2unix src/http/pages/showfilepage.cpp
+ edos2unix CMakeLists.txt
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=( -DI_HAVE_READ_THE_README=ON \
+ -DUSE_BUNDLED_SQLITE=OFF \
+ -DDO_CHARSET_CONVERSION=ON \
+ -DFROST_SUPPORT=$(use frost && echo ON || echo OFF) \
+ -DFCP_SSL_SUPPORT=$(use ssl && echo ON || echo OFF) )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ insinto /var/freenet/fms
+ dobin "${CMAKE_BUILD_DIR}"/fms || die
+ doins *.htm || die "doinstall failed"
+ doins -r fonts images styles translations || die
+ fperms -R o-rwx /var/freenet/fms/ /usr/bin/fms
+ fowners -R freenet:freenet /var/freenet/fms/ /usr/bin/fms
+ doinitd "${FILESDIR}/fms" || die "installing init.d file failed"
+ dodoc readme.txt || die "installing doc failed"
+}
+
+pkg_postinst() {
+ if ! has_version 'net-p2p/freenet' ; then
+ ewarn "FMS needs a freenet node to up-/download #ssages."
+ ewarn "Please make sure to have a node you can connect to"
+ ewarn "or install net-p2p/freenet to get FMS working."
+ fi
+ elog "By default, the FMS NNTP server will listen on port 1119,"
+ elog "and the web configuration interface will be running at"
+ elog "http://localhost:8080. For more information, read"
+ elog "${ROOT}usr/share/doc/${PF}/readme.txt.bz2"
+ if use frost; then
+ elog " "
+ elog "You need to enable frost on the config page"
+ elog "and restart fms for frost support."
+ fi
+}
diff --git a/net-p2p/fms/metadata.xml b/net-p2p/fms/metadata.xml
index 2f2a55f2853b..225e63002744 100644
--- a/net-p2p/fms/metadata.xml
+++ b/net-p2p/fms/metadata.xml
@@ -6,6 +6,7 @@
<name>Thomas Sachau (Tommy[D])</name>
</maintainer>
<use>
- <flag name="frost">Add support for frost boards</flag>
+ <flag name='frost'>Add support for frost boards</flag>
+ <flag name="ssl">Add support for FCP connection over SSL</flag>
</use>
</pkgmetadata>