summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-news/rawdog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-news/rawdog')
-rw-r--r--net-news/rawdog/Manifest2
-rw-r--r--net-news/rawdog/metadata.xml12
-rw-r--r--net-news/rawdog/rawdog-2.19.ebuild27
-rw-r--r--net-news/rawdog/rawdog-2.20.ebuild27
4 files changed, 68 insertions, 0 deletions
diff --git a/net-news/rawdog/Manifest b/net-news/rawdog/Manifest
new file mode 100644
index 000000000000..04e4f855c858
--- /dev/null
+++ b/net-news/rawdog/Manifest
@@ -0,0 +1,2 @@
+DIST rawdog-2.19.tar.gz 66231 SHA256 fea40f673c334f8b0f21cac8c1498ae2130b7c2c79670c5d166bd5634e5313db SHA512 4e2ebf51feb98a0ce994218e6f057268846ed3194626877b5bd0b71971b5e79f1482af8dece29dc6be0a2e04728333b4814a73469b60c0970a323177511a5ae6 WHIRLPOOL 4635121c848660c54a10fde5045d3a810189b9e8b5486c03d7a99d99bcc44c1f9684f0d6f0fe18e9c3358c9d652c117b3c6eda11432ccc3a61d0e49aeb0aa5fb
+DIST rawdog-2.20.tar.gz 66933 SHA256 0a63b26cc111b0deca441f498177b49be0330760c5c0e24584cdb9ba1e7fd5a6 SHA512 83a023f4256cd49242769deef7eaee7ad40f6e61fe97885dd2b311f3e3c9c8a87338a06b1e08a634496bb939d6574795027405decf361f38727efd73dd2ba96b WHIRLPOOL 0582b05560ee18dfef115141f408c3e90b458b506cbb801cd984fba8ba2dc1c95c20d2d60a07137322f61e3e63226e3df4d906554957a1d1ec77c3d4be69161b
diff --git a/net-news/rawdog/metadata.xml b/net-news/rawdog/metadata.xml
new file mode 100644
index 000000000000..f2ed6f38b1fe
--- /dev/null
+++ b/net-news/rawdog/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription>
+rawdog is an RSS Aggregator Without Delusions Of Grandeur. Written in Python,
+it uses Mark Pilgrim's feed parser. It runs from cron, collects articles from
+a number of feeds, and generates a static HTML page listing the newest articles
+in date order. It supports per-feed customizable update times, and uses ETags,
+Last-Modified, and gzip compression to minimize network bandwidth usage.
+</longdescription>
+</pkgmetadata>
diff --git a/net-news/rawdog/rawdog-2.19.ebuild b/net-news/rawdog/rawdog-2.19.ebuild
new file mode 100644
index 000000000000..76b81fb7aa18
--- /dev/null
+++ b/net-news/rawdog/rawdog-2.19.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Rawdog - RSS Aggregator Without Delusions Of Grandeur"
+HOMEPAGE="http://offog.org/code/rawdog.html http://pypi.python.org/pypi/rawdog"
+SRC_URI="http://offog.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ~s390 sparc x86"
+IUSE=""
+
+DEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+RDEPEND=""
+# Test run fails under multi threading
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+python_test() {
+ # pypy fails half way through; meh
+ ./test-rawdog || die "Test run aborted"
+}
diff --git a/net-news/rawdog/rawdog-2.20.ebuild b/net-news/rawdog/rawdog-2.20.ebuild
new file mode 100644
index 000000000000..a47c33e6ae39
--- /dev/null
+++ b/net-news/rawdog/rawdog-2.20.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Rawdog - RSS Aggregator Without Delusions Of Grandeur"
+HOMEPAGE="http://offog.org/code/rawdog.html http://pypi.python.org/pypi/rawdog"
+SRC_URI="http://offog.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+RDEPEND=""
+# Test run fails under multi threading
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+python_test() {
+ # pypy fails half way through; meh
+ ./test-rawdog || die "Test run aborted"
+}