summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-08 13:40:46 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-08 14:05:39 +0200
commit64ae622b0d58fee542822aaef476cf3522838bad (patch)
treebf9ef281aae3702efb4c9eb910070967469c963b /net-misc
parentdev-lang/nim: fix compile - copy sat subproject for atlas (diff)
downloadgentoo-64ae622b0d58fee542822aaef476cf3522838bad.tar.gz
gentoo-64ae622b0d58fee542822aaef476cf3522838bad.tar.bz2
gentoo-64ae622b0d58fee542822aaef476cf3522838bad.zip
net-misc/gallery-dl: bump to 1.27.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.27.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index adc50ce5e1a4..0375284ff3a1 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1 +1,2 @@
DIST gallery-dl-1.27.1.gh.tar.gz 686087 BLAKE2B c80f37d314671637f435957abf9d79d01d421e48c89e90a3290e6fbf6e32f89d4b7495deeaf2ce0528750b65d4b404108fe78bc42f0e39dda4bcfd4267aa9dff SHA512 d3243bd23e7a743d98b9745d78b653546a49a97dd8468b60014fa6ba74071de8057c8b479dc3d74854b4c194034b027fe15bc530a60dea34dcc6221b105c285c
+DIST gallery-dl-1.27.2.gh.tar.gz 698780 BLAKE2B 38b2506f46aa4fc03cc36844c8517dfb706b0da81de3bc33f303b87982dedf617b5e91f9e6e539874b8993f5c435114a4fdc0a11047312c3ece0132c076a3acb SHA512 f8510bfff48e75297a46b10f82f6f8457bd88e21fe79ed702fa165095ca649c07caa1c161b3350f3148837063e1fb5d780da00437f91a58efa68da02cfb05171
diff --git a/net-misc/gallery-dl/gallery-dl-1.27.2.ebuild b/net-misc/gallery-dl/gallery-dl-1.27.2.ebuild
new file mode 100644
index 000000000000..fea34fbde450
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.27.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Tests against real servers, some tests always fail and some are subject to change.
+ rm test/test_results.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile_all() {
+ emake PYTHON="${EPYTHON}" data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}