summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-15 10:25:18 +0100
committerSam James <sam@gentoo.org>2023-09-15 10:25:18 +0100
commit4cbefaa399931045a800c6973faf37955a15fdbc (patch)
tree0238256dee6edd1e2b9fe932d8598c49b50b7939 /net-misc
parentprofiles/arch/powerpc/ppc64: stable-mask pipewire[echo-cancel] (diff)
downloadgentoo-4cbefaa399931045a800c6973faf37955a15fdbc.tar.gz
gentoo-4cbefaa399931045a800c6973faf37955a15fdbc.tar.bz2
gentoo-4cbefaa399931045a800c6973faf37955a15fdbc.zip
net-misc/streamlink: add 6.2.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/streamlink-6.2.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 2ee8a870d41b..ca09e7efe540 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,3 +1,4 @@
DIST streamlink-5.5.1.tar.gz 536064 BLAKE2B 0a651c5dcf9fe0a70ee93505ad0a0ea6aaf10739edc763a796633ce34b8235e4aa6a5a45bd1f6dd2591ced9cd87141d4b89d34e9e399d6166d74c9c3ee12f5ea SHA512 2d7fd75bbf356baaf91791930e74e361b37abf0ff1251fa3022ca216dc16a8610635089cb746506baec82c31f8bc569e3b8e538b17ba910389168e61dcdbbe0f
DIST streamlink-6.0.1.tar.gz 682425 BLAKE2B a84c6c1594b78b62c1c20c021c3dde2eae06e86fad559de285800cb5f1cc2d97dadb5724053b320dafdbca3545e1d10171d1adc3b8a1c9c67d2e4d80940357dc SHA512 96081a23b616d85a0918583d951334f35843cb47d6d3d317c3903516b951db2a953db1ea2cb1fb3de95cb059a37dc605d40817e81819acf4e5c98f831bd39323
DIST streamlink-6.1.0.tar.gz 686463 BLAKE2B cc2890db0181e47bcae9da38eddeaadfd34b29a3d4b8bc2bb4d296289cdb356f9614d4e1edd8b11e23d226115f645399296d5589e42832ad473d9cb96ebfde0f SHA512 24fb549be6088eb913348ae892f694b91a6d6c929a06b9ed0db050e203a020ea9780b217f96d7890b7309d304e9a547c47673b8b3f2588dfedbaa44bb5808e29
+DIST streamlink-6.2.0.tar.gz 690986 BLAKE2B 5f7cab73ea366580aeb837b8f8a27fa7cd5ca687afa53908900dc9f290a0da916778fda8351acda00f795688b156ca0f37302e67128ce30e9838a45111b88ecd SHA512 2747ebc584caa8ebb2fde5d4f309c911a52fd1a8d2d0e832487e589873c270534e0d0b18120a2db7a68e150e301e57db1e8d63f1d5bb6244f364e9cbd6606213
diff --git a/net-misc/streamlink/streamlink-6.2.0.ebuild b/net-misc/streamlink/streamlink-6.2.0.ebuild
new file mode 100644
index 000000000000..5cdf6fa7ab19
--- /dev/null
+++ b/net-misc/streamlink/streamlink-6.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.2.1[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ ${DEPEND}
+ media-video/ffmpeg
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+distutils_enable_tests pytest