summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-01-29 11:47:37 -0600
committerBen Kohler <bkohler@gentoo.org>2020-01-29 11:48:06 -0600
commit782156e886fb0d76fa2831b36ec0c7f48f6278a4 (patch)
treeebb4f51b675d2615a2a548d85f41542ad61eace4 /net-misc/wput/wput-0.6.2.ebuild
parentnet-libs/libupnp: 1.12.0: Fix C++ compat (diff)
downloadgentoo-782156e886fb0d76fa2831b36ec0c7f48f6278a4.tar.gz
gentoo-782156e886fb0d76fa2831b36ec0c7f48f6278a4.tar.bz2
gentoo-782156e886fb0d76fa2831b36ec0c7f48f6278a4.zip
net-misc/wput: bump to 0.6.2 w/ crash fix
Closes: https://bugs.gentoo.org/647848 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc/wput/wput-0.6.2.ebuild')
-rw-r--r--net-misc/wput/wput-0.6.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/wput/wput-0.6.2.ebuild b/net-misc/wput/wput-0.6.2.ebuild
new file mode 100644
index 000000000000..c95956b3e7b1
--- /dev/null
+++ b/net-misc/wput/wput-0.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tiny program like wget, to upload files/whole directories via FTP"
+HOMEPAGE="http://wput.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug nls ssl"
+
+RDEPEND="ssl? ( net-libs/gnutls )"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.2-respect-destdir.patch"
+ "${FILESDIR}/${PN}-0.6-respectldflags.patch"
+ "${FILESDIR}/${PN}-fix-crash.patch"
+)
+
+DOCS=( ChangeLog INSTALL TODO )
+
+src_configure() {
+ local myconf="--enable-g-switch=no"
+ use debug && myconf="--enable-memdbg=yes"
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl) \
+ "${myconf}"
+}