summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-01-29 14:02:08 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2019-01-29 14:02:19 +0100
commit314daf2f1ee5933326ebe0dde344d10e11501d1d (patch)
tree17a79568a8fd87cca8d9da0cf0d6049a8ab011e7 /net-misc/rdesktop
parentdev-perl/Term-ReadLine-Gnu: mark s390 stable (diff)
downloadgentoo-314daf2f1ee5933326ebe0dde344d10e11501d1d.tar.gz
gentoo-314daf2f1ee5933326ebe0dde344d10e11501d1d.tar.bz2
gentoo-314daf2f1ee5933326ebe0dde344d10e11501d1d.zip
net-misc/rdesktop: restore libressl fix
It was lost in the 1.8.4 bump Closes: https://bugs.gentoo.org/664202 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc/rdesktop')
-rw-r--r--net-misc/rdesktop/files/rdesktop-1.8.4-libressl.patch16
-rw-r--r--net-misc/rdesktop/rdesktop-1.8.4-r1.ebuild70
2 files changed, 86 insertions, 0 deletions
diff --git a/net-misc/rdesktop/files/rdesktop-1.8.4-libressl.patch b/net-misc/rdesktop/files/rdesktop-1.8.4-libressl.patch
new file mode 100644
index 000000000000..b56cbfc30539
--- /dev/null
+++ b/net-misc/rdesktop/files/rdesktop-1.8.4-libressl.patch
@@ -0,0 +1,16 @@
+diff --git a/ssl.c b/ssl.c
+index 07d7aa5..45df34f 100644
+--- a/ssl.c
++++ b/ssl.c
+@@ -225,7 +225,7 @@ rdssl_rkey_get_exp_mod(RDSSL_RKEY * rkey, uint8 * exponent, uint32 max_exp_len,
+ BIGNUM *e = NULL;
+ BIGNUM *n = NULL;
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if (OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER))
+ e = rkey->e;
+ n = rkey->n;
+ #else
+--
+2.20.1
+
diff --git a/net-misc/rdesktop/rdesktop-1.8.4-r1.ebuild b/net-misc/rdesktop/rdesktop-1.8.4-r1.ebuild
new file mode 100644
index 000000000000..d0abef7c4ac9
--- /dev/null
+++ b/net-misc/rdesktop/rdesktop-1.8.4-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools eutils
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="A Remote Desktop Protocol Client"
+HOMEPAGE="http://www.rdesktop.org/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="alsa ao debug ipv6 kerberos libressl libsamplerate oss pcsc-lite xrandr"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ alsa? ( media-libs/alsa-lib )
+ ao? ( >=media-libs/libao-0.8.6 )
+ kerberos? ( net-libs/libgssglue )
+ libsamplerate? ( media-libs/libsamplerate )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.6.6 )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}
+ x11-libs/libXt"
+BDEPEND=virtual/pkgconfig
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-sound_configure.patch
+ "${FILESDIR}"/${PN}-1.8.3-no_strip.patch
+ "${FILESDIR}"/${PN}-1.8.3-xrandr_configure.patch
+ "${FILESDIR}"/${P}-libressl.patch
+)
+
+DOCS=( doc/HACKING doc/TODO doc/keymapping.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if use ao; then
+ sound_conf=$(use_with ao sound libao)
+ else if use alsa; then
+ sound_conf=$(use_with alsa sound alsa)
+ else
+ sound_conf=$(use_with oss sound oss)
+ fi
+ fi
+
+ econf \
+ --with-openssl="${EPREFIX}"/usr \
+ $(use_with debug) \
+ $(use_with ipv6) \
+ $(use_with libsamplerate) \
+ $(use_with xrandr) \
+ $(use_enable kerberos credssp) \
+ $(use_enable pcsc-lite smartcard) \
+ ${sound_conf}
+}