summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/linux-identd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/linux-identd')
-rw-r--r--net-misc/linux-identd/Manifest1
-rw-r--r--net-misc/linux-identd/files/identd.init21
-rw-r--r--net-misc/linux-identd/files/identd.xinetd9
-rw-r--r--net-misc/linux-identd/linux-identd-1.3-r1.ebuild36
-rw-r--r--net-misc/linux-identd/metadata.xml8
5 files changed, 75 insertions, 0 deletions
diff --git a/net-misc/linux-identd/Manifest b/net-misc/linux-identd/Manifest
new file mode 100644
index 000000000000..a34daaee2d6a
--- /dev/null
+++ b/net-misc/linux-identd/Manifest
@@ -0,0 +1 @@
+DIST linux-identd-1.3.tar.gz 16719 SHA256 3d82fcf7202f5cd8d92ddcb71c7098f9f76fc81679dcf3076dde82bed12a04fd SHA512 3f533933da0d3be42713ee3ab18a31c72c19434363635b3a996ad1a0b7516eb3a2127f181b4c584a19671ae4e270ab6248a2c975b6e8ae26817990bee3c3bab4 WHIRLPOOL b9745d555668f6b5bb088fd6cfd6595932b5b690349e82a94d5ca54f52572dd2e90610845838a743d17f3a22f55d477853b59867fb3a72d3eb75b0a642a89e0a
diff --git a/net-misc/linux-identd/files/identd.init b/net-misc/linux-identd/files/identd.init
new file mode 100644
index 000000000000..d5ffc5d1a391
--- /dev/null
+++ b/net-misc/linux-identd/files/identd.init
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting identd"
+ start-stop-daemon --start --quiet --name identd \
+ --startas /usr/sbin/identd -- -d
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping identd"
+ start-stop-daemon --stop --quiet --name identd
+ eend $?
+}
diff --git a/net-misc/linux-identd/files/identd.xinetd b/net-misc/linux-identd/files/identd.xinetd
new file mode 100644
index 000000000000..a51d49b2019a
--- /dev/null
+++ b/net-misc/linux-identd/files/identd.xinetd
@@ -0,0 +1,9 @@
+service ident
+{
+ disable = no
+ socket_type = stream
+ wait = no
+ user = nobody
+ protocol = tcp
+ server = /usr/sbin/in.identd
+}
diff --git a/net-misc/linux-identd/linux-identd-1.3-r1.ebuild b/net-misc/linux-identd/linux-identd-1.3-r1.ebuild
new file mode 100644
index 000000000000..d6607ef5fb23
--- /dev/null
+++ b/net-misc/linux-identd/linux-identd-1.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="A real IDENT daemon for linux"
+HOMEPAGE="http://www.fukt.bsnet.se/~per/identd/"
+SRC_URI="http://www.fukt.bsnet.se/~per/identd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ~mips ppc sparc x86"
+IUSE="xinetd"
+
+DEPEND=""
+RDEPEND="xinetd? ( sys-apps/xinetd )"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CEXTRAS="${CFLAGS}"
+}
+
+src_install() {
+ dodir /etc/init.d /usr/sbin /usr/share/man/man8
+ dodoc README ChangeLog
+ emake install DESTDIR="${D}" MANDIR=/usr/share/man
+
+ if use xinetd; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/identd.xinetd identd
+ else
+ newinitd "${FILESDIR}"/identd.init identd
+ fi
+}
diff --git a/net-misc/linux-identd/metadata.xml b/net-misc/linux-identd/metadata.xml
new file mode 100644
index 000000000000..f9d50da18d39
--- /dev/null
+++ b/net-misc/linux-identd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <description>This package lacks a primary herd or maintainer.</description>
+ </maintainer>
+</pkgmetadata>