summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter-Levine <plevine457@gmail.com>2017-05-08 00:25:55 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-08 07:53:07 +0200
commitbde91cad9f1ffa8b0c3454945ac1d30403ef8c70 (patch)
tree3c3abac2222ad85b9c1e1c3406b1199d4e852100 /net-misc/knutclient
parentdev-ruby/patron: cleanup (diff)
downloadgentoo-bde91cad9f1ffa8b0c3454945ac1d30403ef8c70.tar.gz
gentoo-bde91cad9f1ffa8b0c3454945ac1d30403ef8c70.tar.bz2
gentoo-bde91cad9f1ffa8b0c3454945ac1d30403ef8c70.zip
net-misc/knutclient: Fix building with GCC-6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=612936 Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4565
Diffstat (limited to 'net-misc/knutclient')
-rw-r--r--net-misc/knutclient/files/knutclient-1.0.5-gcc6.patch18
-rw-r--r--net-misc/knutclient/knutclient-1.0.5.ebuild8
2 files changed, 24 insertions, 2 deletions
diff --git a/net-misc/knutclient/files/knutclient-1.0.5-gcc6.patch b/net-misc/knutclient/files/knutclient-1.0.5-gcc6.patch
new file mode 100644
index 000000000000..f52f6b4b089e
--- /dev/null
+++ b/net-misc/knutclient/files/knutclient-1.0.5-gcc6.patch
@@ -0,0 +1,18 @@
+Forwarded: no
+Description: Fix the build with gcc 6
+Author: Adrian Bunk <bunk@stusta.de>
+Bug-Debian: https://bugs.debian.org/811882
+
+--- a/src/knutprefdlg.cpp
++++ b/src/knutprefdlg.cpp
+@@ -957,9 +957,9 @@
+
+ QHBoxLayout *setFontLayout = new QHBoxLayout();
+ QStringList fontsList;
+ KFontChooser::getFontList(fontsList, KFontChooser::SmoothScalableFonts);
+- m_fontWidget = new KFontChooser(mainPageWidget, false, fontsList);
++ m_fontWidget = new KFontChooser(mainPageWidget, KFontChooser::NoDisplayFlags, fontsList);
+ setFontLayout->addWidget (m_fontWidget ,0);
+ topLayout->addLayout(setFontLayout);
+
+ topLayout->addStretch( 20 );
diff --git a/net-misc/knutclient/knutclient-1.0.5.ebuild b/net-misc/knutclient/knutclient-1.0.5.ebuild
index c367772a3bd8..3bdb40011a4b 100644
--- a/net-misc/knutclient/knutclient-1.0.5.ebuild
+++ b/net-misc/knutclient/knutclient-1.0.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -17,7 +17,11 @@ SLOT="4"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
-PATCHES=( "${FILESDIR}/${P}-desktop.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-desktop.patch"
+ "${FILESDIR}/${P}-gcc6.patch"
+)
+
DOCS=( ChangeLog )
S=${WORKDIR}/${MY_P}